Problems sharing drives and folders

I have a windows network (wireless) on which I primarily use my desktop pc which has 2 IDE internal drives 2 IDE external drives and one internal SATA drive. I want to be able to access all these drives remotely from my laptop and so I set them up to share on the network but although I can see them from the laptop I get an error message telling me i dont have permission to view them.  This is odd because I can see all the shared folders on my two internal IDE drives ok.  Also when I attach a portable drive to my laptop and share it I can read this on my desktop.
Thinking the problem might be related to the XP Home edition on my laptop, I upgraded it to XP Pro but it makes no difference. I have also tried creating folders on the drives and sharing those as well but although I can see them it wont let me open them.  I dont know what to try next
gbswalesAsked:
Who is Participating?
 
Fatal_ExceptionConnect With a Mentor Commented:
Thanks, James..  :)

Here is how I have my home network setup:

Internet <-->  Router (outside address is static, inside address Default Gateway is Class C 192.168.1.1)  <-->  AP (connected to router on the WAN port with outside static address of 192.168.1.2, inside addresses in the 192.168.2.x ranges )  <-->  Wireless computers connecting with the Class C 192.168.2.x addresses via DHCP)

and don't forget the basics for setting up P2P networking...

1)  If you are running XP Pro, then turn off Simple File Sharing
2)  Setup all machines with IDENTICAL user credentials, including username AND passwords
3)  Make sure you have File and Printer Sharing enabled in the TCP Properties
4)  Share your folders and make sure you give appropriate SHARE permissions
5)  On the Security Tab (available when Simple File Sharing is off with XP Pro, or on an XP Home system accessed by the Admin Account in Safe Mode), give the appropriate NTFS permissions.
6)  Access the remote computer using the Run Line or a batch file:  Start > Run > \\computername (or IPAddress)\sharename
7)  Oh, and don't forget the Firewall!  Make exceptions, or turn it off!
0
 
SysExpertConnect With a Mentor Commented:
1) Create new shares, do not use the default shares.

2) urn on the Guest account

3) Make sure  you are using eh same login for both machines.

I hope this helps !

0
 
SysExpertConnect With a Mentor Commented:
also see


http://www.experts-exchange.com/Operating_Systems/WinXP/Q_20786932.html


Make sure NETbios over TCP is on and firewall is off.

I hope this helps !
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
Jay_Jay70Connect With a Mentor Commented:
still the best P2P resource around!
0
 
Fatal_ExceptionConnect With a Mentor Commented:
Thankyou James.. wait until we start anwswering these questions for Vista!  so much more to know!
0
 
gbswalesAuthor Commented:
Thanks for all your answers - I missed the obvious though that I needed to have passwords set for my login - I had taken them off to allow my partner easy access!!!
0
 
Fatal_ExceptionCommented:
:)   That would do it!

and thank you...

FE
0
 
Jay_Jay70Commented:
oh yes, Vista is going to get messy my friend
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.