ODBC Error connecting to DSN that points to resource on another machine on the network: [ODBC Visual Foxpro Driver]Cannot open file

I'm using IIS 6 on windows 2003 web edition (that is not in a domain), connecting to a foxpro database that is on a Windows 2003 std server (that is in a domain, but not a DC).   The php code that connects via odbc works fine as long as the database in question is local ( I copied to a local folder and tested on another DSN). As a test I moved the web edition server into the domain, and changed the anonymous user that the website is run as to a newly created user within the domain... this works, however the web server is intended to be internet facing and I would like to have it as separate from the network as possible and not have the machine in the local domain.

Anyone know of another way of fixing this or accomplishing the same goal?

Thanks.
LVL 1
techeezAsked:
Who is Participating?
 
AndresMConnect With a Mentor Commented:
Well, I'am not sure, but I think php impersonates by default. In that case, if your site is anonymous, by default it will run under IUSR_MACHINENAME account.

I think one option would be create a local user on the server that has the share, with same name (IUSR_MACHINENAME) and same password than the webserver's IUSR, and see what happens.

If php doesn't impersonate, the site will run under the context of the account configured in the IIS application pool, in this case, you should create this same account in the server that has the share.

This solution is not optimal. An optimal solution would be a database residing in for instance SQL Server, in this case SQL will listen on a TCP port, so you have several options to establish a connection.

Hope this helps.
0
 
AndresMCommented:
ASP or ASP.NET? The foxpro database is in a network share, right?
0
 
techeezAuthor Commented:
Php... The foxpro database is in a folder in an existing network share.
0
 
techeezAuthor Commented:
Hi AndresM,

Thanks... The site is anonymous...I did add the IUSR_MACHINENAME account to the server that the database is coming from and it allowed me to connect... The problem with that is that I had to add the IIS server to the Domain in order to get that account to match. Now that I've said that... I didn't actually try it without moving the server into the domain first.  I'm going to try that now, I'll let you know how it works.

You are correct though, this isn't the optimal solution either way.  Unfortunately the main application that uses the databases that I'm trying to connect to in the first place is written in Visual Foxpro and would require a lot of work to use SQL in the backend :(
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.