Oracle exp / imp -- error: IMP-00017 - IMP-00003 - ORA-00959

When I do an exp of our ORACLE data, then try to imp it as a different user on a different tablespace... I get this error... how can I fix this?? And it only happens on like 3-4 of the 50 tables....


IMP-00017: following statement failed with ORACLE error 959:
 "CREATE TABLE.... (TABLESPACE "ta" ENABLE STORAGE IN ..."
IMP-00003: ORACLE error 959 encountered
ORA-00959: tablespace 'ta' does not exist
LVL 1
JoshWegenerAsked:
Who is Participating?
 
anand_2000vConnect With a Mentor Commented:
then precreate the tables and import with ignore=y option
0
 
Mark GeerlingsDatabase AdministratorCommented:
Does the tablespace "ta" exist in the database where you run import?  If not, create it first.  If yes, does the import user have a space quota in the tablespace that allows tables to be created there?
0
 
ramumorlaCommented:
You should create all table spaces that are existing in the source database.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
JoshWegenerAuthor Commented:
Is there any way to get around this?

Some times we load the same data into 3-4 different users (same server) table spaces
0
 
JoshWegenerAuthor Commented:
Is there a way I can just export the tables / data in different dumps? ( and the creat tables not be depended on the tablespace )
0
 
ramumorlaCommented:
No....
0
 
ramumorlaCommented:
OOPS! Yes you can export tables alone.. Or tables and data - But whats the use?
0
 
JoshWegenerAuthor Commented:
Well, the question is, how can I import the data into a different tablespace with/out any errors
0
 
anand_2000vCommented:
use toad or anyother tool. in Toad you can select an object and right click and select the option "create in another schema". and then you can import the data using ignore=y
0
 
Mark GeerlingsDatabase AdministratorCommented:
Import always tries to create the tables in the same tablespace that export found them in.  If you want them imported into a different tablespace, you need to first create the tablespace(s) then create the empty table(s) there, then run import with "ignore=Y" so it will use the table names in the tablespace(s) you want them in.

You can use import to help you with this.  If you run import first with "rows=n" and "indexfile=[a valid path and filename in your system]" then import will just write the SQL commands that it wants run to this "indexfile".  Just open that with a text editor, change the tablespace names (or whatever else you want to change) then run that script from SQL*Plus or TOAD before you import the data.
0
 
JoshWegenerAuthor Commented:
If I try and edit the DMP file... I get this error ...

IMP-00010: not a valid export file, header failed verification
IMP-00000: Import terminated unsuccessfully
0
 
Mark GeerlingsDatabase AdministratorCommented:
Don't try to edit the *.dmp file.  Run import with "rows=n" and "indexfile=C:\temp\sql_file.txt" (if your server O/S is Windows).  Then open the file C:\temp\sql_file.txt and edit that.
0
 
JoshWegenerAuthor Commented:
I just found the problem... only tables with a column that have a type of "BLOB" give an error
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.