MX record issue local web server external mail server

I am running a local web server and exchange server.  I use exchange to relay mail for whatever purpose.  my mail servers however are hosted offsite.  

my problem is I can not relay mail from my local exchange server to any address with my hosted domain name.  so...

blah@mydomain.com will not relay internally if I use my exchange server.    

currently I've the DNS records setup as such:

(A) mail.mydomain.com = ip of offsite mail server

(MX) mail.mydomain.com priority 10.

using my local dns server when I do an nslookup type mx on mydomain.com it comes up with the external mail server address... but I still can't get it to work.  
LVL 1
ictinusAsked:
Who is Participating?
 
SembeeCommented:
If the external domain is listed in your recipient policy then Exchange will by default consider itself to be responsible for all email for that domain.

SMTP Connectors are for outbound email only, so will play no part in this delivery.

Ideally you should have email on one or other server, not trying to share it with another server.

You might get away with going in to the recipient policy and deselecting the option about Exchange being responsible for all email for that domain.

Simon.
0
 
susanzeiglerCommented:
It sounds like possibly the Exchange server thinks it is responsible for that domain and is conflicting with itself. When you try to send a message that fails, what is the error you get?
0
 
ictinusAuthor Commented:
that sounds accurate and a very good possibility... error messages... to date I haven't been able to induce an error they just get lost someplace.  
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
ictinusAuthor Commented:
maybe I need to add another smtp connector?
0
 
susanzeiglerCommented:
Which version of exchange are you using? And do you have any mailboxes set up on that exchange server which use that domain?
0
 
ictinusAuthor Commented:
I'm running Exchange 2003 and tried to deselect the two deal in the recipient policy however apparently you need at least one in this case my domain name.  

if I created a mailbox for myself using my domain.  I can send mail but can't recieve any mail.  
0
 
susanzeiglerCommented:
If I understand you correctly, ecxhange is only being used to send mail from the website--or are others internally sending mail through it? The server is not being used for collection of any local mail on the hosted domain. Is all of that correct?

If what I stated above, there are several scenarios that could be considered here. Simon mentioned one.

The MTA will ignore DNS if the domain is set up as a local domain in Exchange. Do you just have the one domain in in Exchange right now? Adding a second one--even if it is a third-level domain--and then deselecting the actual domain in the recipient policy might be the quickest solution.

0
 
SembeeCommented:
The default domain that Exchange was built with will often not allow you to deselect the option about being responsible for all email for that domain. The work around is to put a second domain in, make it the default and don't allow Exchange to update the email addresses when prompted. You should then be able to deselect the option.
After making the change, set the domain back as the default and remove the dummy domain.

Simon.
0
 
ictinusAuthor Commented:
sorry for the delay in a response my server crashed and I had to re-install everything... so we're back to were we were.  

I followed the steps Simon and now the email doesn't get lost somewhere but I get a return notification with this error....

Reporting-MTA: dns;mishka.headquarterswholesale.com
Received-From-MTA: dns;nerv
Arrival-Date: Sat, 25 Nov 2006 23:21:29 -0700

Final-Recipient: rfc822;shea@headquarterswholesale.com
Action: failed
Status: 5.1.1

maybe exchange is fixed but I have DNS issues now?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.