Solved

Cisco 3640 with constant Tx and CRC Errors

Posted on 2006-11-20
16
2,775 Views
Last Modified: 2011-10-03
Hello Experts,

Here is the situation.  I have 6 T1 lines coming to my office plugged directly into my Cisco 3640.  The Cisco router has 3  NM-1E2W modules.  Each of those modules has 2 WAN ports (total of 6) and 1 Ethernet port (not Ethernet and total of 3).

My config is very simple with MLPPP and nothing too fancy.  I don't even have ACLs.

My e0/0 is plugged into a NetGear GS748T smart switch.  The interface e0/0 is set to full duplex.  The port on the switch (10/100/1000) was set to Auto Negotiate first which made it work in half duplex with TONS of CRC and Tx Errors = about 1% of packets.  I set it to 10Half and it would show down.  I set it to 10Full and it would also show down.  The only way to get it to work is by setting it to Auto Negotiate, but that gives me lots of CRC errors.

I tried the other two ethernet interfces on the router but I got the same thing.  Here is my router's config.  Please advise what I can do:

config:
====
Cisco3640#sh run
Building configuration...

Current configuration : 2533 bytes
!
version 12.3
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname Cisco3640
!
boot-start-marker
boot system flash:c3640-is-mz.123-9b.bin
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
enable password 7 01030E05683F072B73
!
username jmelika password 7 020C0D4F09565F
clock timezone PCTime -8
no aaa new-model
ip subnet-zero
no ip source-route
!
!
ip cef
ip ftp username jmelika
ip ftp password 7 011E0956080209002F55
ip domain name xxx.com
ip name-server 216.140.16.254
ip name-server 216.140.17.254
!
no ip bootp server
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Multilink1
 ip address x.x.x.x 255.255.255.252
 ppp multilink
 ppp multilink fragment disable
 ppp multilink group 1
!
interface Ethernet0/0
 ip address x.x.x.x 255.255.255.224
 full-duplex
!
interface Serial0/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 ip route-cache flow
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 ip route-cache flow
 ppp multilink
 ppp multilink group 1
!
interface Ethernet1/0
 description Adelphia
 ip address dhcp
 ip nat outside
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 ip route-cache flow
 ppp multilink
 ppp multilink group 1
!
interface Serial1/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 ip route-cache flow
 ppp multilink
 ppp multilink group 1
!
interface Ethernet2/0
 description BW-WAN
 shutdown
 full-duplex
!
interface Serial2/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 ip route-cache flow
 ppp multilink
 ppp multilink group 1
!
interface Serial2/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 ip route-cache flow
 ppp multilink
 ppp multilink group 1
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
!
access-list 1 permit any
!
snmp-server community XXX RO
snmp-server community XXX RW
snmp-server enable traps tty
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 071F294D7D3D182145
 login
!
!
end

Cisco3640#sh interfaces e0/0
Ethernet0/0 is up, line protocol is up
  Hardware is AmdP2, address is 0010.7b9c.4bc1 (bia 0010.7b9c.4bc1)
  Internet address is x.x.x.x/27
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 254/255, txload 69/255, rxload 5/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 4d05h
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 200000 bits/sec, 210 packets/sec
  5 minute output rate 2745000 bits/sec, 290 packets/sec
     10989751 packets input, 1549628788 bytes, 0 no buffer
     Received 1 broadcasts, 0 runts, 0 giants, 0 throttles
     238975 input errors, 238947 CRC, 0 frame, 0 overrun, 28 ignored
     0 input packets with dribble condition detected
     14732776 packets output, 3836244747 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Cisco3640#.

0
Comment
Question by:jmelika
  • 7
  • 5
  • 2
  • +2
16 Comments
 
LVL 20

Expert Comment

by:calvinetter
ID: 17985216
Have you checked/swapped the cable? Tried another port on the switch while also manually setting speed/duplex?  Sounds like the switch, the switch's port or the cable are at fault, since the problem happens with any interface on the router.  I'd swap the cable first.

cheers
0
 
LVL 2

Expert Comment

by:shekharbasnet
ID: 17985790
Have you checked the router/switch log? You would get error logs if its an issue of speed/duplex mismatches.

HTH,
Shekhar  Basnet
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 17986535
Agree wth calvinetter.  Ideally you will want to run the router interface at 10/Full and it sounds like the Netgear can't handle that configuration.  I would try another manageable switch and setting the switch port to 10/Full.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17989156
put both the router and the switch in auto duplex mode
0
 
LVL 9

Author Comment

by:jmelika
ID: 17989294
I tried several different cables and ports on the switch.  Unfortunately, I don't have another smart switch that I could test at this point and I'd rather not invest in one until I determine it's the problem.

Shekhar - how would I capture the router logs to find those errors?

Thanks,
JM
0
 
LVL 2

Expert Comment

by:shekharbasnet
ID: 18001102
JM,

From your router config I can see that you have logging buffered enabled with level degugging. Which means all sort of logs from level debug to above will be logged in your router.  Just do a "show log" from your router prompt and you will see all sort of error logs including duplex mismatches if any.  Do the same for your switch too. If you have not enabled logging in your switch please do so as you have done for the router.

Also as Irmoore has suggested, if you use auto negotiate, then you must have auto negotiate at both ends.

Shekhar Basnet
0
 
LVL 9

Author Comment

by:jmelika
ID: 18024008
Below is my show log results from my router... nothing interesting at all.  The up and down were because I tried a few different cables and ports on my switch.  Netgear does not seem to have logging ability!

How do I set the router to auto negotiate?  I am only familiar with the full-duplex and no full-duplex commands.  How do I set it to auto?

000082: *Mar 12 08:04:40.184: %LINEPROTO-5-UPDOWN: Line protocol on Interface Et
hernet0/0, changed state to down
000083: *Mar 12 08:04:48.136: %LINEPROTO-5-UPDOWN: Line protocol on Interface Et
hernet0/0, changed state to up
000084: *Mar 12 08:07:11.264: %LINEPROTO-5-UPDOWN: Line protocol on Interface Et
hernet0/0, changed state to down
000085: *Mar 12 08:07:28.136: %LINEPROTO-5-UPDOWN: Line protocol on Interface Et
hernet0/0, changed state to up
000086: *Mar 12 08:09:29.780: %LINEPROTO-5-UPDOWN: Line protocol on Interface Et
hernet0/0, changed state to down
000087: *Mar 12 08:09:38.136: %LINEPROTO-5-UPDOWN: Line protocol on Interface Et
hernet0/0, changed state to up
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18024103
up/down flapping is often a sign of either a bad cable, a bad switch port, spaning tree, or problems with the autonegotiation process between the switch and the router.
To set the router to autoneotiate, simply issue the "no full-duplex" command
With no duplex config - neither half-duplex nor full-duplex, the interface should be in "auto" mode
Depending on your IOS version, you might even have a 'duplex auto' command under the interface

0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 9

Author Comment

by:jmelika
ID: 18025837
Thanks, lrmoore.

I did not have the duplex auto command, so I ran the no full-duplex command.  That put it in half duplex.  Again, the only way it'd work is if the switch port is set to auto.  Any other combination would not work.

I tried different cable, different port on the switch, and different interface on the router.  Same issue.

I tried plugging the router directly into my firewall (Dell PowerEdge 850 running IPCop) and I was having major collisions on the firewall interface and the performance degraded dramatically.  I tried using a cheap 5-port linksys switch, and the collission light was blinking a lot.  The speed was degraded dramatically also.

I don't have another managed switch to try.  What should I do?
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 18027326
Try plugging directly into the firewall again, using crossover cable, set the firewall interface to 10/full and go back to full-duplex on the router.

Have you tried using the other Ethernet interface on the router? Eth 2/0 looks unused at the moment.

Else try using an old hub, not a switch, set interface to half-duplex. Make sure the interface on your firewall also correctly negotiates half-duplex. Yes the collision light may blink a lot. That's part of half-duplex operation. Old hubs performed quite well for some time before switches came along. Unfortunately, your old 3640 was designed to work with an old hub.
You might consider upgrading the 3640 with a NM1FE-2W module. The 3640 has been end-of-lifed some time ago. Time to start thinking replacement of the box. You're paying a bunch of money for all those T1's bundled up and a new router should not be difficult to justify. A new 2851 will run circles around the 3640. A 3845 would almost be overkill.

0
 
LVL 9

Author Comment

by:jmelika
ID: 18030171
Thanks, lrmoore.  I'll look for an old hub and try that.  I did try using e2/0 (after changing the IP's), and even e1/0.  They're both unused at the moment.  I had the same results with both of those interfaces.

I am having a little bit of "Linux" issues setting the duplex properly :D, but I'll give it a shot.

I have an empty slot in my 3640 and I have come across a NM-1FE-TX module on ebay for under $200.  Is it worth trying out?  What's the difference between the NM-1FE-TX and NM-1FE-FX?  Is the TX what I need?

Thanks!
JM
0
 
LVL 9

Author Comment

by:jmelika
ID: 18030192
Sorry for the lame question about the difference between TX and FX.  FX is fiber and I need RJ-45, so TX is defnitely what I need.  lrmoore, do you feel getting the module is my best bet now?

Thanks!
JM
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18030582
It just might be your best shot at this time..
Beware that we had someone here that bought no less than 4 of those modules off ebay and every single one was defective.
0
 
LVL 9

Author Comment

by:jmelika
ID: 18030833
OK, I am crossing my finger and buying this one.  It should be here tomorrow.  I'll let you guys know how it works out!

Thanks for all your help so far.

JM
0
 
LVL 9

Author Comment

by:jmelika
ID: 18041682
I installed the FE module and sure enough, the collisions stopped immediately.  FINALLY!!!

Thank you all for helping me out.

JM
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18042981
Glad it worked out for you!
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now