Solved

PIX VPN conected but no access

Posted on 2006-11-20
8
339 Views
Last Modified: 2010-04-12
I setup the VPN on my PIX firewall.  It is setup for radius server on the inside.  I have one PAT port and one static Nat port.  I VPN into either and it lets me connect perfectly, but no access to anything.  It is like I am not connected at all.  The PIX is setup site-to-site with 2 other locations, and I am just trying to make this a remote access server.  Any help!!  I don't see any problems with my access list, but maybe I am blind.

Config

: Saved
: Written by enable_15 at 11:55:12.971 EST Mon Nov 20 2006
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ****** encrypted
passwd *********encrypted
hostname pixfirewall
domain-name ciscopix.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 160 permit ip 192.168.70.0 255.255.255.0 192.168.1.0
255.255.255.0
access-list allow_ping permit icmp any any echo-reply
access-list allow_ping permit icmp any any time-exceeded
access-list allow_ping permit icmp any any unreachable
access-list 170 permit ip 192.168.70.0 255.255.255.0 192.168.60.0
255.255.255.0
access-list 150 permit ip 192.168.70.0 255.255.255.0 192.168.60.0
255.255.255.0
access-list 150 permit ip 192.168.70.0 255.255.255.0 192.168.1.0
255.255.255.0
access-list 150 permit ip any 192.168.70.96 255.255.255.240
access-list 100 permit tcp any host 67.59.38.11 eq www
access-list 100 permit tcp any host 67.59.38.11 eq https
access-list outside_cryptomap_dyn_20 permit ip any 192.168.70.96
255.255.255.240
no pager
logging on
logging monitor debugging
logging buffered debugging
mtu outside 1500
mtu inside 1500
ip address outside 67.59.38.10 255.255.255.0
ip address inside 192.168.70.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool cl-pool 192.168.70.101-192.168.70.110 mask 255.255.255.0
pdm location 192.168.70.0 255.255.255.0 inside
pdm location 192.168.70.190 255.255.255.255 inside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location 192.168.60.0 255.255.255.0 outside
pdm location 192.168.80.0 255.255.255.0 outside
pdm location 192.168.80.0 255.255.255.240 outside
pdm location 192.168.70.185 255.255.255.255 inside
pdm location 192.168.70.96 255.255.255.240 outside
pdm location 192.168.70.102 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 150
nat (inside) 1 192.168.70.0 255.255.255.0 0 0
static (inside,outside) 67.59.38.11 192.168.70.190 netmask
255.255.255.255 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 67.59.38.9 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 5
aaa-server RADIUS deadtime 30
aaa-server RADIUS (inside) host 192.168.70.185 **** timeout 30
aaa-server LOCAL protocol local
http server enable
http 192.168.70.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set gb-set esp-aes-256 esp-md5-hmac
crypto ipsec transform-set is-set esp-3des esp-sha-hmac
crypto ipsec transform-set cl-set esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 3600
crypto dynamic-map outside_dyn_map 20 match address
outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set is-set
crypto map gb-map 1 ipsec-isakmp
crypto map gb-map 1 match address 160
crypto map gb-map 1 set peer 63.88.189.251
crypto map gb-map 1 set transform-set gb-set
crypto map gb-map 2 ipsec-isakmp
crypto map gb-map 2 match address 170
crypto map gb-map 2 set peer 134.215.204.218
crypto map gb-map 2 set transform-set is-set
crypto map gb-map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map gb-map interface outside
isakmp enable outside
isakmp key ********** address 63.88.189.251
netmask 255.255.255.255
isakmp key ********* address 134.215.204.218
netmask 255.255.255.255
isakmp key ******** address 0.0.0.0 netmask
0.0.0.0
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption aes-256
isakmp policy 1 hash md5
isakmp policy 1 group 2
isakmp policy 1 lifetime 5400
isakmp policy 2 authentication pre-share
isakmp policy 2 encryption 3des
isakmp policy 2 hash sha
isakmp policy 2 group 2
isakmp policy 2 lifetime 5400
isakmp policy 3 authentication pre-share
isakmp policy 3 encryption 3des
isakmp policy 3 hash sha
isakmp policy 3 group 2
isakmp policy 3 lifetime 86400
telnet 192.168.70.0 255.255.255.0 inside
telnet timeout 15
ssh timeout 60
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe 40
vpdn group PPTP-VPDN-GROUP client configuration address local cl-pool
vpdn group PPTP-VPDN-GROUP client configuration dns 192.168.70.185
vpdn group PPTP-VPDN-GROUP client configuration wins 192.168.70.185
vpdn group PPTP-VPDN-GROUP client authentication aaa RADIUS
vpdn group PPTP-VPDN-GROUP client accounting RADIUS
vpdn group PPTP-VPDN-GROUP pptp echo 60  
vpdn enable outside
vpdn enable inside
dhcpd address 192.168.70.2-192.168.70.100 inside
dhcpd dns 192.168.70.185 64.186.63.132
dhcpd wins 192.168.70.185 192.168.60.10
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain domain.local
dhcpd auto_config outside
dhcpd enable inside
username ****** password ******* encrypted privilege 15
terminal width 80
Cryptochecksum:************
: end


0
Comment
Question by:tabitha87
8 Comments
 
LVL 9

Expert Comment

by:stressedout2004
ID: 17984740
Cisco does not recommend that the IP pool for the VPN overlaps or is on the same subnet as that of the internal network. I would recommend that you change your IP pool to something other than 192.168.70.0/24. Once you create a new IP pool, add an access-list entry to acl 150 for the new pool.

e.g

ip local pool pptp_pool 10.10.10.1-10.10.10.20 mask 255.255.255.0
access-list 150 permit ip 192.168.70.0 255.255.255.0 10.10.10.0 255.255.255
0
 
LVL 20

Accepted Solution

by:
calvinetter earned 500 total points
ID: 17992355
 Agree w/ stressedout2004 - if your 'ip local pool' overlaps any of the subnets that the PIX knows about, then you'll hit a routing loop, as you've already seen.  The client VPN pool also mustn't overlap any of the remote LANs on the other side of the site-site VPN links, nor the IP range of the LAN where the remote VPN client PC resides on, or again you'll hit a routing loop.

  You should also add this to your config:
isakmp nat-traversal

  I also hope you're not trying to access any of the remote site-site LANs (eg 192.168.1.x) directly from the remote VPN client - even if your client VPN pool doesn't overlap anything, you won't be able to get from the remote VPN client & across the site-site VPN link to the other sites.  PIX 6.x series won't let you do this "U-turn" (aka hairpinning), since traffic would have to enter & exit the same interface in order to get out to the other VPN site.  Only PIX 7.x series supports hairpinning, & 7.x is only supported on PIX 515 or above.
   A workaround would be to connect to a local PC/server on the 192.168.70.x subnet, then from there you'd be able to get over the site-site VPN links.

  Once you've made your changes to the client VPN pool, run this:
clear xlate
crypto map gb-map interface outside   <- important to re-apply VPN settings anytime you change the VPN config

cheers
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18011674
stressedout2004 - WELCOME BACK!
0
 
LVL 9

Expert Comment

by:stressedout2004
ID: 18016551
I've been terribly busy : (
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 79

Expert Comment

by:lrmoore
ID: 18035553
Are you still with us, Tabitha?
Do you need more information? We're here to help but only if you come back and dialog with us...

0
 

Author Comment

by:tabitha87
ID: 18038711
Yes, I am still here.  I tryied the different IP subnet, but not the other ones.  I will work on that by this weekend.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18039695
OK, thanks!
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18107883
Are you still working on this? Can you close out this question before the cleanup crew gets around to it?
Thanks!
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Join & Write a Comment

Suggested Solutions

Sometimes, you want your microsoft VPN to route all the traffic to the remote network. Usually your employer network. This makes it possible to access all the nodes inside this remote LAN, even if they have no "public DNS" entries. To do so, you wo…
When you connect to your workplace's VPN, you may not notice that you are using your workplace's servers to serve up webpages.  This might be undesirable since the workplace can log all the places you've been.  It also might be very slow to load pag…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now