Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Configuring proper index

Posted on 2006-11-20
12
Medium Priority
?
199 Views
Last Modified: 2010-03-04
I have a critical issue that is simple in nature.  I am not familar with apache and I have www.abc.com going to the correct page and abc.com going to the incorrect page.  I want to get abc.com to point to the same page that www.abc.com is pointed to.  

I am currently searching through apache's documentation and forums... I gotta get this fixed tonight and any direction to the correct documentation page would be helpful.  

Also, how can I tell what version of apache we are using?

P
0
Comment
Question by:PeterZog
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
12 Comments
 

Author Comment

by:PeterZog
ID: 17984942
Ok I got into httpd.conf.  There are <virtualhost www.abc.com> settings among others like <xyz.abc.com> ... but there is nothing for <virtual abc.com>  ... there is a <virtualhost abc.ourisp.com>  ... Is THIS what I adjust for abc.com?

Peter
0
 
LVL 57

Expert Comment

by:giltjr
ID: 17985007
What platform are you running Apache on?

In the <virtualhost www.abc.com> paramters add:

      ServerAlias abc.com

So you have:

     <virtualhost www.abc.com> 
     "other paramters"
     ServerAlias abc.com
     </virtualhost>

0
 

Author Comment

by:PeterZog
ID: 17985045
Thanks I'll give that a try.  Apache is running on Windows Server.  Does that have an impact?
0
What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

 
LVL 57

Expert Comment

by:giltjr
ID: 17985077
Not with the ServerAlias.

However, it does to figure out what version of Apache you are running.  In Windows go to program files and look for a directory like "Apache" or "Apache Software Foundation", under this there should be a directory with the version/release of Apache.
0
 

Author Comment

by:PeterZog
ID: 17985116
Ok, that took care of 50% of the problem.  I didn't tell you that I have two domains that are hosting ... and they are both having the problem.  What you suggested corrected the problem for one domain but not the other.

There is a difference in config for these two:

The NOW working one:

<Virtual Host www.abc.com>
    ServerAdmin  xxxxxxxxxx
    DocumentRoot xxxxxxxxxxx
    DirectoryIndex xxxxxxxxxxx
    ServerName 216.17.xxx.xxx
    ErrorLog xxxxxx
    CustomLog xxxxxxxx
    ServerAlias abc.com
</VirtualHost>

The one that is still incorrect:
<VirtualHost www.xyz.com>
    ServerAdmin  xxxxxxxxxx
    DocumentRoot xxxxxxxxxxx
    DirectoryIndex xxxxxxxxxxx
    ServerName 216.17.xxx.xxx
    ErrorLog xxxxxx
    CustomLog xxxxxxxx
           Alias /admin "/var/www/html/xyz/admin"
           <Location /admin>
           AuthName "Authorised Users"
           DirectoryIndex admin.php index.html index.htm
           AuthType basic
           AuthUserFile /etc/.xyz
           require valid-user
           </Location>
      ServerAlias xyz.com
</VirtualHost>

Is that exact code making the difference?



ServerAlias abc.com
0
 
LVL 57

Expert Comment

by:giltjr
ID: 17985128
I would try what I have below.  I would also check the logs to see if there are any errors.

<VirtualHost www.xyz.com>
    ServerAdmin  xxxxxxxxxx
    DocumentRoot xxxxxxxxxxx
    DirectoryIndex xxxxxxxxxxx
    ServerName 216.17.xxx.xxx
    ErrorLog xxxxxx
    CustomLog xxxxxxxx
    ServerAlias xyz.com
           Alias /admin "/var/www/html/xyz/admin"
           <Location /admin>
           AuthName "Authorised Users"
           DirectoryIndex admin.php index.html index.htm
           AuthType basic
           AuthUserFile /etc/.xyz
           require valid-user
           </Location>
</VirtualHost>
0
 

Author Comment

by:PeterZog
ID: 17985177
Hey I really appreciate the help... a couple things...

1. I just commented the extra code out for the time being.  I'll see if someone screams about it.

2. The problem came back... I wanted to make sure that I actually made the change.  So I commented out the ServerAlias code www.abc.com, saved the file, checked it and it went to the incorrect page, then I uncommented the code, saved it and it went to the incorrect page again.   (???)  

Could this be because of DNS caching or something?  Does it take time sometimes for the httpd.conf changes to take effect?  I have triple checked my code to make sure I am not missing something.

Peter  
0
 

Author Comment

by:PeterZog
ID: 17985259
This server has multiple instances of apache folders (different versions and projects).  How can I tell which httpd.conf is actually being used?  
0
 
LVL 13

Expert Comment

by:rhickmott
ID: 17986009
Try the Following

NameVirtualHost *:80

<VirtualHost *:80>
     ServerName abc.com
     ServerAlias abc.com *.abc.com 216.17.xxx.xxx
     DocumentRoot xxxxxxxxxxxxxxxxxxxxxx
     ServerAdmin  xxxxxxxxxx
     DirectoryIndex xxxxxxxxxxx
     ErrorLog xxxxxx
     CustomLog xxxxxxxx
</VirtualHost>

<VirtualHost *:80>
     ServerName xyz.com
     ServerAlias xyz.com *.xyz.com 216.17.xxx.xxx
     DocumentRoot xxxxxxxxxxxxxxxxxxxxxx
     ServerAdmin  xxxxxxxxxx
     DirectoryIndex xxxxxxxxxxx
     ErrorLog xxxxxx
     CustomLog xxxxxxxx
</VirtualHost>
0
 

Author Comment

by:PeterZog
ID: 17986881
It still doesn't work.  How can I make sure that the httpd.conf that I am editting is the one being used?
0
 
LVL 57

Accepted Solution

by:
giltjr earned 2000 total points
ID: 17987360
Are both Virtualhost definitions in the same conf file?  If so and changing the 1st one works, then the correct conf file is being use.

Just to make sure "http://abc.com" is returning the same page as "http://www.abc.com."?  Correct?

What do you get when you try "http://xyz.com"?

If you have not tried I would suggest:

<VirtualHost *:80>
  ServerName www.xyz.com
  ServerAlias xyz.com *.xyz.com
  "other parms"
</VirtualHost>

Is there a special reaons you have a IP address in there?  Does the "xyz" domain have a unique IP address?

Also do you have the parameter:

     NameVirtualHost

This should come before first <VirtualHost> definition.  You can code it as:

    NamveVirtualHost *:80
0
 
LVL 57

Expert Comment

by:giltjr
ID: 18000653
Glad to see you got it working.  Thanks.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hi, in this article I'm going to teach you how to run your own site, and how to let people in (without IP). I'll talk about and explain each step... :) By the way, everything in this Tutorial is completely free and legal. This article is for …
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
Suggested Courses

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question