Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

configure both tomcat and iis 6 on port 80 (windows 2003 std. server)

Posted on 2006-11-20
5
Medium Priority
?
3,890 Views
Last Modified: 2008-03-26
Hi,

I wnat to configure the IIS 6.0 and Tomcat 6.0 both on port 80 on samve server, plz update how it can be possilbe,

I ahve 3 static ip on this server.

Regards,
Naresh
0
Comment
Question by:nareshver
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 143

Expert Comment

by:Guy Hengel [angelIII / a3]
ID: 17985481
you cannot have 2 applications listening on the same port on the same machine.
you have to choose 2 different ports. having 2 or more IP addresses on the machine does not help.
0
 

Author Comment

by:nareshver
ID: 17985521
Hi,

I have configue the exchange 2003 and merak mail server on the same server using differtert ip, i think this option will also avilalbe for web servers.

Naresh
0
 
LVL 13

Expert Comment

by:rhickmott
ID: 17985982
You should be able to set Apache to listen port 80 of one IP.

iirr with the LISTEN xxx.xxx.xxx.xxx:80 command.

Im not sure how the Tomcat set-up is but assumingly its a similar set-up.
0
 
LVL 19

Accepted Solution

by:
ramazanyich earned 2000 total points
ID: 17991557
Indeed web servers allow ind to specific IP addresses, so if you have multiple IP addresses you can use multiple servers on the same port.
In tomcat6 you should modify $TOMCAT_HOME/conf/server.xml file. Search for <Connector> element eith port="8080" attribute and change value of 8080 to 80 and add additional attribute address="IP_address". For example if you want bind to IP address 192.168.0.2 then this element will look like this:
<Connector port="80" address="192.168.0.2" .... />

to bind  IIS 6 to specific IP address (for example 192.168.0.1) do the follwoing:
1. Extract the httpcfg.exe utility from the support tools area on the Win2003 CD.
2. stop all IIS services: net stop http /y
3. execute: httpcfg set iplisten -i 192.168.0.1
 make sure: httpcfg query iplisten (the ip's listed are the only ip addresses that IIS will be listening on and no other)
5. restart IIS Services: net start w3svc
0
 

Author Comment

by:nareshver
ID: 17993357
thanks Ramazanyich ,

frist I will try to configure this setting  on win2k3 virtual image

Naresh
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my time as an SEO for the last 2 years and in the questions I have assisted with on here I have always seen the need to redirect from non-www urls to their www versions. For instance redirecting http://domain.com (http://domain.com) to http…
Hi, in this article I'm going to teach you how to run your own site, and how to let people in (without IP). I'll talk about and explain each step... :) By the way, everything in this Tutorial is completely free and legal. This article is for …
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Suggested Courses

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question