Solved

500 Internal Server Error - The certificate chain was issued by an authority that is not trusted

Posted on 2006-11-21
13
8,455 Views
Last Modified: 2008-07-04
Here's the problem,

We have a SBS server with ISA 2000, exchange 2003 and IIS all running on the same server.  We recently changed company names and I started messing with the certs, like a stupid person.  Now, when a user tries to access OWA, they get:  500 Internal Server Error - The certificate chain was issued by an authority that is not trusted. (-2146893019)
Internet Security and Acceleration Server.  I am at a loss as to what to do.  I have the orginal cert installed and back, howerver I keep getting this each time.  Please help!!
0
Comment
Question by:mb2answers
  • 7
  • 5
13 Comments
 

Author Comment

by:mb2answers
Comment Utility
I know its a problem with ISA, but just not sure what to do to resolve it.  I do not have much experience with ISA.
0
 
LVL 1

Expert Comment

by:netstable
Comment Utility
Hi mb2

Not sure if the following site will help:

http://forums.isaserver.org/m_230004400/tm.htm

The issue seems to have been touched on there and could point you in the right direction!
0
 

Author Comment

by:mb2answers
Comment Utility
I have already been through that article with no sucess.  Any other ideas?
0
 

Author Comment

by:mb2answers
Comment Utility
This may help as well.  Before I messed with it, when you went to the site, it would prompt you to install the certificae, no it does not.
0
 
LVL 9

Expert Comment

by:PeterMac
Comment Utility
Problem is with Master certificate on server, whether or not you are using a commercial certificate, from Verisign etc, or one generated localy, the certificate contains the server name (Domain Name strictly), and this is why you are now getting errors. Only solution is to generate new certificate with correct name
0
 
LVL 9

Expert Comment

by:PeterMac
Comment Utility
Sorry finger trouble, had not finished posting.

To check problem go to Internet Services Manager - Select webmail site - Properties - Directory Security - At bottom under Secure Communications - View Certificate Details - will show both "Issued to" must match full Website Name, and "Issued by" must match Domain (For Internal Cert), or Trusted Supplier (e.g Verisign) (For External Cert).

If you have changed either Site Name, or Domain Name, Certificate is no longer valid (Trusted).
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Author Comment

by:mb2answers
Comment Utility
both issued to and issued by are the correct domain name.  This is a self generated cert.  Is there something that ISA needs to use the cert?  Where does the cert need to be installed?  I tried to put everything back the way it was.  But still haveing the same issue.
0
 
LVL 9

Expert Comment

by:PeterMac
Comment Utility
Yes there is something needed, too long since I did this, to explain myself, and don't want to upset my server by checking details here, but following should help you through process.

http://hellomate.typepad.com/exchange/2004/07/this_security_c.html
0
 

Author Comment

by:mb2answers
Comment Utility
Reistalled the cert, still nothing.
0
 
LVL 9

Accepted Solution

by:
PeterMac earned 500 total points
Comment Utility
Sorry, had not read all the way through Post, it looked as though it was going to exolain everything, but on checking only mentions client side of problem. You also need certificate installed as trusted root certificate on server. Will need to go into IE on server, Internet options, Content, Certificates, Trusted Root Certificates, Needs to have copy of your Locally produced Root Certificate (Should have been produced at same time as client certificate) imported to here.

Check below - additional point 1) after end of main install.

http://eal.us/blog/_archives/2003/6/2/25109.html
0
 

Author Comment

by:mb2answers
Comment Utility
You are correct.  It was a problem with the cert.  Unfortunatly on a SBS Server there is an easy was to fix it but didn't know it.  After messing with the certs I had another error and found an article that resolved the issue:  http://support.microsoft.com/kb/842612  this wizard fixed the whole thing.
0
 
LVL 9

Expert Comment

by:PeterMac
Comment Utility
Nice, last contact I had with SBS was NT 4.5, did not have any nice features like that then.
0
 

Author Comment

by:mb2answers
Comment Utility
Yeah, what would be even nicer would be if microsoft had an easier way to find support.  Digging through their stuff is a nightmare.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now