?
Solved

CISCO Pix506E Internet Access?

Posted on 2006-11-21
3
Medium Priority
?
255 Views
Last Modified: 2010-04-12
Hi, Just aquired Cisco Pix506e for an industrial application...
I am no IT expert, I NEED HELP!

I set up VPN, pinging, split tunnel and everything is working fine the only thing i need now to finish this project is getting the Network on the Inside internet access, i am not even sure is the pic can act as a router? canthis be done?:

heres topolgy:  inside----switch-----ciscopix506-----house net with dhcp.

PLease Help me out? i set up rules to alow access but nothing i think it may be NAT but am not sure, all inside clients are set to static:
   ip: 192.168.10.x/24
 gw: 192.168.10.1
dns: 192.168.10.1

where pix is:    192.168.10.1
pix is getting ip on oustide int via dhcp:    10.0.0.76/24

Heres my Config:::

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XCXu9VvUtWzg.grr encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list company_splitTunnelAcl permit ip host 0.0.0.0 any
access-list company_splitTunnelAcl permit ip 192.168.10.0 255.255.255.0 any
access-list inside_outbound_nat0_acl permit ip any 192.168.10.192 255.255.255.192
access-list inside_outbound_nat0_acl permit ip any any
access-list outside_cryptomap_dyn_20 permit ip any 192.168.10.192 255.255.255.192
access-list inside_access_in permit ip any any
access-list inside_access_in permit tcp 192.168.10.0 255.255.255.0 any
access-list inside_access_in permit ip 192.168.10.0 255.255.255.0 any
access-list outside_access_in remark Outside to Inside all
access-list outside_access_in permit tcp any any
pager lines 24
logging history informational
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.10.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool companyVpn 192.168.10.200-192.168.10.254
pdm location 192.168.10.10 255.255.255.255 inside
pdm location 0.0.0.0 255.255.255.255 inside
pdm location 0.0.0.0 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 dns 0 0
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 255.255.255.255 outside
http 192.168.10.0 255.255.255.0 inside
snmp-server host inside 192.168.10.10
no snmp-server location
snmp-server contact Administrator
snmp-server community password
snmp-server enable traps
tftp-server inside 192.168.10.10 /firewall
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp enable inside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup company address-pool companyVpn
vpngroup company dns-server 192.168.10.1
vpngroup company wins-server 192.168.10.1
vpngroup company default-domain OOM
vpngroup company split-tunnel company_splitTunnelAcl
vpngroup company idle-time 1800
vpngroup company password ********
telnet timeout 5
ssh 0.0.0.0 255.255.255.255 outside
ssh 0.0.0.0 255.255.255.255 inside
ssh timeout 5
management-access inside
console timeout 0
vpdn enable outside
dhcpd address 192.168.10.2-192.168.10.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username administrator password yCeBw7hwWikHoR.u encrypted privilege 15
terminal width 80
banner login Welcome To company Oilfield and Marine Secure firewall...
Cryptochecksum:2d9deb2751c6816947d8cf050417e489
: end
[OK]

THANK YOU VERY MUCH!!!!!!

0
Comment
Question by:ricardosanchezquirch
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 32

Accepted Solution

by:
rsivanandan earned 1500 total points
ID: 18013413
On both sides of the pix firewall you have private network segments connected. So where is your internet connection ? Modify the diagram in such a way that you indicate the internet connection as well.

Cheers,
Rajesh
0
 

Author Comment

by:ricardosanchezquirch
ID: 18019299
Thanks Rajesh It was DNS/proxy i had misconfigured...
Got it working now...
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 18019974
Oh I see. thnx for the points anyways.

Cheers,
Rajesh
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

One of the Top 10  common Cisco VPN problems are not-matching shared keys. This is an easy one to fix, but not always easy to notice, see the case below. A simple IPsec tunnel between fast Ethernet interfaces of routers SW1 (f1/1) and R1(f0/0). …
Sometimes, you want your microsoft VPN to route all the traffic to the remote network. Usually your employer network. This makes it possible to access all the nodes inside this remote LAN, even if they have no "public DNS" entries. To do so, you wo…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question