Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1141
  • Last Modified:

Performance monitoring from a remote computer

I am using a tool to monitor various services and statistics on Win2k3 servers.  The tool runs on a workstation - which is important because of course one of the main purposes of the monitoring is to get notified if services stop abnormally or if the server itself freezes or goes down.  Normally there is no problem with doing this, using an account that is a member of the Administrators group. However, I'm having a problem with one particular server in one of my domains.  This server was upgraded from Win2K to Win2K3 about a year or so ago.  I was previously able to monitor it with no problem.  Now my software cannot access the machine and when I try to connect remotely to the performance monitors I get a message saying "Unable to connect to remote computer."  I can, however, run performance monitors locally on the server, so it's not a problem with the perfmon program itself.

I've checked the permissions per MS knowledgebase articles and also turned off media sensing on the gigabit NIC per MS.  Still no joy.  Any ideas?

TIA,
Deb
0
Hypercat (Deb)
Asked:
Hypercat (Deb)
  • 3
  • 2
1 Solution
 
AndresMCommented:
See if romete registry service is started on target machine.
Also see:
"Unable to Connect to Machine" Error Message When You Try to View Remote Counters
http://support.microsoft.com/?id=300702
0
 
Hypercat (Deb)Author Commented:
Thanks for the response. The remote registry service must be started, since I can remotely edit the registry.  The article you suggested is the one we have already followed concerning the permissions.  The account I'm using is a member of the domain Built-in Administrators group, but I checked all the settings anyway and they are correct.

Deb
0
 
AndresMCommented:
See if this helps (from newsgroups):

1.      Open regedit on the machine to which you are trying to connect to perfmon.
2.      Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Perflib
3.      Right click on Perflib key and select permissions
4.      Click Add and add Local Service with full control
5.      Save and exit
6.      Restart the Remote Registry Service


0
 
Hypercat (Deb)Author Commented:
That fixed it.  AndresM, you da man.  Thanks!!

Cheers,

Deb
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now