Solved

Windows Server 2003 Standard Remote Desktop Automatic Logon

Posted on 2006-11-21
26
556 Views
Last Modified: 2013-11-21
Hi, I have applied the Group Policy update to allow automatic logon to a Windows Server 2003 machine. I have the chechbox on the client marked to remember password. But when I go to logon in through the RD client, it still prompts for a password on the machine. I have done everything I can think of, including: making the user a member of the Remote Desktop group, adding the user to the allowed connections, etc. I can't see anything in the event viewer. Does anyone have any suggestions?
0
Comment
Question by:firstbankak
  • 14
  • 7
  • 3
  • +1
26 Comments
 
LVL 67

Expert Comment

by:sirbounty
ID: 17992464
Click Start->Run->tscc.msc <Enter>

From the Connections section, in the right-pane, double-click RDP-Tcp

The adjustments can be made from the Logon Settings tab...it's probably set to use client-provided logon...
0
 

Author Comment

by:firstbankak
ID: 17992489
thanks again for your reply sirbounty. It is set to use client-provided login. That's because I am going to have one end user logon with a restircted account as per her client, then I will logon with an administrator account as per my client. The reason I am using Remote Desktop as opposed to Terminal Server is because we only need two remote connections to this machine.
0
 
LVL 67

Assisted Solution

by:sirbounty
sirbounty earned 100 total points
ID: 17992536
I think that's why you're getting prompted though.
Here's what I do to override that behavior...

I have a batch file that I use that ensure I'm using 'my' rdp setup:

::begin code copy
@echo off
if [%1]==[] goto :eof
start mstsc "c:\data\connect.rdp" /console /v %1
::end code copy

Next, create your session:

Start->Run->MSTSC <Enter>
Click Options
Next, enter your username, password, etc and click Save my password, then click Save As to save it as (in my example) c:\data\connect.rdp

Now, you can use the batch file to connect, name it RDP.cmd - probably place it in your \winnt\system32 folder, so you can run it from anywhere...

Start->Run->RDP Servername <Enter>

should now work for you....
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 2

Expert Comment

by:stevew1999
ID: 17992940
It sounds like you have the box checked that says "always prompt for password"  on the Logon Settings tab.

It can be misleading.  You still need to pass credentials if you uncheck that box.  If you have it checked it will behave as you described.

0
 

Author Comment

by:firstbankak
ID: 17997141
Thanks sirbounty and stevew1999. While I am sure the batch file would work sirbounty, I would like to get to the bottom of the problem and fix it. This is a live production server, and if there are any problems on it they need to be addressed fully. stevew1999, that checkbox is unchecked. I have combed through all the settings that I can, including intense research on Google. But for some reason, the remote desktop client always prompts for a password. I haven't run Windows updates on this machine, so I need to see if there is an update that perhaps addresses this issue.
0
 

Author Comment

by:firstbankak
ID: 17997227
OK, I just noticed something. I am in the group policy editor under Administrative Templates -> Windows Components -> Terminal Services -> Encryption and Security. Under the option for 'Always prompt client for password upon connection', there is a little note that says: 'Supported on: At least Microsoft Windows XP Terminal Services'.

Our corporate environment is mostly w2k. Since I am using the remote desktop client on a w2k machine, this is probably why I am being prompted for a username/password. So, unfortunately, I will have to look for a hack. I am going to try your batch file now sirbounty.
0
 

Author Comment

by:firstbankak
ID: 17997257
Well, your batch file brings up the remote connection alright, but I am still being prompted for a password...
0
 
LVL 2

Expert Comment

by:stevew1999
ID: 17997296
I was thinking something in the GPO would be next...

Try installing the 5.2 RDP client on the win2k machine.
0
 
LVL 2

Expert Comment

by:stevew1999
ID: 17997308
You can get the new RDP version from any Windows Server 2003 SP1 installation - Look for it in the %systemroot%\system32\clients\tsclient folder.

0
 

Author Comment

by:firstbankak
ID: 17997508
Thanks stevew1999, I updated the version on my w2k machine. Still being prompted for a password. So I tried connecting from an XP machine, and that's asking for a password too. So there must be something server-side, some setting that I am missing.

The reason I am pushing for this is we have numerous end users, and its so much easier for them and us if they don't have to remember another password.
0
 
LVL 2

Expert Comment

by:stevew1999
ID: 17997755
I understand - I'm actually doing the same thing.

OK - This works in my test environment using an XP client.

GPO for the TS, > Computer Configuration > Administrative Templates > Windows Components >Terminal Services > Encryption and Security.

> Always prompt client for password upon connection >disable

Make sure you give it enough time to refresh the policy or force an update.


0
 

Author Comment

by:firstbankak
ID: 17998228
I've already tried playing with that setting to no avail. I just made sure that setting was set and attempted a connection from an XP machine, still prompting for password. Tell me, how do I "force" the GPO update?
0
 
LVL 2

Expert Comment

by:stevew1999
ID: 17998296
on the TS and the xp machine.

Start > Run

GPupdate /force

0
 

Author Comment

by:firstbankak
ID: 18000281
Well, its a bugger, I have spent a lot of time toying with this today. It seems that there is an issue server side with remote desktop. I am going to revert (ick!) to pcAnywhere. Thanks for your help stevew1999.
0
 
LVL 6

Expert Comment

by:DaMaestro
ID: 18008517
In addition to the above, you may want to review the following GPO settings

User Config
Administrative Templates > Windows Components > Terminal Services > Client > Do not Allow passwords to be saved

Computer Config
Windows Settings > Security Settings > Local Policies > Security Options > Interactive Logon: Do Not Require CTRL ALT DEL

Administrative Templates > Windows Components > Terminal Services > Client > Do not Allow passwords to be saved


For your situation I might disable all three
0
 

Author Comment

by:firstbankak
ID: 18020504
Thanks for your input DaMaestro. I tried these three settings and am still being prompted for a password.
0
 

Author Comment

by:firstbankak
ID: 18023938
This must be a bugger of an error. I've spent most of the afternoon Googling and I haven't found any additional information. There must be some other server-side setting that is keeping the client from auto logging in?
0
 
LVL 2

Expert Comment

by:stevew1999
ID: 18025394
Do the client machines apply a different GPO than the server?  You've looked everywhere I would have looked on the server side.
0
 

Author Comment

by:firstbankak
ID: 18029168
Thanks for the follow-up. I've tried both a w2k and an xp client. I upgraded the RD client on these machines from the %systemroot%\system32\clients\tsclient folder on the w2k03 server. But as for the GPO, I think they are a bit different because of the different os versions.
0
 

Author Comment

by:firstbankak
ID: 18029558
... as it comes down to it, my gut instinct is the windows server 2003 box is not recognizing the saved username and password on the client. This could be due to a number of things, most likely encryption.
0
 
LVL 2

Assisted Solution

by:stevew1999
stevew1999 earned 200 total points
ID: 18029576
I'm a little out of my league here but I'll try to reprhase my question.  Are you sure the GPO that your looking at is the one that is being applied?  I ran into a situation where what I thought was being applied really wasn't.


http://windows.stanford.edu/docs/gpoorder.htm
0
 

Author Comment

by:firstbankak
ID: 18030377
I checked into what you said stevew1999, still no luck. OK, I really think I have narrowed it down. And if I can solve this then I know the problem will be solved. This computer uses the Novell client for Windows. Every time I go to log into the console I have to hit CTRL-ALT-DEL. I notice that when I try to remote into it with a saved username/password, I do not have to hit CTRL-ALT-DEL. If I could find a way to disable the Novell Welcome Screen (ie, the Novell prompt to hit CTRL-ALT-DEL) then I am pretty sure I will be able to auto login.
0
 

Author Comment

by:firstbankak
ID: 18030488
OK, I just verified my last post. I hit CTRL-ALT-DEL at the console. Then I ran back to my desk and attempted an auto logon with the remote desktop client. It worked! NOW, how to remove that pesky Novell Welcome Screen?
0
 
LVL 6

Expert Comment

by:DaMaestro
ID: 18061185
Oh I wish you would have mentioned that sooner, Novell CTRL-ALT-DEL would not respond to the policy settings we suggested. Are you using Novell for any particular reason? If  you use the terminal server as a workstation only, you can try using the MS client for netware instead of the Novell client.
0
 
LVL 6

Accepted Solution

by:
DaMaestro earned 200 total points
ID: 18061202
If you must use Novell services on the network
Control Panel / Network Connections / Local Network / Properties / Install / Client / Microsoft Client for Netware

It's been awhile since I used a genuine Novell client, so you may or may not have to add/remove programs to remove the authentic Novell Client
0
 

Author Comment

by:firstbankak
ID: 18069924
Thankyou sirbounty, stevew1999 and DaMaestro for all your comments. The solution is, the Novell Welcome screen interferes with remote desktop automatic logon. I was able to bypass this through the Novell client properties. Points distributed throughout.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip Migration Tip #1 – Source Server Health can be found here: http://www.experts-exchang…
Have you considered what group policies are backwards and forwards compatible? Windows Active Directory servers and clients use group policy templates to deploy sets of policies within your domain. But, there is a catch to deploying policies. The…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

785 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question