[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 328
  • Last Modified:

Accessing a printer on a network

 OK, this is a bit complex, so I will try to give all the details right off so I do not have to keep responding to questions.

I need to access a printer attached to a PC on my network.  I have three PC's all connected to an 8 port hub.  That hub is attached to a Cisco router and it is attached to a DSL modem.  Well, just to complicate things, my boss decides to add a laptop.  It is connceted wirelssly to a Dlink wirelss router that is connected to the hub also.  It is connected using the WAN port and a straight through cable to an empty port on the hub.  Works great, laptop has internet.  BUT, it cannot access the printer on one of the PC's.  The wireless router has an address of 192.168.0.100.  The rest of the network has addresses of 10.42.4.88, etc.  All the PC's can use the printer on the one PC, but the laptop cannot even see the PC's.  All computers are running XP Home SP2.  
  How can I get the laptop to access the printer?
0
slice090697
Asked:
slice090697
  • 4
  • 3
  • 2
  • +2
1 Solution
 
darrenakinCommented:
Ok, first off where is your 10.42.XX.XX getting there IP's from? Server or router? Whatever the case you need to change the scope of the DHCP in the router or on the server to assign DHCP from (for example) 10.42.4.10 - 10.42.4.100 depending on how many IP's you will need. It doesnt sound like many because you only have an 8 port Hub. Now you need to go into the Wireless Router and change the Local IP of the router to (for example) 10.42.4.2 and change the scope on the DHCP for 10.42.4.101 - 10.42.4.150. Give this a try, should work for you.
0
 
RaymunCommented:
you can make a workgroup and share the printer
0
 
Mark PavlakCommented:
I agree with Darrenakin, that would fix your problem.  I also have a suggestion though that would fix your issue and imporve your internal LAN speeds.  This is under the assumption you are really using a "hub".  Hub's are old technology which limit bandiwidth.  With your 8port hub you are taking a 100mps(hopefully) connection and dividing it up by 7.  Inother words you are only getting approx 15mps per port on the hub wether something is connected to a port or not.  This might be insignificant untill it comes down to internal lan traffic, ex. your printers.  I am assuing your Dlink wireless router has at least 4 ports on it.  THis being the case you can simply run the cat5 from the cisco to the WAN on the router.  Setting up the wan port either DHCP or Static depending on the cisco config.  Then attach you 3 pc's to the Dlink via cat5 and use the wireless link.  This will eliminate the bottle neck you have with the hub and effective put all the pcs/laptops/printer shares on the same segment.
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
rpone605Commented:
you could just disable dhcp on the wireless router all together and move the connection to the lan port on the wireless router.  this would make it function as an access point.  i would also consider enabling the mac filter on the wireless router so you can secure it.
0
 
Mark PavlakCommented:
ture but you also need to modify the host address on the Router to match the internal scheme so you can interface with it and configure it
0
 
slice090697Author Commented:
 Ok, while waiting for yoru replies, I called D-Link and asked for assistance with their product, but since I mentioned the work "printer", they freaked out and said it was a Windows sharing issue and refused to assist me.  This is why I go here first, not to manufacturers support lines, they know less than my cat.
  Anyway, I have successfully changed the address of the wireless router to 10.42.4.5.  I set the laptop to get it's address from the router and now I have internet again, but I am unable to ping the other PC's on the network.  I have the router set to Enable DNS Relay.  It will issue addresses from 101 to 199.  
  Any other ideas?  These other 3 PC's and the two printers have been working fine for over 15 years.  The issue is definitely with the new wireless router configuration.
0
 
darrenakinCommented:
See if there is a firewall option in the wireless router that you can turn OFF. No big deal since this router is behind the Cisco
0
 
darrenakinCommented:
Better yet add the IP in the router of the other router to the DMZ
0
 
slice090697Author Commented:
 Do you mean add the address of the wireless router to the DMZ in teh Cisco router?
0
 
slice090697Author Commented:
 OK, latest update!  I have had the wireless router connected to the hub via the WAN port and a straight through cable.  Doing this I have internet, but no access to the rest of the network.  I tried connecting the cable from a regular port to a regular port on the hub.  Now I have no internet, but I can access the rest of the network, including the printers I need.  How can I do both?
0
 
slice090697Author Commented:
 Actually, I just disabled the routers passthrough and server abilities,a nd now everything works fine.  Both internet and local network files and printing.  Thanks for the input anyway.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now