Solved

Incorrectly spelt receipants not being rejected

Posted on 2006-11-21
7
571 Views
Last Modified: 2013-11-15
Hi there, we have an exchange server here that accepts mail from 4 domains.
If a receipant address does not exist it gets rejected for all domains except for one where it gets queued in
'messages queued for deferred delivery'.
I then need to manually delete these emails.
Any ideas on this.

Thanks

0
Comment
Question by:tollair
  • 3
  • 2
7 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 17995783
Which version of Exchange?

Exchange 2000 cannot do this natively, you have to use a third party tool.
Exchange 2003 can do this natively, but it needs to be configured. http://www.amset.info/exchange/filter-unknown.asp

Simon.
0
 

Author Comment

by:tollair
ID: 18000475
I am running exchange 2003 enterprise SP2.
4 out of the 5 domains coming in will reject unknown receipants without the above being configured.
Its just one domain thats not being rejected and queuing on the server.
0
 
LVL 104

Accepted Solution

by:
Sembee earned 125 total points
ID: 18004009
If you haven't got recipient filtering configured in Exchange, then there is no other way of Exchange natively rejecting emails at the point of delivery. Exchange will accept the email and then attempt to send back an NDR. The message isn't being rejected at the point of delivery; point of delivery rejection is considered the best way to deal with misaddressed email.

Don't get rejecting the connection confused with generating an NDR. The processes are very different. Rejecting the connection using recipient filtering forces the sending server to generate the NDR. Accepting the email and then trying to NDR the message means that your server is doing the work.

If you don't have recipient filtering configured then your Exchange server is exposed to a NDR attack.

If the emails are being rejected immediately, with the NDR being generated by the remote server, then you must have something else on the server doing that rejection.

Is there any reason why you don't want to configure recipient filtering? As far as I am concerned there is no reason why you wouldn't want that option enabled.

Simon.
0
 

Author Comment

by:tollair
ID: 18005744
I have enabled this feature, there is still no change.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 18008314
Have you enabled both parts? There is a setting in Global Settings and there is also a setting on the SMTP virtual server.
You then need to restart the SMTP virtual server.
I also strongly suggest enabling the tar pit, if you haven't already.

Then test it by telnetting to the server and attempting to send an email to a non-valid user. You should get an error back.
Don't rely on what the queues show you as that could be showing your old information. Exchange will try and resend email messages for 48 hours by default.

Simon.
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

All of the resources available today make learning a new digital media easier than ever-- if you know where to begin. This is a clear, simple guide to a few of the basic digital art mediums and how to begin learning them on your own.
Developer portfolios can be a bit of an enigma—how do you present yourself to employers without burying them in lines of code?  A modern portfolio is more than just work samples, it’s also a statement of how you work.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
Viewers will learn how to use the Hootsuite Dashboard.

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question