Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1160
  • Last Modified:

Stopping a Network Adaptor Registering itself with DNS

Hi,

My question boils down to "Under Windows Server 2003, how can you stop a Network Adaptor registering it's address with DNS".

The background:-

We're running the "software" VPN Service, Hamachi (www.hamachi.cc) on one of our Domain Controllers/File/Print Servers within an 2003 Active Directory domain.

Hamachi is on the DC purely to allow someone at a regional office access to Files - it is not used to tunnel any AD services such as Domain Authentication.

However, despite turning off the "Register this connection with DNS" option on the Hamachi adaptor, the 5.82.x.x address of the Hamachi Adaptor keeps registering itself in the AD integrated DNS zone.

The result of this is that other DC's in other sites try to use the 5.82.x.x address, and AD replication problems occur.

Once I've manually deleted the 5.82.x.x DNS entry - things spring back into life, but it's a pain constantly having to do this.

The DNS Server itself is only registered to serve addresses on the 192.168.10.2 range. It accepts all Dynamic Updates.

Can anyone suggest how to prevent Hamachi from registering it's details in DNS, so the Adaptor is simply used as a VPN tunnel for the sites that wish to use it?

I also have a thread running at the Hamachi Forums (http://forums.hamachi.cc/viewtopic.php?p=41547#41547) but the Hamachi folk are stumped on this, so I thought I'd turn to the good folks at EE for help. :-)

Regards,

Richard Tubb.
0
netlinkrtubb
Asked:
netlinkrtubb
  • 2
1 Solution
 
oBdACommented:
Verify that your DNS server is only listening on the 192 address, as a DNS server will automatically register all addresses it's listening on, independent of the settings in the DNS tab in TCP/IP properties.
Check here on how to handle/disable automatic registration:
How to enable or disable DNS updates in Windows 2000 and in Windows Server 2003
http://support.microsoft.com/?kbid=246804
0
 
netlinkrtubbAuthor Commented:
Hi ObdA,

Thanks for this.

I've implemented the following change on the Hamachi Adaptor:-

"To disable DNS updates for a particular interface, follow these steps:

1. Click Start, click Run, type regedit, and then click OK.  
2. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ Tcpip\Parameters\Interfaces\deviceID

Note deviceID is the device ID of the network adaptor for the interface.

3. On the Edit menu, point to New, and then click DWORD Value.  
4. Type DisableDynamicUpdate, and then press ENTER two times.
5. In the Edit DWORD Value dialog box, type 1 in the Value data box, and then click OK.
6. Quit Registry Editor."

I'll schedule a reboot of the server out-of-hours (the article states Windows 2000 needs to be re-started, I'm guessing this is true for Windows 2003 too) - then re-enable the Hamachi adaptor, wait for a few hours to see if any problems occur, and get back to you with my findings!

Many thanks again!

Regards,

Richard Tubb.
0
 
netlinkrtubbAuthor Commented:
Hi Obda,

Good news - the Hamachi adaptor hasn't registered itself in the 24 hours since I've rebooted.

So I think it's safe to say that your solution worked. Many thanks!

Regards,

Richard Tubb.
www.netlink-it.com
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now