GRUB geom error after install of suse 9.1

I am trying to install suse 9.1 on a Dell inspiron lap top. This computer has Windows xp already installed. During the install I only had enough space for the minimal graphical system (probably an indication that something was wrong since it has a 120G hard drive that is mostly empty). I tried the install anyway and it went smoothly until the reboot. Then I immediately  got "GRUB geom error". I can boot from the installation CD. Yast gives me the message "it appears this machine already has Linux .. ". Then I take the option "Boot installed system" and it boots ok.

I cannot get into windows at all. If I use the windows installation CD and try the recovery console, I get the message "The path or file specified is not valid C:\>" . It does not seem to "see" the hard drive at all.  

At this point I would be happy just to get Windows xp running again, and re-try the linux installation at a later date. I was just installing linux to learn about it and don't know much about it yet.
morgan_dgAsked:
Who is Participating?
 
ygouthamConnect With a Mentor Commented:
http://www.experts-exchange.com/Operating_Systems/Linux/Linux_Setup/Q_21462711.html

gives you an idea to mount the NTFS partition in your case it is

/dev/hda2

and take the data.  if it is any critical data that you want backed up first, then consider doing so first before doing further damage.  once that is done, then get back to reinstalling windows or something so that you can have a comfortable working windows machine.

do not partition entire 120 GB as a single disk. consider multiple partitions and then pick any one of the smaller areas to install suse. you can already see that you would be quite well off with  a lesser partion size of about 10 GB space which gives ample play area for suse.

RECOVER data first and then do anything ahead.
0
 
ygouthamCommented:
did you try the windows installation cd and attempt to FIX MBR as an option.  

Linux installs grub on the Master Boot Record (MBR) which would have been earlier occupied by the Windows info.  Try that once.  Normally, it is advisable to have different partitions and loading windows and linux on different partitions makes the system work trouble free between the OS.  if you had single partition and have gone ahead with the Linux installation, well you only can reinstall windows all over again.

good luck
0
 
morgan_dgAuthor Commented:
I did load Linux on a different partition. Here is the partition table:

Disk /dev/hda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1           6       48163+  de  Dell Utility
/dev/hda2   *           7       14001   112414837+   7  HPFS/NTFS
/dev/hda3           14002       14409     3277260   db  CP/M / CTOS / ...
/dev/hda4           14410       14592     1469947+   f  W95 Ext'd (LBA)
/dev/hda5           14410       14440      248976   82  Linux swap
/dev/hda6           14441       14592     1220908+  83  Linux

I've tried using the windows recovery console, but it can't find the hard drive. I tried running fixmbr anyway, but I still get the same error when the system is rebooted.
0
 
ygouthamConnect With a Mentor Commented:
it seems that you did not have a separate partition when you tried to install suse and went in to install suse in available free space and linux has created its own partition tables overwriting the windows tables.

you might want to look at some utility to mount NTFS partitions so that the data stored in them can be recovered.

it is always GOOD to have a separate partition CREATED in windows and then install linux in that free partition if you intend to use windows AND linux from the same box.  installing linux in available free space always creates this problem.
0
 
morgan_dgAuthor Commented:
Success! I repartitioned the disk. First I deleted the Linux partitions and the I shrunk the windows partition ( I don't know why this wouldn't work on the original install). Then I reinstalled Linux. I was able to create a large Linux partition (plus a Linux swap partition).  Now everything works perfectly.  I can boot both windows and Linux.

My guess is that the geom error was because the original Linux partition too high in memory for the bios to access. Thanks for the helpful suggestions ygoutham.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.