Solved

Mesh Network with Cisco Routers

Posted on 2006-11-23
20
535 Views
Last Modified: 2013-11-29
Hi guys be hurry

here is me scenario....

i have 3 2501 routers
with V.35 Interfaces ...
want to connect them in 3 different locations ....
Media Provided inbetween is DXX with 64 KBPs....
now i want to connect each of them with each other....

 A                        B                       C
2501>>>>>>>>2501>>>>>>>>2501
10.1.1.1/29        10.1.1.2/29         10.1.1.3/29
 
i know how to connect point to point .... ..means to enabling PPP and HDLC..

but how to connect A with C and C with A and etc.. all of them ...

if  i need to take my serial IP's (A,B,C) in the same subnet ????

and please tell me how to make a mesh ...

if a loopback ip address can be defined  and advertise them into the Subnet ....

so that my traffic can go every where ...

i am running EIGRP for this  WAN cloud ...

and have CSU/DSU on each of location ...

Waiting

ASAd
0
Comment
Question by:annasad
  • 9
  • 8
  • 2
  • +1
20 Comments
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18002469
If it's point-to-point, use a new /30 for each link.

A needs static routes so it can find the BC link, the B LAN, and the C LAN.
B needs static routes so it can find the A LAN and the C LAN.
C needs static routes so it can find the AB link, the A LAN, and the B LAN.
0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18002476
And of course, you could use dynamic routing as well.

Also, since they're P2P media, you could actually use a /31 on the links.
0
 
LVL 1

Author Comment

by:annasad
ID: 18002513
well oky .. i got you ... but i would be comfertable with the Dynemic Routing Protocol..

and from each router i am using one Physical cable V.35 to CSD/DSU... on my each end ...

kindly explain me how to do it ... i am getting you but needs further assistance
0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18002522
You need a second serial port and CSU/DSU on router B.
0
 
LVL 1

Author Comment

by:annasad
ID: 18002534
hmmmm

i have 2 serial ports on every router .....  but how to connect them ????

there would be total of 6 serial ports .....
0
 
LVL 1

Author Comment

by:annasad
ID: 18002540
to tell you what is did is that

 A                        B                       C
2501>>>>>>>>2501>>>>>>>>2501
10.1.1.1/29        10.1.1.2/29         10.1.1.3/29

i just assigned these IPs to serail ports of each router and and advirtise this subnet in EIGRP ...shouldnt if work ????

all in one subnet and adding all to the Routing Protocols ???

0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18002873
If you know how to do it, go for it.  I sure couldn't get it to function that way.
0
 
LVL 9

Expert Comment

by:PeterMac
ID: 18003519
No will not work, because is not single network, you actually have three seperate physical Networks A - B, B - C, and C - A. you will need to supply routing information to tell routers which interface to use to connect to each.

e.g. on A specify route to B via 10.1.1.2 on IF1
       on A specify route to C via 10.1.1.3 on IF2

       on B specify route to A via 10.1.1.1 on IF1
       on B specify route to C va 10.1.1.3 on IF2

      on C specify route to A via 10.1.1.1 on IF1
      on C specify route to B via 10.1.1.2 on IF2

Routers need to know which interface to use to get to which other router.
0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18003783
But you can't have the same subnet on different interfaces, so what you suggest just won't work.
0
 
LVL 9

Expert Comment

by:PeterMac
ID: 18003873
What you specify in routing table is just IP address, and MASK does not have to be full subnet as used by client PC's.
Does mean client PC's at each location need to have seperately MASK-able IP subsets. I do not know any other way to run as single subnet - Broadcast would be OK, routers will just send on all interfaces, but for replies, and normal connections routers need to know which interface to use. If cannot make determination simply will not send anything.

Only other possibility might be to put routers into Gateway mode, not sure if this is possible with 2501 but check documentation, or what it would make of multiple links, have only used Gateway in past to link two seperate physical networks.

Gateway mode essentially does not care what is at other side of connection, simply copies all traffic - like a hub.
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 12

Expert Comment

by:pjtemplin
ID: 18003892
Um, no.

Cisco router interfaces have to have subnet masks.
Cisco router interfaces cannot overlap subnets.
Cisco IOS static routes have to have subnet masks.

OP is using P2P media.  Broadcast is not an option here.

Read some IOS documentation please before reposting.
0
 
LVL 1

Author Comment

by:annasad
ID: 18004185
pjtemplin .... i am getting confuse ... its not that much complex ...
please suggest a SOL ...i am just throwing my Voice which are connected to my Welltech (Voice interfaces )......well for now forget about it .....
and let me know finally how to make it ....

i am also pasting all the running config here for all three routers ... so you just have a look on it ...

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>


KRI >>>>>>>>>ISB>>>>>>>>LHR


form City Lahore



LHR#sh runn
Building configuration...

Current configuration : 772 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
hostname LHR
!
logging console emergencies
enable secret 5 $1$Xz60$w.RFPyS81SuqFFwg7Bh/9.
!
!
!
!
!
ip subnet-zero
!
!
!
 --More--         !
interface Ethernet0
 ip address 164.168.10.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.3 255.255.255.248
 no keepalive
 no fair-queue
 clockrate 56000
!
interface Serial1
 no ip address
 shutdown
 clockrate 56000
!
interface TokenRing0
 no ip address
 shutdown
!
router eigrp 1
 network 10.0.0.0
 network 164.168.0.0
 --More--          auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

LHR#
LHR#
LHR#


###############################################3

KHI#sh runn
Building configuration...

Current configuration : 772 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
hostname LHR
!
logging console emergencies
enable secret 5 $1$Xz60$w.RFPyS81SuqFFwg7Bh/9.
!
!
!
!
!
ip subnet-zero
!
!
!
 --More--         !
interface Ethernet0
 ip address 192.168.1.4 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.2 255.255.255.248
 no keepalive
 no fair-queue
 clockrate 56000
!
interface Serial1
 no ip address
 shutdown
 clockrate 56000
!
interface TokenRing0
 no ip address
 shutdown
!
router eigrp 1
 network 10.0.0.0
 network 192.168.1.0
 --More--          auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

KHI#

############################################


LHR#sh runn
Building configuration...

Current configuration : 772 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
hostname LHR
!
logging console emergencies
enable secret 5 $1$Xz60$w.RFPyS81SuqFFwg7Bh/9.
!
!
!
!
!
ip subnet-zero
!
!
!
 --More--         !
interface Ethernet0
 ip address 172.168.10.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.3 255.255.255.248
 no keepalive
 no fair-queue
 clockrate 56000
!
interface Serial1
 no ip address
 shutdown
 clockrate 56000
!
interface TokenRing0
 no ip address
 shutdown
!
router eigrp 1
 network 10.0.0.0
 network 172.168.10.0
 --More--          auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

ISB#




whatelse i need to do ????????


plz be precise ......


0
 
LVL 12

Accepted Solution

by:
pjtemplin earned 500 total points
ID: 18004411
On R1, make S0 10.0.0.1 255.255.255.252.
On R2, make S0 10.0.0.2 255.255.255.252.
On R2, make S1 10.0.0.5 255.255.255.252.
On R3, make S0 10.0.0.6 255.255.255.252.

R1 S0 to R2 S0.
R2 S1 to R3 S0.
0
 
LVL 1

Author Comment

by:annasad
ID: 18005944
ok ..... well you see if i need to reach from LHR to ISB ....LHR will first go to KHI who will forward his request to ISB?????

dont you think so if would work some thing like this ?????


1 >>>>>>>>>>>>>>>>>>>2>>>>>>>>>>>>>>>>>>>>3

in this case i am not directly connected to point 3 ...i will have to go to point 2 in order to send some traffice from 1 to 3.

please explain me this ....


Regards
ASad
0
 
LVL 1

Author Comment

by:annasad
ID: 18005981
and if 2 is down ...the my trafiice from 1 to 3 will not be able to forward ... and
tell me what are these LOOPBACK INTERFACES .......if we define a loopback interface and advertise its subnet in routing protocol...will it make difference ...


regards
ASAD
0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18006067
Loopback interfaces won't make a difference here.  You're not using BGP.

If you have a circuit directly from R1 to R3, you could set it up from R3 S1 (10.0.0.9/30) to R1 S1 (10.0.0.10/30).
0
 
LVL 1

Author Comment

by:annasad
ID: 18006715
but in that case i will have to use both of Serial interfaces of Each router..............???

what i could understood....and offcourse they should make thier Media Like this ...becasue i need a mesh ...

do you think so that my all trafiic would reach at point 3 from 1 ...what you explained earlier ????

Regards
ASAD
0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18007356
What I've suggested will work.

If YOU have a better way to do it, ignore the experts and do it.
0
 
LVL 5

Expert Comment

by:jeffkell
ID: 18011590
If you're really using DXX, you should be just fine with the serial IPs and EIGRP advertisements.  Some of the answers offered seem to think you're doing point-to-point serial between your routers, and that isn't DXX.  If it is DXX, your serials should be already meshed by the DXX cloud and on the same subnet, so there should be no "routing" issues with getting the three routers to at least talk to each other.

What concerns me is that you have all of the serials configured with 'clockrate 56000' which has your routers providing clocking.  There's no line clock source on your DXX interface?  Are you actually getting connectivity between the three?  You can ping the 10.x.x.x interfaces?

Until you get to that point, the routing isn't the problem [yet].  Your routing configuration looks [essentially] OK.
0
 
LVL 1

Author Comment

by:annasad
ID: 18014315
well pjtemplin
i am going to work on your way and then i will let you know that it worked or not ... and also Jeffkkell i am pretty sure that we are going to use DXX media ...
and thats why i made this configurations ...but instantly they are saying me that we will not be able to have three routers in the same subnet ... Either you use all with the 2nd Serial interface to make it point to point or run Frame Relay which i think not possible as dont have the Frame Relay Switch...

what you suggest me...n
pjtemplin.... i m not here to disagree with your respectful help ..but just using my little brain over it .. so plz be calm and dont angry with me ... you have really helped me as you are replying me from a quite time .. so please dont be angry

Thanks for your patience


Regards
ASAd  


0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now