IIS Settings for OWA reset on reboot of server

I have a Windows 2K3 server (standard) running Exchange 2003. I have OWA working fine on this box (all one server).

If we reboot the server then the IIS settings reset to incorporate IWA (Integrated Windows Auth) and sets the defauly domian to be "\". We don't want or need this. User then have to log in using "domain\username" or "username@domain". We have to take off IWA and set the default domain to be "domain". Do an iisreset from cmd and hey hey it works.

The reboot also resets our OWA spell checker and we have to reset the IWA on the /Exchweb Vir Dir.

Its a reall pain because some of our techs never remeber to change the settings back!

Please help!
LVL 13
Mark GalvinManaging Director / Principal ConsultantAsked:
Who is Participating?
LeeDerbyshireConnect With a Mentor Commented:
Where are you configuring the auth settings - IIS Manager or Exchange System Manager?  The correct place is ESM, because the ESM settings overwrite any settings made in IIS Manager.  Make sure you are going to Servers/<servername>/Protocols/HTTP/Exchange Virtual Server/Exchange to make these settings.
Mark GalvinManaging Director / Principal ConsultantAuthor Commented:
The changes are not being made in ESM. I will check there.

Mark GalvinManaging Director / Principal ConsultantAuthor Commented:
I have made the change for "Exchange" under the Default Web Site in ESM but there is no "Exchweb" for the Spell Checker problem.

I am waiting forthe next reboot to test.
I am not sure what is causing the spell checker problem.  You will not find ExchWeb in ESM.  Note that by default, the ExchWeb VDir has Anonymous Access enabled, not Integrated Auth.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.