Solved

Can't install drivers Netgear NIC

Posted on 2006-11-23
11
334 Views
Last Modified: 2010-05-18
I am trying to install the drivers for a Netgear PCI (10/100) NIC (FA311) onto a fresh Fedora Core 5. When installing Fedora I chose to install ALL options, used yum to check for and install all updates and changed SELINUX to permissive for the time being. When I try to install the drivers for the Netgear NIC, using the MAKE ALL command, I get a series of errors beginning with:

ccl:  error:  /lib/modules/2.6.18-1.2239.fc5/build/include/linux/modversions.h:  No such file or directory

0
Comment
Question by:john1ireland
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 3
11 Comments
 
LVL 14

Assisted Solution

by:pablouruguay
pablouruguay earned 50 total points
ID: 18006925
ok. the kernel dont have the headers.. download the kernel headers and soruces for this version of kernel and all works fine.
0
 
LVL 38

Accepted Solution

by:
wesly_chen earned 450 total points
ID: 18008024
You need to install kernel-devel package for those header files.
As root, run
# yum install kernel-devel

Then recompile the Netgear NIC driver.
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 18009807
yes the development package too....  

ps. hey wesly time to didnt see you! welcome again!!!  :)
0
Don't Miss ATEN at InfoComm 2017!

Visit booth #2167 to see the  new ATEN VM3200 32 x 32 Modular Matrix Switch. Other highlights include the VE8950 4K HDMI Over IP Extender, VS1912 12-Port DP Video Wall Media Player  and VK2100 ATEN Control System. Register now with Free Pass Code ATEN288!

 

Author Comment

by:john1ireland
ID: 18011636
Thank you, but am still having the same problem, as shown in the highlights below. This is after installing the kernel-devel. Only additional point I can think of is that the drivers available from netgear are for kernel 2.2. or 2.4, whereas the kernel in Fedora is 2.6:

'gcc -D__KERNEL__ -DMODULE -DMODVERSIONS -D__init="" -D__exit="" -D_DRIVER_ -DNETGEAR_DEV=310 -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -pipe -w -I/lib/modules/2.6.18-1.2239.fc5/build/include -include /lib/modules/2.6.18-1.2239.fc5/build/include/linux/modversions.h -g -c fa3xx.c

cc1: error: /lib/modules/2.6.18-1.2239.fc5/build/include/linux/modversions.h: No such file or directory
In file included from /lib/modules/2.6.18-1.2239.fc5/build/include/asm/thread_info.h:16,


Any other suggestions? Thanks.
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 18011829
yep other solution is install via ndiswrapper
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 18012032
Could you provide the following result:
ls /lib/modules/2.6.18-1.2239.fc5/build/include/linux/mod*.h
ls /lib/modules/2.6.18-1.2239.fc5/build/include/mod*.h
uname -a
rpm -q kernel-devel

Usually, the driver written for 2.4.x kernel might not compatible to 2.6.x kernel. You need to download the driver for 2.6.x kernel for better luck.
0
 

Author Comment

by:john1ireland
ID: 18012444
Here is the output requested:

[root@localhost ~]# ls /lib/modules/2.6.18-1.2239.fc5/build/include/linux/mod*.h
/lib/modules/2.6.18-1.2239.fc5/build/include/linux/mod_devicetable.h
/lib/modules/2.6.18-1.2239.fc5/build/include/linux/module.h
/lib/modules/2.6.18-1.2239.fc5/build/include/linux/moduleloader.h
/lib/modules/2.6.18-1.2239.fc5/build/include/linux/moduleparam.h


[root@localhost ~]# ls /lib/modules/2.6.18-1.2239.fc5/build/include/mod*.h
ls: /lib/modules/2.6.18-1.2239.fc5/build/include/mod*.h: No such file or directory


[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.18-1.2239.fc5 #1 Fri Nov 10 13:04:06 EST 2006 i686 athlon i386 GNU/Linux


[root@localhost ~]# rpm -q kernel-devel


kernel-devel-2.6.18-1.2239.fc5

Thanks. (I tried ndiswrapper, but ran into a problem with that route)
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 18013809
As root, try
# updatedb
# locate modversions.h
to see if you can find the modversions.h in your system somewhere such as /usr/src/linux-2.x.x/include/config/...
Then copy modversions.h to /lib/modules/2.6.18-1.2239.fc5/build/include/.

Or you can install the kernel src rpm.
# rpm -ivh ftp://zeniv.linux.org.uk/pub/distributions/fedora/linux/core/updates/5/SRPMS/kernel-2.6.18-1.2239.fc5.src.rpm
Then
# updatedb
# locate modversions.h
to find the modversions.h.
0
 

Author Comment

by:john1ireland
ID: 18015893
I moved the modversions.h  to the location specified, but it still provies the same result. Question: The instructions with the Netgear Readme did not specify where the .c, .h and makefile needed to be copied before trying to compile. Is there a specific place they must be?
Thanks.
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 18017258
> I moved the modversions.h  to the location specified, but it still provies the same result.
Which error message is the same? Still complain
"cc1: error: /lib/modules/2.6.18-1.2239.fc5/build/include/linux/modversions.h: No such file or directory"
or others?

By default, it looks for system and kernel library/include files in
/lib/modules/`uname -r`/build/include/linux/
0
 

Author Comment

by:john1ireland
ID: 18049202
I am sorry for delay in update.

When I said that I tried to move modversions.h and it produced the same result...I meant that I got the message
"cc1: error: /lib/modules/2.6.18-1.2239.fc5/build/include/linux/modversions.h: No such file or directory"
I noticed later that the size of that file (??) is 0  (significant, ???).
In any event, I deeply appreciate the prompt and excellent advice from wesley chen and pablouruguay. I will continue to work on this with more self study before making further postings. You at least inspired someone to pursue linux to a much deeper level and it is encouraging to know that there are people willing to share their time and effort with those trying to break into new territory.
Thanks again and I'll get the well earned points out.

 
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question