?
Solved

CUPS "lost" connection to my printer

Posted on 2006-11-23
7
Medium Priority
?
2,613 Views
Last Modified: 2013-12-15
Hi experts !

    I have a Kyocera FS-820 (BW Laser Printer) that worked for a long time on my Linux distro.  I bought a new computer, re-installed my distro, and now, I have problems with my printer.  On three different Linux install (two Gentoo, one archLinux).  My goal is to install it on my Gentoo server.

    The problem I have is that Cups "lost" the connection to my USB printer after a short time.  If I power down and then power up my pinter, Cups will see it, and I will be able to print, and the result is perfect.  But if I wait like 30sec or 1min, and I try to print again, Cups will tell me "printer not connected; will retry in 30 seconds".

    If I do: "lpinfo -v"

The result after I started the printer:
------------------------------------------------
network socket
network beh
network http
network ipp
direct usb://Kyocera/FS-820
network lpd
direct parallel:/dev/lp0
direct scsi
serial serial:/dev/ttyS0?baud=115200
------------------------------------------------

After about 30sec:
------------------------------------------------
network socket
network beh
network http
network ipp
network lpd
direct parallel:/dev/lp0
direct scsi
serial serial:/dev/ttyS0?baud=115200
------------------------------------------------

    As you can see, the USB printer is not there anymore.  The "usblp" module is compiled directly in my kernel (not as a module).

    It was working in the past, and I've even installed a Windoz to validate that it's not my printer, and it work great in Windoz.

Any idea ?
Thanks a lot !
Have a nice day !
Xor
0
Comment
Question by:BGMi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 

Author Comment

by:BGMi
ID: 18008572
Ok ... tried something new.  If I do: "echo "test" > /dev/usb/lp0", it will wake up the printer and print the result with success.  But still won't print if I try via Cups.

Thanks for your help !
Xor
0
 
LVL 40

Expert Comment

by:noci
ID: 18019529
gentoo recently (last weeks) upgraded the cups system from 1.1.23 -> 1.2.6,
have you tried that one allready?

0
 
LVL 40

Expert Comment

by:noci
ID: 18019752
And what does lsusb show when the printer is offline.
0
WordPress Tutorial 1: Installation & Setup

WordPress is a very popular option for running your web site and can be used to get your content online quickly for the world to see. This guide will walk you through installing the WordPress server software and the initial setup process.

 

Author Comment

by:BGMi
ID: 18020968
Thanks for your answers.

  I currently have Cups 1.2.7.  The latest build under "unstable".

  The "lsusb" command return:

Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 019: ID 0482:0010 Kyocera Corp.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

  And the "lpinfo -v" command still don't see it.

Thanks for your help !
Xor
0
 
LVL 40

Accepted Solution

by:
noci earned 2000 total points
ID: 18021867
For the USB system it is not off-line, that definitely makes it a cups issue.

It might be that the usb code does a check wrong, as "printing" to the file
/dev/usb/lp0 works.

Can you try to use the url: "file:/dev/usb/lp0"
it might help. The problem then is that is there are more printers
the order might change, and that shouldn't be the case with usb:/...

If the Kyocera can handle HP compatibility, you could try the hplip package.
(that's an intermediate between cups and hp printers).
0
 
LVL 40

Expert Comment

by:noci
ID: 18021875
The hplip might need some tweeking for usb-id etc.
0
 

Author Comment

by:BGMi
ID: 18024041
Thanks a lot Noci !

    The "file:/dev/usb/lp0" workaround did the trick !  In my case, I will not connect other printers to this computer/server ... so the printer address shouldn't change in the future.

    I think my printer is HP compatible ... remember seing that on linuxprinting.org.  But I don't really have a lot of time for that ... and prefer a "faster" way to do it !

    So, for other passing by, what I did, is change the line "DeviceURI usb://Kyocera/FS-820" to "DeviceURI file:/dev/usb/lp0" in file "/etc/cups/printers.conf" (I already had earlier the printer via CUPS, as an USB printer).  I've restarted Cups, and everything works nice now, thanks to Noci :)

Thanks again !
Xor
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Microsoft Office Picture Manager is not included in Office 2013. This comes as a shock to users upgrading from earlier versions of Office, such as 2007 and 2010, where Picture Manager was included as a standard application. This article explains how…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
Suggested Courses
Course of the Month12 days, 6 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question