Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Linux (Ubuntu) Can't copy image to a fat32 partition due to access permissions - Simple for linux user

Posted on 2006-11-23
3
519 Views
Last Modified: 2013-11-15
Hi, I have recently installed UBUNTU, i'm trying to install another image to a different partition on the same SATA II hard drive.

My machine:
Intel Core Due E6300 @ 1.86
1024MB DDR667 Corsair Memory
2 x 250GB Sata II Seagate Hard Disk
ConRoeXfire-eSATA2 - Motherboard
Intel Extreme Graphics onboard
ATI Radeon X1600PRO 512MB - Pci-e Slot

Hard Drive 1(HD1): 4 Partitions,
Partition 1 - Vista 80gb NTFS Primary
Partition 2 - Ubuntu 80gb EXT2 Primary
Partion 3 - Linux Swap 400 MB LINUX SWAP
Partion 4 - Empty FAT32 Primary

Hard Drive 2(HD2): 1 partition Windows XP professional

So i tried the command

dd bs=1048576 if=./image.img of=/dev/sda4 (as i have been instructed but the website i got the image from.)

from the folder containing the image(on a usb hard drive) and I get an error message
"You do not have permission to access this disk" or something similar

when i go to /dev/sda4 and right click it says I don't own the disk, any tips?!

It's a bootable image that i'm trying to instal,
Sorry it's not many points it's all i have left

Thanks,
Gav
0
Comment
Question by:GavinAiken
3 Comments
 
LVL 27

Assisted Solution

by:Jason Watkins
Jason Watkins earned 50 total points
ID: 18005355
It sounds like you must mount the NTFS volume in Ubuntu first.  NTFS read/write capability in Linux is sketchy at best.  

Can you use VMWare to mount this image?

/F
0
 
LVL 1

Accepted Solution

by:
Sandeepraj earned 55 total points
ID: 18005668
I'm not sure but sound like the rare one that annoying some people

It doesnt matter that you logged in as an admin account.It becouse an
app has changed registry keys permissions so your user account doesnt
have permission, weather you an admin or not. You'd have to go into your
registry useing regedit, right click the keys and directries, then permissions
and set the permissions back to full read write for your account.

The other possabilty is youve disabled some windows services that
are needed....


Regards
Sandeep raj
0
 

Author Comment

by:GavinAiken
ID: 18010418
Ok so eventually i found out that i just need to put the word sudo in front of the command in Ubuntu to act as the root user for the command, tahnks for your help guys but the solution was actually incredibly simple due to the way Ubuntu works.

Gav
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In a recent article here at Experts Exchange (http://www.experts-exchange.com/articles/18880/PaperPort-14-in-Windows-10-A-First-Look.html), I discussed my nine-month sandbox testing of the Windows 10 Technical Preview, specifically with respect to r…
In this article we will discuss all things related to StageFright bug, the most vulnerable bug of android devices.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question