• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 883
  • Last Modified:

Auto sequence in a table

How do I stop Access from auto filling the next record if it spots a sequence?

eg. In a text field if it put the following records in 1,2,3 it will automatically put a 4 in the next record.

I understand I can stop this if adding to a form but I can't figure out how to stop it when adding directly to the table.

Thanks!
0
sbiddle
Asked:
sbiddle
1 Solution
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
You can't stop it when adding data directly to a table. More importantly, your users should NEVER be adding data directly to a table.
0
 
rockiroadsCommented:
I take it this is a autonumber field? if so then this is how Access works. Once u create a new record, it automatically gets the next available number and assigns it to you.

What is the exact issue though, why would u want to stop it?

Is it the sequence u are worried about? u can generate random numbers
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
rocki: I don't think this is an autonumber field, but is instead a standard Numeric or Text field ... if you fill in the first record with 1, the second with 2, then Access will automatically insert a 3 in the third, and a 4 in the fourth, and so on ...
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
rockiroadsCommented:
oh, I know what u mean now, durr!!!! having a thick idiot moment there :)
yes, Ive seen that, Ive not seen anything round that, nothing in autocorrect that ive seen either
0
 
sbiddleAuthor Commented:
It's just a normal text field.  Also happens on a form set to datasheet.  Thought if I could control it on the table itself that would be the best place to start.  Setting the default for the field to Null seems to work but it's not really what I want.

I thought maybe I was missing a setting somewhere as most things can be controlled - but not this it seems!
0
 
GRayLCommented:
What version of Access?
0
 
Jeffrey CoachmanMIS LiasonCommented:
sbiddle,

In the Table, put an Input mask of:
999

This will allow up to a three digit number and disable the auto-sequence.

For larger numbers, simply increase the mask:
99999999


OR

Use a sequence other than 1,2,3,4  or 2,4,6,8

Instead, try to use a sequence of 10's (Typing 10 then 20 WILL NOT produce a 30 in the next row)
(A sequence of 3's or 5's WILL NOT auto-sequence either.

Jeffrey Coachman
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now