Solved

Why does IE keep trying to connect through my VPN connection?

Posted on 2006-11-24
13
439 Views
Last Modified: 2010-05-18
This is driving me nuts!!  I created a vpn connection on my windows xp pro machine.  When I try to use IE6 it continually tries to connect through my vpn connection (I have a dsl connection already).  I have set the internet connection properties to NEVER dial a connection, but it seems to ignore this setting.  If I remove the vpn connection from the list of dialup/vpn connections it deletes the vpn connection!  Any help appreciated.
0
Comment
Question by:dhenderson12
  • 5
  • 4
  • 2
  • +2
13 Comments
 

Author Comment

by:dhenderson12
ID: 18008565
Let me add that MS Outlook, as well as anything else that connects to the internet, does the same thing .... tries to connect through the vpn connection.
0
 
LVL 30

Expert Comment

by:IanTh
ID: 18009237
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 18009506
Most likely because the Network Settings on the VPN connection are configured to use the Remote Gateway.   On your VPN connection's properties > Networking Tab > Internet Protocol (TCP/IP) > Properties > Advanced... is "Use default gateway on remote network" checked?  if so, uncheck it.

Other possibility... in Internet Properties > Connections > LAN Settings... make sure Automatic Configuration boxes are unchecked.

Jeff
TechSoEasy
0
 

Author Comment

by:dhenderson12
ID: 18011964
Thanks for the replies.
"Use default gateway" is unchecked.  Automatic configuration check boxes are also unchecked.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 18013376
Check your HOSTS file in C:\Windows\System32\drivers\etc\ to make sure that there are no entries that would cause this.  Also, there should NOT be an LMHOSTS file (just LMHOSTS.sam)

Jeff
TechSoEasy
0
 
LVL 14

Expert Comment

by:Ehab Salem
ID: 18018411
Is this happening when the VPN is established, or it tries to connect to VPN?
If the VPN is established, all traffic will be forced thru it.
0
Network it in WD Red

There's an industry-leading WD Red drive for every compatible NAS system to help fulfill your data storage needs. With drives up to 8TB, WD Red offers a wide array of solutions for customers looking to build the biggest, best-performing NAS storage solution.  

 

Author Comment

by:dhenderson12
ID: 18020679
Jeff,
   There are no entries in the HOSTS file and nothing in the LMHOSTS file (an empty file is as good as no file at all in this case right?).  I did go ahead and delete the LMHOSTS file but the problem is still there.

Just to be clear:  IE tries to start the vpn connection and I have to keep disconnecting it or (if I'm fast enough) hit the "Cancel" button when it starts up.  
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 250 total points
ID: 18025316
Please check this key in your registry: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\EnableAutoDial and make sure that it's set to "0".  

If the key is not there, then you will need to add it as a DWORD.

If it is there and correct, please log onto that computer with a different user account and see if you experience the same behavior.

Jeff
TechSoEasy
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 18025344
Actually... I think I may have just realized what's going on.  If your VPN connection is configured to use the remote network as the default gateway, then it is controlling this behavior.

Please open your VPN connection properties > Networking > Internet Protocol (TCP/IP) > Properties > Advanced.  Uncheck the box that says "Use default gateway on remote network"

Jeff
TechSoEasy
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18030583
Silly question.....I havent seen anyone touch on the basics yet, soI figure I would jump in with it.....

IE>Tools>Options>Connections> Make sure you dont haev your VPN set as the default......Most apps will get their Internet Settings from IE....
0
 
LVL 14

Expert Comment

by:Ehab Salem
ID: 18034808
Try to install ZoneAlarm an it will tell you which app is trying to access the inet, and to which IP an dfrom which IP.
0
 

Author Comment

by:dhenderson12
ID: 18045888
The actual answer to the question, at least for my computer, is that after making sure all the settings are correct you need to do a power-down of the computer ... doing restarts did not help, but a cold boot seems to have done the trick.
0
 

Author Comment

by:dhenderson12
ID: 18045891
Thanks to all who responded.  I am awarding the points to Jeff (TechSoEasy).
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Join & Write a Comment

Greetings, Experts! First let me state that this website is top notch. I thoroughly enjoy the community that is shared here; those seeking help and those willing to sacrifice their time to help. It is fantastic. I am writing this article at th…
This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now