rpc unavailable errors

I have a server that I need to get into but everytime I try to remote desktop in:

I get an rpc unavailable error

I can bounce the machine but it still gives the same error after it comes back up. The rpc service is running on the machine.


Does anybody have any idea how I can get into this server without having to be at the console??


Thanks for any help
LVL 1
andrew_89Asked:
Who is Participating?
 
wpgatrelConnect With a Mentor Commented:
Have any changes, that you know of, been made to that node that hasn't been made on any of the others?  Hardware or Software.

Can you post the entire output of the NETDIAG results?
0
 
andrew_89Author Commented:
Also , when using remote desktop I can actually get to the login screen and provide credentials. After I give credentials is when the rpc server unavailable error happens.
0
 
wpgatrelCommented:
Is this server a Domain Controller or a Member server?  If it is a member server, does it have the Firewall turned-on on the NIC?

Can you ping it's  own IP address from the command prompt?
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
andrew_89Author Commented:
this is a cluster node and ha firewall off. I can ping by ip or hostname. I cant do anything that requires rpc on it though. However because there is an internal heartbeat connection on it , I ws able to reboot and look at services via WMI.


0
 
andrew_89Author Commented:

Here is the event log error

Logon rejected  Unable to obtain Terminal Server User Configuration. Error: The RPC server is unavailable.
0
 
wpgatrelCommented:
Have you checked everything with Active Directory to make sure it is healthy and also make sure that the TCP/IP NetBIOS Helper service is running on the server?

Also, this isn't by chance a K12 educational server is it?  I've seen a piece of software common to K12 institutions shutdown ALL networking services once an attempt was made to log onto the server either at the console or via T/S.
0
 
andrew_89Author Commented:
Yes the TCP/IP NetBIOS Helper is running and AD is fine. I have 100+ other services which have no issues. This seems to be an  issue with something local to this server.

No this is not a k12 educational server.
0
 
andrew_89Author Commented:
I was able to ssh into this server via the internal heartbeat connection. I ran netdiag and got the output below> Any ideas on how to fix this?????

DC list test . . . . . . . . . . . : Failed                                                                                    
    'NT': No DCs are up.                                                                                                        
                                                                                                                               
                                                                                                                               
Trust relationship test. . . . . . : Failed                                                                                    
    'NT': No DCs are up (Cannot run test).                                                                                      
    Secure channel for domain 'NT' is to '\\nt-dc1.nt.com'.                                                                    
                                                                                                                               
                                                                                                                               
Kerberos test. . . . . . . . . . . : Failed                                                                                    
        [FATAL] Kerberos does not have a ticket for host/nt-srch1.nt.com.                                                      
                                                                   
0
 
andrew_89Author Commented:
Also, the dcs are up and have no issues. All 100+ of the other member servers are fine and there are no other kerberos issues.
0
 
andrew_89Author Commented:
Gathering Winsock information.                                                                                              
    Testing DNS                                                                                                                
    Testing redirector and browser... Failed                                                                                    
    Testing DC discovery.                                                                                                      
        Looking for a DC                                                                                                        
    Cannot get information for DC nt-dc1.nt.com. [ERROR_BAD_NETPATH] Assume it is down.                                        
        Looking for a PDC emulator                                                                                              
    Cannot get information for DC nt-dc2.nt.com. [ERROR_BAD_NETPATH] Assume it is down.                                        
        Looking for a Windows 2000 DC                                                                                          
    Gathering the list of Domain Controllers for domain 'NT'                                                                    
    Testing trust relationships... Failed                                                                                      
    Testing Kerberos authentication... Failed                                          
0
 
andrew_89Author Commented:
I have reolved this issue. I reset the tcp/ip via netsh:

netsh int ip reset

I manually added the dc to the lmhost file: (this was to force it to use the pdc and make sure it knew how to get to it for kerberos)
10.1.1.1     "domain_name  \0x1c #pre
10.1.1.1     "domain_name  \0x1b #pre

I then rebooted the machine and let it pull a dhcp address.

Now, I could connect via rdp with the dhcp address. The last step was to go back and change all the ip configs for the nics back to the correct address and mask.

After this the netdiag output returned no errors and all was well.



thanks
0
 
andrew_89Author Commented:
thanks for your help! you pointed me in the right direction....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.