Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Wireless and Wired Connection Priority

Posted on 2006-11-24
3
Medium Priority
?
2,663 Views
Last Modified: 2009-09-02
So I have a laptop running WinXP Home.

As most laptops nowadays do, it has both a regular LAN connection and a wireless connection.

We have the wireless connection configured to DHCP off a router on the 10.10.60.0/24 subnet which has Internet connectivity, and the wired connection configured to DHCP off another router on the 192.168.0.0/24 subnet which does not have Internet connectivity.

When both interfaces are enabled, trying to ping to the outside world fails. Cannot load up any webpages either.

With the wired connection disabled, it will load up webpages fine.

So, from this, I will assume that when both interfaces are enabled, it is trying to use the wired connection instead of the wireless.

Is there some way to tell it to use the wireless connection instead?

When the machine has connections to two subnets, how does it know which one to use anyway?
0
Comment
Question by:ISoul
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 18009994
>from this, I will assume that when both interfaces are enabled, it is trying to use the wired connection instead of the wireless.
That is correct.

You can easily manipulate the routing table, and tell Windows not to use automatic metric for network connection.
TCP/IP properties, Advanced [x] Automatic Metric  is checked by default...

Take a look at C:\>route print to see which has priority. This is how Windows knows which gateway to use.
0
 
LVL 10

Author Comment

by:ISoul
ID: 18010004
Cool. Never knew about that metrics setting. I see a lower metric number means higher priority.

Got it working as I want now. Thanks!
0
 
LVL 7

Expert Comment

by:knightrider2k2
ID: 18010005
What you have to do is, take the default gateway OFF the wired connection.

There should be only one default gateway configured that is on the wireless connection.
0

Featured Post

Sign your company up to try the MB 660 headset now

Take control and stay focused in noisy open office environments with the MB 660. By reducing background noise, you can revitalize your office and improve concentration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question