[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Windows 2003 x32 AD to Windows 2003 R2 x64 AD

Posted on 2006-11-25
11
Medium Priority
?
999 Views
Last Modified: 2008-01-09
Hi

 I am running two DC both running Windows 2003 32-bit.  We recently bought a new server to replace the main domain controller.  Of course the new server is Windows 2003 R2 x64.  I moved over the the catelog & FSMO to the backup DC.  I removed what was our primary Domain Controller from the Active Scheme & removed it physically from the network.  I put the replacement server in its place and added it to the AD as the same name as the old server with the same IP address.  My problem comes when trying to run DCPROMO on the windows 2003 R2 x64 server.  I get the following error:

"The version of the Active Directory schema of the source forest is not compatible with the version of Active Directory on this computer."

From what I've read about the issue it seems that I need to run the adprep.exe from the Windows 2003 R2 x64 CD2 on the exsisting DC(Windows 2003 32-bit).  It would appear the AD Scheme upgrades doesn't have as much to do with 32-bit vs. 64-bit, but with the fact that the new server is running Release 2.  I ran this adprep on the current domain controller (windows 2003 32-bit) and it gives me the following error:

"The image file .....ADPREP.EXE is vaild, but is for a machine type other than the current machine."

If I try to run this same adprep on the DC I'm trying to promote I get an error telling me it needs to be a DC first.  

Has anyone come across this issue before?

Thanks,
Aaron

0
Comment
Question by:dresch26
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
11 Comments
 
LVL 85

Accepted Solution

by:
oBdA earned 1000 total points
ID: 18012601
Interesting problem. Unless you have a x32 version of R2, you can try to just reinstall the new DC, but use the first disk *only*, do NOT continue the setup with the second disk. Then run dcpromo on the new DC (which should now be just a regular Server 2003 SP1). Once dcpromo has been finished successfully, run the adprep from the second DC, and finally continue the R2 setup from the second CD.
0
 

Author Comment

by:dresch26
ID: 18012621
Intresting point.  I will try that tomorrow morning.  I had to reinstall the OS directly out of the box as Dell made a 12GB OS partition leaving the other 50Gb for who knows what.  I ran the dcpromo after running the 2nd CD.  

 I ran dcdiag on the working Domain contoroller and it came up with only one error which I don't know is the overall issue or jsut a potential issue that hasn't shown it's face yet becasue it's the weekend. I think the host is the old DC that I removed.

   Testing server: DOMAIN\PRIMARYDC
      Starting test: Connectivity
         The host 25f5a121-6b55-4184-821c-5bdea4dddbd3._msdcs.DOMAIN.COM could not be resolved to
an
         IP address.  Check the DNS server, DHCP, server name, etc
         Although the Guid DNS name (25f5a121-6b55-4184-821c-5bdea4dddbd3._msdcs.DOMAIN.COM)
         couldn't be resolved, the server name (PRIMARYDC.DOMAIN.COM) resolved to the IP address
         (192.168.9.21) and was pingable.  Check that the IP address is registered correctly with
         the DNS server.
         ......................... PRIMARYDC failed test Connectivity

Doing primary tests

   Testing server: DOMAIN\PRIMARYDC
      Skipping all tests, because server PRIMARYDC is
      not responding to directory service requests
0
 
LVL 85

Expert Comment

by:oBdA
ID: 18012854
Depends on what you mean with "removed" when you talk about the old machine. Did you run dcpromo on it to depromote it properly, or did you just shut it down and deleted the account? Seems like the latter to me. If you didn't run dcpromo, you need to do some cleanup before you can run dcpromo on the new machine.
How to remove data in Active Directory after an unsuccessful domain controller demotion
http://support.microsoft.com/?kbid=216498
0
Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

 

Author Comment

by:dresch26
ID: 18013918
I ran the dcpromo on the old machine to demote it.  At the time it was running DHCP & DNS.  It appeared to transfer the responsibilities over to the existing DC no prob.  I was looking at the previous issue.  It seems a rogue entry in the DC's DNS was causing the issue.  Our network is 192.168.9.x.  The previous person had put 198.x.x.x for DNS lookup, so when I took down the only good entry it didn't know what to do.  All in all, I feel pretty good about the state of AD.  I will be heading into work soon to reinstall the OS as suggested & try a DCPROMO before installing any bits from CD2.  That is a good link non the less, I found some very intresting information in there.

Thanks,
Aaron
0
 
LVL 51

Expert Comment

by:Netman66
ID: 18014174
Don't do anything destructive.

Call MS PSS and ask for private Hotfix - 919151.

See this for more detal.

http://www.msblog.org/2006/05/09/trying-to-upgrade-the-schema-using-r2-64bit-cd-on-an-existing-32bit-windows-server-2003-sp1/
0
 

Author Comment

by:dresch26
ID: 18014281
You beat me to it!!  I will call them tomorrow to get the hotfix, One bit I read was that running an adprep from a Windows 2003 x64 (non R2) would do the trick, but that didn't work.  
0
 
LVL 51

Assisted Solution

by:Netman66
Netman66 earned 1000 total points
ID: 18014294
The process would be to install R2 x64 from CD1 and BEFORE adding R2 to it you would DCPROMO it into the domain and move the Schema Master onto it.  Once that's done, adprep it with R2 version of adprep and install the R2 components.  You can then transfer the Schema role back to the original server if you want.

That hotfix is simply the 32bit version of adprep for R2.
0
 

Author Comment

by:dresch26
ID: 18014299
okay... thats it.  I've put the restored the old domain controller and removed this one for right now.  I will try that out tomorrow & POST the results.  Thank you very much for your input!

Aaron
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

by Batuhan Cetin In this article I will be guiding through the process of removing a failed DC metadata from Active Directory (hereafter, AD) using the ntdsutil tool in a Windows Server 2003 environment. These steps are not necessary in a Win…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question