Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1745
  • Last Modified:

Cannot ping PC from laptop

Here's my situation -

I have a Linksys WRT54GL wireless router that my PC is connected to via ethernet cable.  I have a laptop that connects to the router via wireless.  I am able to ping from PC to laptop, but not laptop to PC.  I tried both wired and wireless connections in pinging the PC and still nothing.  I also tried my laptop from work and nothing still.

The thing is, I am trying to setup a network at home so that I can transfer files from laptop to PC and also share the printer that is connected to the PC.  I have a feeling this pinging situation is at the root of my problems with setting up the workgroup.  When I setup the workgroup initially, I can see the laptop in the My Network Places and I am able to share documents and printers on the laptop only.  Sometimes I can see the PC in Network Places and other times I can't.  When I can and try to connect, I get error message "\\workgroup\pc is not accessible.  You may not have permission to use this resource...".  The last time I had this working to where I was able to connect from laptop to PC, I was using XP home edition and both the PC and laptop were wireless.

Any suggestions are more than welcomed.

Thanks in advance.
0
mdelany
Asked:
mdelany
1 Solution
 
lrmooreCommented:
>able to ping from PC to laptop, but not laptop to PC.
99.9% of the time this one-way ping is result of some typ of firewall on the PC that cannot be pinged.
Many AV vendors have built in firewall. Remnants of a once-installed firewall, VPN client (Cisco for sure), etc..
0
 
MATTHEW_LCommented:
Turn off any firewall / inernet security software including the windows firewall for testing.  Try the ping and see if it works.  Also, try connecting the two computers back to back via a cross-over calbe, manually set their ips and see if you can ping back to back.
0
 
mdelanyAuthor Commented:
I turned the all firewalls off (windows, router, and everything else I could find).  I thought that the firewall may be enabled in the router since my PC was directly connected to that, but when I logged into the router and looked at the firewall settings they were turned off.

I do have a cisco client installed on my PC so that I can do work from home but I wouldn't think that would be blocking pings would it?
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
InfoStrangerCommented:
Your problem is that your desktop is blocking the ping.  It is not your laptop.  You said that the ping from the desktop to the laptop is fine.  So, the laptop has nothing blocking pings.

Note: When you said that you can ping the laptop, this means that you did not block ping on your router.

Here is another test you can do.  Since you have the desktop connected to your switch on your router.  Get another ethernet cable and connect your laptop as well.  Now, you do not need to worry about the router for now.  This acts like a cross-over cable as suggested by MATTHEW_L.  A switch is just a more complex version of one.  Now, ping to the desktop from the laptop.

If it still does not work it is being blocked by your desktop.  You have something on your desktop blocking pings.

When you said cisco client on your PC, what kind of client is it?  Is it a VPN?  If it is, that will not be your culprit.  I suggest checking your desktop PC again.  Look for software firewalls, like Sygate Personal Firewall, Zone Alarm, Norton Security Suite, McAfee Security Suite, etc.

Look for ICMP blocking.
0
 
mdelanyAuthor Commented:
---Here is another test you can do.  Since you have the desktop connected to your switch on your router.  Get another ethernet cable and connect your laptop as well.  Now, you do not need to worry about the router for now.  This acts like a cross-over cable as suggested by MATTHEW_L.  A switch is just a more complex version of one.  Now, ping to the desktop from the laptop.---

I tried this as well and the ping failed yet again.  I do have Norton Security Suite installed but I only have NAV running, not the Internet Security.  I will check the ICMP blocking as well.

0
 
lrmooreCommented:
>I do have a cisco client installed on my PC so that I can do work from home but I wouldn't think that would be blocking pings would it?
ABSOLUTELY!
Options | uncheck Stateful Firewall Always on
0
 
mdelanyAuthor Commented:
lrmoore!!!

As soon as I read this, this morning I remembered when I started losing the ability to do all of this.  Right around the time I installed the cisco client on my PC.  I turned that stateful firewall off and now I can ping AND share my printer and docs folder with the laptop!  Thank you!
0
 
lrmooreCommented:
Glad to help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now