• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 620
  • Last Modified:

'max_allowed_packet' Error With Reload of Database Dump

"ERROR 1153 (08S01) at line 33291: Got a packet bigger than 'max_allowed_packet' bytes"

We're getting the error above when trying to restore a dump to a new database.

We have continuosly adjusted up with the following command but keep getting the error.

mysql> set max_allowed_packet = 300000000;

Is there somewhere else that we need to adjust?

I've read some about my.cnf, but am not sure if I need to change it, or what to change in it. Also, there are multiple versions of my.cnf?

Background: new to Linux!
0
runningone
Asked:
runningone
1 Solution
 
todd_farmerCommented:
There is both a session variable and global variable for this.  Try setting the global variable:

set @@global.max_allowed_packet = 300000000;

Also, you can set this parameter in the defaults file (/etc/my.cnf):

http://dev.mysql.com/doc/refman/5.0/en/packet-too-large.html
http://dev.mysql.com/doc/refman/5.0/en/option-files.html

0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now