I get this message when I try to see my page

You don't have permission to access /awstats/ on this server.

<Directory "/usr/local/awstats/wwwroot">
    Options None
    AllowOverride None
    Order allow,deny
    deny from all
    allow from

my ip address is correct! can someone please help me?
Who is Participating?
HackneyCabConnect With a Mentor Commented:
If you have "Order allow,deny" I don't think you need the "deny from all" line. From the Apache manual:

    The Allow directives are evaluated before the Deny directives. Access is denied by default. Any client which does not match an Allow directive or does match a Deny directive will be denied access to the server."

This suggests that your config will allow your IP, but then check the deny line and deny everything, including your IP. Seeing as allow,deny causes access to be denied by default, try taking away the "deny from all" line in your config.
Start from allowing cgi execution
 Options ExecCGI
Also, please check that you uploaded the script as an ascii file, and if you are on linux server, that you properly changed the permissions to make the script executable (probably something like 755) via the chmod command.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.