Posted on 2006-11-26
Last Modified: 2007-11-27
I'm very new to so hopefully someone with some real experience can help.

Here's what I have done so far:
My installations are:   MySQL version 5.0.24a-community-nt;   visual studio 2005;  The MySQL ODBC driver 3.51

With MySQL on my local server (W2000 server) and on my development computer (Win XP) both computers have the same ODBC connector installed.

I then proceeded to work with the data Sources in and managed to get my database through the ODBC into as a DataSource. There is a bug in VB.Net that creates SQLs for all the tables in your DB like as follows: "SELECT * FROM `truwest`..`orders`" I went through all the SQLs and removed the double dots and everything seemed good. I could now drop a table from my data source onto a form and I would have a data table. I could also use the same data source to bind fields on my form to controls on the form. I had just two records in my DB table to test with.

There is just one line in the form that attaches the table (not counting all the supporting code you don't need to look at too closely that it adds into a different source file) which looks like this and is placed in the form_load event:


Where "DStruWest" is just the name of my DataSet. "Orders" is a table in the DataSet that represents an orders table in the DB. Now, the first time I started my form everything worked fine (by the way, I only have one control bound right now it's just a text field.) Then I closed it, opened it again and got this error:    "Failed to enable constraints. One or more rows contain values violating non-null, unique, or foreign-key constraints." Now I know with just two lines in the DB table there is no constrains that could be a problem. I also made sure that I didn't add any in the DStruWest.xsd file since you can define relationships there.

Then I started tracking down the error and it came to be that one line above. And now it gets fun. I highlighted the portion in the brackets "Me.DStruWest.orders" and viewed it through Shift+F9. Everything came up and it looked fine.  However, when I checked the Err.LastDLLError I found that a different error was created, the error being: "Invalid flags" ( I used the the following to see the errors: errMsg = New Win32Exception(Marshal.GetLastWin32Error()).Message) ).

Now I just used Shift+F9 again and checked for the error. Now there wasn't an error! I then let the whole line run, that is the [ Me.OrdersTableAdapter.Fill(Me.DStruWest.orders) ] and no error this time.

When I stop the debugging and restart the project, the error reappears. Ok, that's it, it's beyond me to even begin to figure out what's going on while I'm still grasping yet alone something funky like this.

Now, if I just let the error occur and then continue with the code as it if never happened, then my form comes up and I can navigate back and forth between the two records just fine. But that's not safe I know, I have to find out why this error is occurring and fix it or I'll just have headaches later that will be even harder to track down.

If anyone has any ideas I would really appreciate it, I'm at a "grasping at straws" stage right now.

As a thought there is a bunch of options on the ODBC Connecter for MySQL, perhaps someone know about whether some of these need to be set with They are:
Tab 1:  Don't Optimize Column Width; Return Matching Row; Allow Big Result; Use Compressed Results; Change BIGINT Columns To Int; Safe;
Tab 2:  Don't Prompt Upon Connect; Enable Dynamic Cursor; Ignore # Table Name; User Manage Cursors; Don't User Set Locale; Pad Char To Full Length; Don't Cache Result(forward only cursors);
Tab 3:  Return Table names For SQLDescribeCol; Ignore Space After Function Names; Force use Of named Pipes; No Catalog (exp); Read Options From my.cnf; Disable Transactions; Force use of Forward Only Cursors;

I turned on tracing in the ODBC connector but the SQL trace doesn't seem to work (doesn't create a file of SQL's sent) and the other trace gives results that doesn't help me much like the following:
truWest.vshost  7a0-f54      EXIT  SQLDriverConnectW  with return code 0 (SQL_SUCCESS)
            HDBC                03FD1B00
            HWND                00000000
            WCHAR *             0x74329A38 [      -3] "******\ 0"
            SWORD                       -3
            WCHAR *             0x74329A38
            SWORD                        2
            SWORD *             0x00000000
            UWORD                        0 <SQL_DRIVER_NOPROMPT>
Question by:RegProctor
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
LVL 13

Accepted Solution

newyuppie earned 500 total points
ID: 18014409
before you do the fill, try adding this line

DStruWest.EnableConstraints = FALSE
DStruWest.EnableConstraints = TRUE

Author Comment

ID: 18017143

Hi, I think you meant: Me.DStruWest.EnforceConstraints = False

Now I get these errors which at least say a little more:

A first chance exception of type 'System.Data.Odbc.OdbcException' occurred in System.Data.dll
The specified procedure could not be found


Author Comment

ID: 18018241
Okay, I've made progress.  I went back to look at the DB and the tables wouldn't show.  That's the first time I have never seen before (using phpMyAdmin to look at it).

Now my only question is, how can the database get corrupted like that when all you are doing is read it from through the ODBC? Anyway I'll post an update after I rebuild the database and test for the error again.

Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now


Author Comment

ID: 18023841
Well, I'll just have to put this down to one of those unexplainable things in that I'll probably never know how my DB could get corrupted in the way it did. VB is talking with MySQL nicely now.

Author Comment

ID: 18023861
Thanks newyuppie. It wasn't the answer but it helped me get there.
LVL 13

Expert Comment

ID: 18025131
hi regproctor, im glad you could work it out. thanks for the points

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction As chip makers focus on adding processor cores over increasing clock speed, developers need to utilize the features of modern CPUs.  One of the ways we can do this is by implementing parallel algorithms in our software.   One recent…
It’s quite interesting for me as I worked with Excel using for some time. Here are some topics which I know want to share with others whom this might help. First of all if you are working with Excel then you need to Download the Following …
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question