Solved

Virtual PC, Cent OS, and Single user mode

Posted on 2006-11-26
19
1,823 Views
Last Modified: 2013-11-15
Hello,

I was attempting to install CentOS 4.4 on microsoft Virtual PC 2004 when I recieved the following error:

"An internal virtual machine error (13) has occurred when running Redhat Linux Enterprise AS 4 on Microsoft Virtual PC"

I followed the directions on this website:

http://radcom.ir/weblog/majid/archive/2005/11/06/10789.aspx

for a fix. I just got past step for where it mentions editing the "/etc/inittab configuration file" under single user mode - I do not know how to do this.


So basically, all the points for someone who can tell me now to successfully edit the config file as described in the above link.

Thank You,
Max
0
Comment
Question by:Maxwellb
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
19 Comments
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18016591
Hi,

To boot the CentOS in single-user mode when GRUB appears in your screen durinfg the Linux booting, just hit "e" to edit the boot line and and add the word "single" at the end of the line and boot (hit "b")

Thats it.

Cheers,
K.

0
 

Author Comment

by:Maxwellb
ID: 18016851
Hi KeremE,

Thanks for responding so quickly! However, that part I have completed - it is the next part:

"Now edit /etc/inittab configuration file and change default runlevel from 5 (X11) to 3 (Full multi user mode), then reboot your computer. Now Linux boots in text mode and virtual machine won't crash anymore."

That I am having trouble with.

Would you be of assistance?

Thank You,
Max
0
 
LVL 30

Accepted Solution

by:
Kerem ERSOY earned 500 total points
ID: 18016953
Hi,

Ok. just follow these steps:

- cd /etc
- vi inittab

locate the entry in the inittab:

# inittab       This file describes how the INIT process should set up
...
# Default runlevel. The runlevels used by RHS are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

change 5 to 3

- save & reboot

cheers,
K.
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 

Author Comment

by:Maxwellb
ID: 18016969
When you say, "change 5 to 3", do you mean that for for number 5 - (X11), I should change the number to three... (bit confused, never in the true sense used linux before)

Thank you for your time,
Max
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18016978
Yeah this line (which is original):

id:5:initdefault:

should read:

id:3:initdefault:

when you are done editting.


0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18016980
This is what comments above the line explains.
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18016986
if you don't know how to modify it in vi:
- Just locate you cursor over 5
- Hit r (will now show anything but vi will be in replace mode)
- Type 3 (you will see the 5 is changed to 3)
- Hit ESC key
- type : (semicolon)
- you will see you cursor is  at the bottom line before the ":" prompt
- type wq
- Hit enter

now reboot.

0
 

Author Comment

by:Maxwellb
ID: 18017071
Hi,

Thanks for all your help! Worked like a charm. I will award you the points. Would you be able to tell me though, how to get back into the GUI, all I get now is:

"root@localhost~]#"

Thank you,
Max
0
 
LVL 2

Expert Comment

by:pavithrab4u
ID: 18017205
Hi,

Since you have edited the inittab file to 3 the system does not boot by default to GUI.
To get into GUI just type 'gdm' or 'kde' at the prompt if you have logged in as root.
If you have logged in as any other user then just type startx at the prompt to go to GUI.

[root@localhost~]# gdm

0
 

Author Comment

by:Maxwellb
ID: 18017286
Hi pavithrab4u and KeremE,

pavithrab4u: Thank you for those commands but as soon as I run them, I get the virtual PC error message again.

I found on this website:

http://72.14.253.104/search?q=cache:MElRuMo3UaAJ:vpc.visualwin.com/+An+internal+virtual+machine+error+(13)+has+occurred+CentOS&hl=en&gl=ca&ct=clnk&cd=2

That CentOS's graphical interface is indeed capable of running under virtual PC, but only with the following enhancements:

"Needed to add "noacpi" to boot parameters, and set X color depth to 16"

Any idea of what this means?
As well, I noted in the beginning that this question was just for editing that file, but as this question deals with the successful operation of CentOS under VPC 2004, I thought it would be more useful to experts exchange to continue it until the real solution is found - however, if you wish I can award you (KeremE ) the points right now, as you did successfully answer my question.

Thank You,
Max
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18017863
Hi,

to add "noacpi" means you need to edit you grub configuration again and add "noacpi" permenently as an option. To accomplish this:

cd /etc
vi grub.conf

and add noacpi to the end of every kernel entry such as this:

default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.9-42.0.3.EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-42.0.3.EL ro root=/dev/VolGroup01/LogVol00 rhgb quiet
        initrd /initrd-2.6.9-42.0.3.EL.img
title CentOS-4 i386 (2.6.9-42.EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-42.EL ro root=/dev/VolGroup01/LogVol00 rhgb quiet
        initrd /initrd-2.6.9-42.EL.img

In this example you need to add noacpi following the quiet. Save and exit.

0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18017905
For the screen depth to 16:

cd /etc/X11
vi xorg.conf

locate the section "Screen"

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"  
        DefaultDepth     24  


Such as this. Change DefaultDepth to 16 save and exit.

As for the quetion and grading: You might have closed the question as such you have commented the original q is already answered. The correct way would you create another tread for the new question for the pepole might not be able  to search a solution on how to change depth etc.

But anyway may be pepole would have difficulties just as yourself and follow this Q step by step :)

0
 

Author Comment

by:Maxwellb
ID: 18019663
Thank you for the information, I will review it as soon as I have access to the virtual machine.

Thank You
0
 

Author Comment

by:Maxwellb
ID: 18034614
Hi KeremE,

How do I edit the grub configuration file to add "noacpi" to the end of the line? I tried your above instructions but they did not seem to work - perhaps because it was at the end of the line? And, I only have one "kernel entry", as you called it.

Thank you for your patience,
Max
0
 

Author Comment

by:Maxwellb
ID: 18034752
Hello,

I did a Google search and brought up a page on how to edit with 'vi' and completed editing the 'grub' configuration file by adding 'noacpi' to the end of my only "kernel entry". Now when I went to edit the X11 configuration file, the screen color depth was already at 16...and after a reboot, it doesn't work. I've just about had it with Virtual PC and unless you can think of anything, I think I will download VMWare and see if I have better luck.

Thank you for your help,
Max
0
 
LVL 19

Expert Comment

by:alextoft
ID: 18036039
I would... Microsoft Virtual PC stinks. It was a very poor product before MS bought it, and hasn't improved much. VMware is superior in every way.
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18037104
I agree with Alextoft :) VMWare is very robust and known to work very well with linux. It even has a prepacked RedHat FC packet available.

But for the sake of the question it is not sure that 16 refers to color depth or color (16 bit versus 4 bits (16 color)). Then just set the color depth to 4 and modify thi Sceen saction such as:

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     4
        SubSection "Display"
                Viewport   0 0
                Depth     4
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0  
                Depth     24
                Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

And give it a try.

Another Alternative is to setup Cygwin on any Wintel Computer and start X over the cygwin. Accessing your PC remotely.

Last but not least I guess it is time to close the Question :) May be the rest of this discussion is another topic . We're getting more and more off-topic. I'm afraid the moderators would "terminate" us all :)
0
 

Author Comment

by:Maxwellb
ID: 18054500
Hi Everyone,

Sorry for taking a while - I was a bit busy. No, it did not work either. For anyone else looking at this I (and I'm sure the experts will as well) recommend VMWare for running CentOS in a virtual environment. I will award full points to KeremE since he did answer the original question.

Thank you for your patience, knowledge, and willingness to put up with my constant steering off-topic,
Max

0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 18058033
Yr welcome. I hope You'll enjoy VMWare :)
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

VM backups can be lost due to a number of reasons: accidental backup deletion, backup file corruption, disk failure, lost or stolen hardware, malicious attack, or due to some other undesired and unpredicted event. Thus, having more than one copy of …
Are you looking to recover an email message or a contact you just deleted mistakenly? Or you are searching for a contact that you erased from your MS Outlook ‘Contacts’ folder and now realized that it was important.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question