Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Linux Hardware (Undetectable  Floppy Drive)

Posted on 2006-11-26
20
Medium Priority
?
424 Views
Last Modified: 2010-04-20
Hi,

Am totally new to Fedora (to Linux in general) and am facing a problem with my desktop (Linux Fedora) that the floppy drive is not detectable (not shown in Computer Icon in Desktop). I can see the CD rom drive, the USB flash memory (if I plug it), the filesystem and network icons but no floppy drive.

I did some searching in Google and I found that I need to add the following line in /etc/fstab file

/dev/fd0 /media/floppy auto rw,user,noauto 0 0

When I saved it. I can see an icon called floppy. However, when I click it, an error msg saying:

Unable to mount the selected floppy drive.
Mount: you must specify the filesystem type.


Can you help me in accessing the floppy drive.
0
Comment
Question by:turki_00
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 12
  • 8
20 Comments
 
LVL 12

Expert Comment

by:ibu1
ID: 18017512
Do this exactly
#mkfs.ext3 /dev/fd0

It will format ur floppy and make ext3 file system.

Best of Luck
0
 
LVL 12

Expert Comment

by:ibu1
ID: 18017521
If u mount it as fat file system, do this exactly
mount -t msdos /dev/fd0 /mnt/floppy
0
 

Author Comment

by:turki_00
ID: 18017547
ibu1,

do i have to keep this line in fstab file ?

/dev/fd0 /media/floppy auto rw,user,noauto 0 0
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:turki_00
ID: 18017550
also,

should i write this
#mkfs.ext3 /dev/fd0

in the command line or write it in the fstab file ?
0
 
LVL 12

Expert Comment

by:ibu1
ID: 18017579
Keep the above entry in fstab.
Write this command in command line and not in fstab.

Best of Luck
0
 

Author Comment

by:turki_00
ID: 18017663
ibu1,

Here is what i did:

add the following line in /etc/fstab
/dev/fd0 /mnt/floppy auto rw,user,noauto 0 0

type this command in terminal window:
#mkfs.ext3 /dev/fd0

nothing happened. (it gave me a new line prompt)

then I typed this in the terminal window:
mount -t msdos /dev/fd0 /mnt/floppy

a message came to me saying:
mount point: /mnt/floppy does not exist
 ------------------------------------------------
*note: am calling the mounting piont /mnt  
is this a problem rather than call it /media ????
0
 
LVL 12

Expert Comment

by:ibu1
ID: 18017720
Check that you have /mnt/floppy directory exist.
0
 
LVL 12

Expert Comment

by:ibu1
ID: 18017772
If ur mount point is /media make sure that the media directory exist.
Whatever u write in fstab file for mounting point, by default it will take that mount point.
Suppost u write /mnt/floppy in fstab file, u don't need to specify every time to mount the floppy in /mnt/floppy. It will by default mount it in /mnt/floppy.
For instance
# mount /dev/fd0
It will mount it in /mnt/floppy coz u already mention in fstab to mount floppy in /mnt/floppy
0
 

Author Comment

by:turki_00
ID: 18017810
floder /mnt exist with the following permmision:
drwxr-xr-x

no files or directory inside the /mnt folder
0
 

Author Comment

by:turki_00
ID: 18017871
ibu1,

do i have to restart the pc every time i do changes in fstab ?
0
 
LVL 12

Expert Comment

by:ibu1
ID: 18017895
See
if u put mount point /mnt/floppy
OR
if u didn't make any changes to fstab and it is like before /media/floppy

Answer this question first

0
 
LVL 12

Expert Comment

by:ibu1
ID: 18017899
You don't need to restart everytime your pc when u make changes to fstab. Do this just
# mount -a
0
 
LVL 12

Expert Comment

by:ibu1
ID: 18017922
U need to create 'floppy' directory inside the /mnt directory coz u are going to mount floppy in that directory
0
 

Author Comment

by:turki_00
ID: 18017927
right now,

my mounting piont is /mnt/floppy in the fstab file.

when i chked the /mnt directory, nothing inside it.

do i have to create the folder "floppy" inside the /mnt directory ?
0
 
LVL 12

Accepted Solution

by:
ibu1 earned 500 total points
ID: 18017940
yes make one directory 'floppy' inside /mnt folder
0
 

Author Comment

by:turki_00
ID: 18018010
ibu1,

IT WORKS

big kissssssses..

thank you very much,

i guess creating the folder floppy inside /mnt was causing the problem.

one last thing,
do i have every time to "umount" before i reomve the disk ?
0
 
LVL 12

Expert Comment

by:ibu1
ID: 18018043
yes
#umount /dev/floppy
0
 
LVL 12

Expert Comment

by:ibu1
ID: 18018050
Sorry
#umount /dev/fd0
0
 
LVL 12

Expert Comment

by:ibu1
ID: 18018055
Any more question ?
u r welcome
0
 

Author Comment

by:turki_00
ID: 18018091
no thanx

You have been good helper.
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. http://www.linuxmint.com. Once you open the link you will see …
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question