[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

server goes down

Posted on 2006-11-26
14
Medium Priority
?
200 Views
Last Modified: 2010-04-20
Hello,
today when I was logged in from the shell I tried to stop apache service
and the server just stopped responding! this is what I did

-(02:11 15 AM)-(root@server)-(/home) $ service httpd stop
Stopping httpd: [SSH] ERROR: An existing connection was forcibly closed by the remote host.

[SSH] INFO: DISCONNECT

can someone please tell me why is this? sometimes my server stops responding for no
reason, so I have to open a ticket and request a reboot! could it be because of stopping apache?
0
Comment
Question by:Sabrin
  • 5
  • 5
  • 2
  • +2
14 Comments
 
LVL 12

Expert Comment

by:ibu1
ID: 18017572
What are the contents of ur /var/log/messages ?
0
 

Author Comment

by:Sabrin
ID: 18017803
the server went down at 2:11am
and I see this from the file /var/log/messages

Nov 26 22:08:23 dedicated sysctl: kernel.sysrq = 0
Nov 26 22:08:23 dedicated sysctl: kernel.core_uses_pid = 1
Nov 26 22:08:23 dedicated sysctl: fs.file-max = 65000
Nov 26 22:08:23 dedicated rc.sysinit: Configuring kernel parameters:  succeeded
Nov 27 03:08:24 dedicated date: Mon Nov 27 03:08:24 EST 2006
Nov 27 03:08:24 dedicated rc.sysinit: Setting clock  (localtime): Mon Nov 27 03:08:24 EST 2006 succeeded
Nov 27 03:08:24 dedicated rc.sysinit: Loading default keymap succeeded

so the part from where the server goes down its missing!
0
 

Author Comment

by:Sabrin
ID: 18017814
nothing found from nov 27 at 2am
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 12

Assisted Solution

by:ibu1
ibu1 earned 400 total points
ID: 18018098
May be ur server is exceeding the no. of connection.Please check any entry in /var/log/httpd
Please also check that enough swap memory is alloted by
# free -m
0
 
LVL 10

Expert Comment

by:ssvl
ID: 18019379
If it not a hack
and
not a low memory problem
so  I think It because of h/w problems like memory

(I got the same isue in my server and thay (customer support person) told me to clean the memory and now it works fin)e  



0
 
LVL 16

Assisted Solution

by:xDamox
xDamox earned 400 total points
ID: 18019694
Hi,

Also could you check your

/var/log/secure log file for any entries made on that day when your machine stopped responding.
0
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 18022426
I would check *any* log file in /var/log that has changed recently. Some will be no help, but one may tell you something useful.
0
 

Author Comment

by:Sabrin
ID: 18031285
ssvl, how do I clean the memory?
0
 

Author Comment

by:Sabrin
ID: 18031615
ibu1, what do I look for in /var/log/httpd
0
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 18035221
In the absence of an answer yet from ssvl, "re-seating" the memory may help, that may be the same thing as "clean" or may not. In other words, unplug & plug back in the memory sticks. Be sure they are firmly home. Once should be enough, if indeed this is the problem.
0
 
LVL 35

Accepted Solution

by:
Duncan Roe earned 1200 total points
ID: 18035233
Take precautions against static electricity: wear your wriststrap if you have one else ty to toucg the metalwork of the computer chassis as much of the time as practicable and certainly just before you start.
0
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 18035235
toucg should be touch
0
 

Author Comment

by:Sabrin
ID: 18036921
the datacenter is 100 miles away from where I am..
0
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 18040140
If it *is* a hardware problem, you'd have to physically fix it even if the system was at the North Pole. Pursue software possibilities first.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
This article will show you step-by-step instructions to build your own NTP CentOS server.  The network diagram shows the best practice to setup the NTP server farm for redundancy.  This article also serves as your NTP server documentation.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month18 days, 1 hour left to enroll

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question