?
Solved

Linux and email.

Posted on 2006-11-27
8
Medium Priority
?
327 Views
Last Modified: 2010-04-20
I have a default debian installation. I can send mail using the "mail email@email.com" command. The problem is that any major email company will mark it as spam. The email's address shows up as "root@". I know this is probably because I don't have a hostname or something of that effect set. I have a domain, and mail.freepalaces.com points to my IP address that is running the mail server, so how can I send emails so they can correctly bypass the spam filter?
0
Comment
Question by:CurlyFri3s21
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 14

Expert Comment

by:ygoutham
ID: 18018347
edit your /etc/mail/sendmail.mc

change line "dnl # define(`SMART_HOST', `smtp.your.provider') dnl"
to read something like

define(`SMART_HOST', `1.2.3.4') dnl

you can use your mail server ip instead of "1.2.3.4".  this would make it look like mail appearing out of mail.freepalaces.com



0
 
LVL 14

Expert Comment

by:ygoutham
ID: 18018351
you would need to do the following after you edit the lines

make
m4 sendmail.mc > sendmail.cf
service sendmail restart
0
 
LVL 31

Expert Comment

by:rid
ID: 18021520
Might be a good idea to configure your mail to show a proper user instead of "root". My guess is that some spam filters react to a generic username like that. In addition to previous suggestion, of course.
/RID
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 

Author Comment

by:CurlyFri3s21
ID: 18022051
Okay, I am running into troubles, first off I think you assumed I had sendmail installed, but instead I had mutt or something. Anyways I installed sendmail but it first gave em some kind of error saying I needed to report it or something. I then did apt-get install sendmail-bin and it installed, then I did apt-get install sendmail and it installed, I went to the /etc/mail/sendmail.mc and I changed it from


FEATURE(`msp', `[127.0.0.1', `MSA')dnl
to
FEATURE(`msp', `[smtpout.secureserver.net]', `MSA')dnl

This is the smtp server that godaddy said I can use. as stated by this: "Your outgoing mail server will be "smtpout.secureserver.net" I also had to set a username and password to it, but no where did I find a place to put the username in password.

None the less I did make it and m4 sendmail.mc > sendmail.cf,

I dont have service commands but I used /etc/init.d/sendmail restart.

I then tried mail -s "testsubject" paroxsitic@gmail.com </dev/null  and it basically froze on me, Putty wouldnt cancel with CTRL C or q or anything.

0
 
LVL 14

Expert Comment

by:ygoutham
ID: 18025477
it is not a feature that you need to change, but a definition of the smtp that needs change.  what distro are you using? sendmail version?  more info pls...
0
 

Author Comment

by:CurlyFri3s21
ID: 18025563
As stated eariler, I am using debian 3.1 and sendmail version: 8.13.4

I dont really care if I have a correct domain or not, All i want to do is send non-spam emails
0
 
LVL 14

Accepted Solution

by:
ygoutham earned 2000 total points
ID: 18025780
then try the feature(masquerade_domain) and feature(masquerade_entire_envelope) which should be available at the end of sendmail.mc and change them to make it look like your domain and try resending mails.

most of the mail servers (atleast popular ones like yahoo and google) accept mails from ip addresses as long as they find a reverse dns entry for that number, even if there is a masquerade in place.  i have sent numerous mails as root to myself on these accounts from unregistered domains.  i only get away with a warning but never got marked as spam.  ensure that you are not on the open relay mode and someone else might be doing the good deed of spamming from your ip where it gets listed in

spamcop.org

the above list is read by all popular mail hosting guys and they can mark you off as spam.
0
 

Author Comment

by:CurlyFri3s21
ID: 18031417
Thanks, I got it working for mail.freepalaces.com, which goes back to my IP and marks as not spam.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Fine Tune your automatic Updates for Ubuntu / Debian
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses
Course of the Month13 days, 19 hours left to enroll

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question