Solved

Enable Split Tunneling 501 PIX

Posted on 2006-11-27
11
1,389 Views
Last Modified: 2010-05-18
Hey guys - I am trying to allow users to browse the Internet while connecting to VPN. I know, this is a security risk but the client does not care. I went into the PDM and enabled split tunneling (outside:20) but no luck.

Here is my config:


PIX Version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password
passwd
hostname xxx
domain-name xxx
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 102 permit tcp any interface outside eq www
access-list 102 permit tcp any interface outside eq https
access-list 102 permit tcp any interface outside eq ftp
access-list 102 permit icmp any any
access-list 102 permit tcp any any eq smtp
access-list 102 permit tcp host x.x.x.x interface outside eq 3389
access-list 102 permit tcp host x.x.x.x interface outside eq 3389
access-list inside_outbound_nat0_acl permit ip any 192.168.8.64 255.255.255.224
access-list outside_cryptomap_dyn_20 permit ip any 192.168.8.64 255.255.255.224
pager lines 24
logging host inside 192.168.8.5
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.x 255.255.255.252
ip address inside 192.168.8.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool xxx-pool 192.168.8.70-192.168.8.80
pdm location 192.168.8.5 255.255.255.255 inside
pdm location x.x.x.x 255.255.255.255 outside
pdm location x.x.x.x 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface smtp 192.168.8.5 smtp netmask 255.255.255.
255 0 0
static (inside,outside) tcp interface www 192.168.8.5 www netmask 255.255.255.25
5 0 0
static (inside,outside) tcp interface 3389 192.168.8.5 3389 netmask 255.255.255.
255 0 0
access-group 102 in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.8.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup xxx-vpn address-pool xxxx-pool
vpngroup xxx-vpn dns-server 192.168.8.5 208.254.149.169
vpngroup xxx-vpn wins-server 192.168.8.5 208.254.149.169
vpngroup xxx-vpn default-domain xxxxxxxx.com
vpngroup xxx-vpn split-tunnel outside_cryptomap_dyn_20
vpngroup xxx-vpn idle-time 1800
vpngroup xxx-vpn password  
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:
: end

What did I miss?

0
Comment
Question by:Justin Durrant
  • 6
  • 5
11 Comments
 
LVL 20

Accepted Solution

by:
calvinetter earned 500 total points
ID: 18018901
 Never use "ip any" in a VPN ACL, & your "ip local pool" must not overlap any local subnets behind the PIX.  Run this:

no no vpngroup xxx-vpn address-pool xxxx-pool
no vpngroup xxx-vpn split-tunnel outside_cryptomap_dyn_20
no crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
no nat (inside) 0 access-list inside_outbound_nat0_acl
no access-list inside_outbound_nat0_acl
no access-list outside_cryptomap_dyn_20

access-list nonat permit ip 192.168.8.0 255.255.255.0 10.203.49.0 255.255.255.0
access-list split_acl permit ip 192.168.8.0 255.255.255.0 10.203.49.0 255.255.255.0
nat (inside) 0 access-list nonat
ip local pool clientpool 10.203.49.1-10.203.49.50
vpngroup xxx-vpn address-pool clientpool
vpngroup xxx-vpn split-tunnel split_acl
clear xlate
crypto map outside_map interface outside

Because PIX v6.3(3) is quite buggy, you may need to save the config & reboot the PIX.  If this PIX has current SmartNet support on it, I strongly urge you to upgrade to the latest 6.3(5), which has *many* bug & security fixes.

cheers
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 18027491
Can I not just figure this in the PDM? I really do not want to reconfigure my entire VPN.
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 18033227
 You can get the best of both worlds & enter those commands via PDM:
You can copy/paste that block of commands like so:
   Tools -> Command Line Interface... -> Mutliple Line Command.. -> paste the block of commands, click "Send"

>I really do not want to reconfigure my entire VPN.
   You're not completely reconfiguring VPN, but if you want it to work, you'll need to make the several necessary changes.

cheers
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 18033286
ok, so my client pool should be separate than my local lan 192.168.8.x? Why is that exactly?
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 18033373
Yes, it positively must be different than the local LAN, otherwise you'll hit a routing loop.  Cisco's VPN implementation requires the VPN client pool to be different than any local subnets behind your PIX & also different than the LAN where the remote client PC resides.

cheers
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 23

Author Comment

by:Justin Durrant
ID: 18033419
interesting.. I am glad it has just always worked... LOL Thanks.. I will give it a go. I assume you did not mean to use redundant no's in the first line? Are there any other typos? :)
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 18033485
D'oh!  LOL  Good eye, yes that 1st line shouldn't be "no no".  
(Early-morning post just before leaving for work, obviously caffein hadn't fully kicked in yet!)

cheers
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 18033603
cool! I will let you know how it goes. :)
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 18033666
worked! Thanks again! Is there any real security risk with split tunneling?
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 18111035
You're welcome!

  There's a bit of a concern about security with split tunneling, since while connected to the VPN the remote client PC can also access the Internet & possibly vice versa if there's a trojan, etc on the PC, or simply having malware that may "dial home" & send a copy of captured company passwords/data to an external party.
  It really comes down to your business security policy, how well you need to protect the company data, how well you trust the remote users (are they clueless about security?), how well the remote client PCs are secured: are they fully-patched XP SP2 with great (or terrible) antivirus/antispyware apps installed/updated & doing regular scans, etc?
  Even without split-tunneling configured, if possible you still want to keep the remote VPN PCs/laptops as secured as you can.  A lot of this can be taken care of by an initial eval/lockdown of the PC by the IT Dept, then if possible train the user to properly maintain the PC thereafter.

cheers
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 18111343
Thanks!
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Nothing in an HTTP request can be trusted, including HTTP headers and form data.  A form token is a tool that can be used to guard against request forgeries (CSRF).  This article shows an improved approach to form tokens, making it more difficult to…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now