path_translated, cgi and iis6

Posted on 2006-11-27
Last Modified: 2012-05-05
I have a Windows 2003 server with IIS 6.0. I have a cgi application that tries to read path_translated variable. The return value is always empty. This cgi is working well on my Windows 2000 IIS 5.0 server.
I've tried to set IIS variable AllowPathInfoForScriptMappings to true but still not working.
Is there anything else I need to configure in IIS 6.0 to get this working?

Any help would be appreciated.

Thank you
Question by:julcar
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 10

Expert Comment

ID: 18021005

Author Comment

ID: 18022244
thank you andresM
I've tried to read PATH_INFO, SCRIPT_TRANLATED and PATH_TRANSLATED. all of them return an empty string.
Any other idea?
LVL 10

Expert Comment

ID: 18022334
If you try same thing but with a simple asp page, what happens?
IIS Server Variables

PS: See:

The physical path that maps to the virtual path in PATH_INFO, for example, "c:\inetpub\wwwroot\vdir\myisapi.dll". This variable is used by IIS during the processing of ISAPI applications. If the AllowPathInfoForScriptMappings metabase property is set to true (to support exclusive CGI functionality), PATH_INFO will only contain "/zip" and ISAPI applications such as ASP will break.
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.


Author Comment

ID: 18022471
It works just fine in do you think it is a cgi problem?
LVL 10

Expert Comment

ID: 18027128
are you sure you set correctly AllowPathInfoForScriptMappings ? did you restart IIS after that?
or may be the problem is in the cgi application ...
LVL 23

Expert Comment

ID: 18030083

Author Comment

ID: 18036566
AndresM: yes I set it correctly and I restarted IIS. The proof is that it works fine in ASP

ram krihna580: these webpages applies to IIS 4.0. I use IIS 6.0

Thank you.

Author Comment

ID: 18046833

I've found my problem. The problem was in my cgi application (a Bbx application).

Thank you all for your help!


Accepted Solution

Computer101 earned 0 total points
ID: 19229729
PAQed with points refunded (400)

EE Admin

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

687 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question