Solved

path_translated, cgi and iis6

Posted on 2006-11-27
10
611 Views
Last Modified: 2012-05-05
Hi,
I have a Windows 2003 server with IIS 6.0. I have a cgi application that tries to read path_translated variable. The return value is always empty. This cgi is working well on my Windows 2000 IIS 5.0 server.
I've tried to set IIS variable AllowPathInfoForScriptMappings to true but still not working.
Is there anything else I need to configure in IIS 6.0 to get this working?

Any help would be appreciated.

Thank you
0
Comment
Question by:julcar
10 Comments
 
LVL 10

Expert Comment

by:AndresM
ID: 18021005
0
 

Author Comment

by:julcar
ID: 18022244
thank you andresM
I've tried to read PATH_INFO, SCRIPT_TRANLATED and PATH_TRANSLATED. all of them return an empty string.
Any other idea?
0
 
LVL 10

Expert Comment

by:AndresM
ID: 18022334
If you try same thing but with a simple asp page, what happens?
IIS Server Variables
http://msdn2.microsoft.com/en-gb/library/ms524602.aspx

PS: See:

PATH_TRANSLATED
The physical path that maps to the virtual path in PATH_INFO, for example, "c:\inetpub\wwwroot\vdir\myisapi.dll". This variable is used by IIS during the processing of ISAPI applications. If the AllowPathInfoForScriptMappings metabase property is set to true (to support exclusive CGI functionality), PATH_INFO will only contain "/zip" and ISAPI applications such as ASP will break.
 
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:julcar
ID: 18022471
It works just fine in asp....so do you think it is a cgi problem?
0
 
LVL 10

Expert Comment

by:AndresM
ID: 18027128
are you sure you set correctly AllowPathInfoForScriptMappings ? did you restart IIS after that?
or may be the problem is in the cgi application ...
0
 
LVL 23

Expert Comment

by:rama_krishna580
ID: 18030083
0
 

Author Comment

by:julcar
ID: 18036566
AndresM: yes I set it correctly and I restarted IIS. The proof is that it works fine in ASP

ram krihna580: these webpages applies to IIS 4.0. I use IIS 6.0

Thank you.
0
 

Author Comment

by:julcar
ID: 18046833
Hi,

I've found my problem. The problem was in my cgi application (a Bbx application).

Thank you all for your help!

0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 19229729
PAQed with points refunded (400)

Computer101
EE Admin
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Logparser is the smartest tool I have ever used in parsing IIS log files and there are many interesting things I wanted to share with everyone one of the  real-world  scenario from my current project. Let's get started with  scenario - How do w…
Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question