Belkin Wireless Router problem

I have installed a Belkin wireless router onto my network, I have disable DHCP on the router so it uses the dhcp server already on the network. When I try to connect using my wireless network card on my pc it can see the Wireless Network and connect to it without any problems, its get a valid address from the network but thats it. Once it has recieved an address it cant communicate or even ping the router ??????

Any pointers ?
Who is Participating?
BudDurlandConnect With a Mentor Commented:
Is the Belkin router in NAT mode or Access Point (WAP) mode?

In NAT mode, the WAN and the Wireless network are 2 separate networks.  Even if a device on the wireless gets an address from the DHCP server on the router's "wan" side, it's still 2 separate networks -- ping won't work because the network IP scheme doesn't match the IP address the wireless device got from the DHCP server.

If you configure the Belkin router as a Wireless Access Point (WAP), then the wired and wireless networks are all one happy family, and all should be well
b0lsc0ttIT ManagerCommented:

Disabling DHCP on the Belkin router may have caused it not to respond to the ping.  Did you provide that device with an IP in the range compatible with the server?  Can you enter that IP in your browser and access it that way?  Some Belkin wireless devices do not provide a web interface and you have to install their utility to access the device.  Did you do that and can you access it that way?

If you still have issues please let me know the results of these questions.  Also, the model and version number of the router.  You should also confirm that you can ping or communicate with the server, etc.

Let me know if you have any questions or need more information.

Yes, the problem seems that the Router has IP in different subnet than your network.

So, Assign a static IP to a computer to be in the range of the Belkin router (say if your Router still has default, then put the IP of the computer as

Then connect the computer to the Router, and logon normal. Then in the LAN setting of the Router, change the IP address to be in the same range of the Server network. Also remember that this IP should be away from the DHCP scope of the Server.

So, if you network is with mask of, and if you have assigned scope of - to the DHCP, then assign the IP of the Router to be away from this scope say
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

NSCexpertAuthor Commented:
The wireless router has a static ipaddress which is a valid address from the joining network and is on the same subnet. For the record it running in access point mode.


can u ping it with a hardwired connection?

is it connecting to the ssid you established? (not ur neighbors?)

does it have the CORRECT gateway? dhcp server is assigning properly?

correct DNS??

can u let us know the ip info schema?

NSCexpertAuthor Commented:
ok now i have more info: even though it is setup as WAP to just relay traffic, it is now allocating an ipaddress( as if it was a dhcp server. The ipaddress it is allocating is not a valid ipaddress on the network. Buts what is really weird is that once you set the router up to be an access point it removes the DHCP options from the Navigation which I would assume it has also disables DHCP ?????

Has anyone seen this before ? Sounds like a bug with the software.
b0lsc0ttIT ManagerCommented:
What model and version of the router do you have?  It would be a bug (or a major defect) if what you say is true.  They may have a firmware update available for download from their website you can install.

b0lsc0ttIT ManagerCommented:
That is why I would normally recommend purchasing just a wireless access point in cases like this.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.