[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Cisco 837 DHCP problems

Posted on 2006-11-27
2
Medium Priority
?
351 Views
Last Modified: 2012-05-05
Hi All,

I seem to be having all sorts of difficulty with my 837.

I am simply trying to get the DHCP server running so that my laptop can obtain an IP address and use the http server to administer the router.

It all looks OK to me but the router does not provide an IP address.

Your help as usual would highly appreciated.

Thanks
Sean


Here's my config

Current configuration : 1225 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname caddell
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxx
enable password xxxxxxx
!
no aaa new-model
ip subnet-zero
no ip routing
!
ip dhcp pool CLIENT
   network 20.20.20.0 255.255.255.0
   domain-name xxxxxxxxxxxx
   default-router 20.20.20.20
   netbios-name-server 1.1.1.1
   dns-server 1.1.1.2
   lease 0 1
!
!
no ip domain lookup
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
no crypto isakmp ccm
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip route-cache
 hold-queue 100 out
!
interface ATM0
 ip address 10.10.10.1 255.255.255.0
 no ip route-cache
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
ip classless
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password xxxxxxxxxx
 login
!
scheduler max-task-time 5000
end

caddell#

- - - - - - - - - - - - - - - -
0
Comment
Question by:seancaddell
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 9

Accepted Solution

by:
rshooper76 earned 2000 total points
ID: 18022806
Is this information accurate for your network?  It does not appear so.

ip dhcp pool CLIENT
   network 20.20.20.0 255.255.255.0
   domain-name xxxxxxxxxxxx
   default-router 20.20.20.20
   netbios-name-server 1.1.1.1
   dns-server 1.1.1.2
   lease 0 1

I would do this


ip dhcp pool CLIENT
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server [isp or local dns server]
 
0
 
LVL 8

Expert Comment

by:thur6165
ID: 18022808
show ip dhcp server statistics

see if the router is recieving any DHCPDISCOVER packets
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question