Solved

CF and DW were working fine.  Now we all get "The server name or address could not be resolved" error

Posted on 2006-11-27
12
304 Views
Last Modified: 2013-12-24
Ok, we have two seperate web servers.  One is for testing, one is for production.  We have CF on both.  CF was working fine for months on both of them.  Now we come back from Thanksgiving and the RDS login isn't specified.  No problem, I'll just re-specify it.  But when I click on the RDS login link to specify it, I get this error (we ALL get this error):
The server name or address could not be resolved.
Possible reasons:
1. The URL specified for this site's testing server may be incorrect: http://www.blahblahblah.com
2. The testing server may be incorrectly configured (for example, ColdFusion may not be running).

This was working fine a few days ago for four of us.  We've checked with everyone who has access to those servers and no one did anything, we weren't even here for the holiday.

I've been digging on the internet and found a bunch of forums where people had this problem to start with and just re-installed CF and got it working.  Re-installing is much messier for us since we have tons of users who need this stuff (plus it's extremely time consuming).  So I kept digging and found this forum where they talk about altering the win.xml file.  http://www.easycfm.com/forums/printthread.cfm?Forum=17&Topic=1989  But the forum is talking about Coldfusion 6 I believe.  We're on DW 7, Coldfusion MX7.  I can't think why the win.xml file would mysteriously change over the weekend either.
This is preventing us from using any functions that require the datasources (like building Recordsets in the nice Dreamweaver interface).  
Has anyone else had this problem or know of something we can do??
Thanks in advance!
0
Comment
Question by:wyldtwyst
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
12 Comments
 
LVL 20

Expert Comment

by:trailblazzyr55
ID: 18022943
not sure off the top of my head, however it sounds to be a dreamweaver issue, not a coldfusion issue. If I understand correctly you're having issues getting dreamweaver to connect to your datasources so you can take advantage of the tools dreamweaver has for creating queries and such without having to hand code everything. Perhaps going into your codfusion admin and changing the RDS login and then in dreamweaver making the appropriate changes for the new credentials will solve the problem, or you may want to try a re-installation of dreamweaver on one of your machines to see if that gets it to work.

You don't need to mess with Coldfusion other than perhaps the RDS login set in the administrator.
0
 
LVL 1

Author Comment

by:wyldtwyst
ID: 18025459
But the problem is that we cannot even get to the part where you type in the RDS password.  Dreamweaver just pops up that error saying that it can't resolve the server name.  I'll try re-installing Dreamweaver but it doesn't make sense.  The four of us work on different terminals across the country, surely Dreamweaver didn't have the same corruption at the same time on all terminals.  Seems like a server issue, but then why is it happening on both of our servers... I will try to re-install and let you know, thanks.
0
 
LVL 36

Expert Comment

by:SidFishes
ID: 18028569
have your tried using an IP instead of your URL? Sounds like a possible DNS issue.

0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 
LVL 1

Author Comment

by:wyldtwyst
ID: 18029058
Yes we tried the IP address.  We tried mapping to the root of the web servers, mapping down to a folder, everything.  Using the alias was working fine.  I will try re-installing Dreamweaver and let everyone know.
0
 
LVL 1

Author Comment

by:wyldtwyst
ID: 18029339
Ok I uninstalled then re-installed Dreamweaver and it did not work.   >.<
0
 
LVL 36

Expert Comment

by:SidFishes
ID: 18029420
some other guesses...

check...
event logs
how about firewall logs...
perhaps a windows update has changed something?
0
 
LVL 1

Author Comment

by:wyldtwyst
ID: 18030933
Ok I just installed DW on a computer that has never had DW before and I am still getting this error.  I checked with our server admin and nothing has changed on the servers.  He knows because he has to manually push updates to them.  I even checked all of our Windows policies and nothing is Enabled.  We also checked the win.xml file per the instructions above and the RDS is enabled, i.e. it's not commented out.  Also tried dropping the datasources in the CF Admin Console and re-adding them.  No effect.
0
 
LVL 36

Expert Comment

by:SidFishes
ID: 18032416
Maybe this?

http://www.dansshorts.com/?day=11/10/2005
(doesn't sound likely since it was working before...but worth a shot)

you could try manually specifying the port

http://www.blahblahblah.com:80 




0
 
LVL 1

Author Comment

by:wyldtwyst
ID: 18036464
Well, turns out there *was* a change.  
We have been trying to make our Coldfusion reports work with Reverse Proxy.  Of course, for Reverse Proxy you have to come in at a certain level and then you can only access folders and files from there down.  This causes a problem because our CFIDE folder is a step above where Reverse Proxy users come in, so we tried copying everything in the CFIDE folder and moving it a step down, then in the mappings under CFAdmin console we mapped CFIDE down to /folder/CFIDE.  It seemed to be halfway working with Reverse Proxy (there were still some problems with Flash elements) but one of the developers tried taking the mappings off and voila, it's working again.  I had thought that when the change was made I wasn't having any problems, but I just must not have noticed them.  So I guess morale of the story is if you're having this problem, check your mappings!  Thanks SidFishes and trailblazyr55 :)
0
 
LVL 36

Expert Comment

by:SidFishes
ID: 18069556
no objections
0
 
LVL 1

Accepted Solution

by:
DarthMod earned 0 total points
ID: 18076734
PAQd, 500 points refunded.

DarthMod
CS Moderator
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article provides a case study on how our local youth baseball league deployed a new website, including the platform selection, implementation and benefits to the league.
Periodically we have to update or add SSL certificates for customers. Depending upon your hosting plan you may be responsible for the installation and/or key generation. In the wake of Heartbleed many sites were forced to re-key. We will concen…
The purpose of this video is to demonstrate how to properly insert a Vimeo Video into a WordPress site or Blog. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp…
The purpose of this video is to demonstrate how to prevent comment spam on a WordPress Website. This will be demonstrated using a Windows 8 PC. Plugin Akismet will be used. Go to your WordPress login page. This will look like the following: myw…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question