Solved

PIX 501 to PIX 501 lan to lan - ike up - IPSec up - still cant talk to other network.

Posted on 2006-11-27
4
225 Views
Last Modified: 2010-08-05
Here is the configs for the two PIX501's ---  What am I missing? The IKE shows UP, and the IPSec tunnel shows up.
but I cant get any traffic from on to the other.

PIX 1

Building configuration...
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxxx encrypted
hostname ChampaignPIX
domain-name mossersshoes.com
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.2.0 Springfield
name 192.168.5.0 Orland
access-list inside_outbound_nat0_acl permit ip any 192.168.1.48 255.255.255.248
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 Springfield 255.255.255.0
access-list inside_access_in remark all traffic
access-list inside_access_in permit ip 192.168.1.0 255.255.255.0 any
access-list inside_access_in permit icmp 192.168.1.0 255.255.255.0 any
access-list outside_access_in permit udp any host 75.16.175.219 eq 6502
access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 Springfield 255.255.255.0
pager lines 24
logging on
icmp permit any outside
icmp permit 192.168.1.0 255.255.255.0 inside
mtu outside 1500
mtu inside 1500
ip address outside 75.16.175.217 255.255.255.248
ip address inside 192.168.1.1 255.255.255.0
ip audit info action drop
ip audit attack action drop
ip local pool Mosser_VPN 192.168.1.50-192.168.1.55
pdm logging debugging 25
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (inside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.168.1.0 255.255.255.0 0 0
static (inside,outside) 75.16.175.218 192.168.1.5 netmask 255.255.255.255 0 0
static (inside,outside) 75.16.175.219 192.168.1.6 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 75.16.175.222 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server RADIUS (inside) host 192.168.1.5 mo$$er timeout 5
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set lan2lan esp-3des esp-sha-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 74.135.32.204
crypto map outside_map 20 set transform-set lan2lan
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 74.135.32.204 netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh 74.134.236.99 255.255.255.255 outside
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication pap
vpdn group PPTP-VPDN-GROUP ppp authentication chap
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto
vpdn group PPTP-VPDN-GROUP client configuration address local Mosser_VPN
vpdn group PPTP-VPDN-GROUP client configuration dns 192.168.1.5 192.168.1.6
vpdn group PPTP-VPDN-GROUP client configuration wins 192.168.1.5 192.168.1.5
vpdn group PPTP-VPDN-GROUP client authentication aaa RADIUS
vpdn group PPTP-VPDN-GROUP client accounting RADIUS
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn username espitzner password *********
vpdn username wgood password *********
vpdn username 21pos1 password *********
vpdn enable outside
dhcpd lease 3600
dhcpd ping_timeout 750
username wgood password xxxxxxxxxxxxxx encrypted privilege 15
terminal width 80
Cryptochecksum:0147ff769308744f828011225da785ea
: end
[OK]



PIX 2
Building configuration...
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxxx encrypted
hostname SpringfieldPIX
domain-name mossersshoes.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.0 Champaign
access-list inside_outbound_nat0_acl permit ip any 192.168.2.208 255.255.255.240
access-list inside_outbound_nat0_acl permit ip 192.168.2.0 255.255.255.0 Champaign 255.255.255.0
access-list outside_cryptomap_20 permit ip 192.168.2.0 255.255.255.0 Champaign 255.255.255.0
access-list inside_access_in permit icmp 192.168.2.0 255.255.255.0 any
access-list inside_access_in permit ip 192.168.2.0 255.255.255.0 any
pager lines 24
logging on
icmp permit any outside
icmp permit 192.168.2.0 255.255.255.0 inside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute retry 4
ip address inside 192.168.2.1 255.255.255.0
ip audit info action drop
ip audit attack action drop
ip local pool temp 192.168.2.200-192.168.2.210
ip local pool temp1 192.168.2.211-192.168.2.220
pdm logging debugging 25
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (inside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.168.2.0 255.255.255.0 0 0
access-group inside_access_in in interface inside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set lantolan esp-3des esp-sha-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 75.16.175.217
crypto map outside_map 20 set transform-set lantolan
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 75.16.175.217 netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet Champaign 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication pap
vpdn group PPTP-VPDN-GROUP ppp authentication chap
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto
vpdn group PPTP-VPDN-GROUP client configuration address local temp1
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username wgood1 password *********
vpdn enable outside
dhcpd address 192.168.2.100-192.168.2.130 inside
dhcpd dns 192.168.1.5 63.240.76.4
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
username wgood password xxxxxxxxxxxxxxxx encrypted privilege 15
terminal width 80
Cryptochecksum:8ab928fa10687520c3f69989f9bda302
: end
[OK]

I have been stuck on this all weekend, running out of time to get fixed, may lose data..... Thanks For the help.
0
Comment
Question by:goodnetworking
  • 2
4 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 18035529
Can you post result of "sho cry ip sa" and "sho cry is sa" from both ends?
Also result of "sho access-list"

Every host on both ends point to their respective PIX inside IP as their default gateway?
You are pinging from end host to end host and not from pix to pix inside IP?

Suggest removing this on both sides. It is default and redundant
 access-group inside_access_in in interface inside

   no access-group inside_access_in in interface inside
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18107847
Are you still working on this? Can you close out this question before the cleanup crew gets around to it?
Thanks!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Using Windows 2008 RRAS, I was able to successfully VPN into the network, but I was having problems restricting my test user from accessing certain things on the network.  I used Google in order to try to find out how to stop people from accessing c…
Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now