Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 534
  • Last Modified:

Accessing SAMBA shares is very very slow.

We had an old P2 server w/ 256MB RAM running Netware 4.11. It shared a folder containg an .exe to a dozen Windows (Windows 2000) machines. The Windows machines mapped the folder and when the person clicked on the .exe it would start the app immediately.

I recently replaced that old Netware machine with a much newer P3 system with 256MB RAM running CentOS 4.4 Linux. I created a share in SAMBA with the proper permissions and set up the Windows workstations to map to it. I put the .exe in a shared folder.

The problem is that when one person from a Windows machine starts the shared .exe it is very slow to start up, taking upwards of 2 minutes to start where as on the Netware box it would start immediately. When all twelve people try to access it, it starts very slowly for some of them and only gets a Windows application error on the other machines.

I have diasbled all uneccesary services on the Linux box to try to free up some memory. I have disabled iptables just in case that was messing with something. I have switched to runlevel 3 so that X and KDE are not hogging memory. Yet still it is as slow as ever to access the share. I then doubled the RAM to 512MB and it is STILL just as slow to access the share.

What am I doing wrong? Why is it so slow? The Netware box served the file up very speedily. But the Linux box, with a way faster processor and now with twice the RAM, serves very slowly.
0
xy8088
Asked:
xy8088
1 Solution
 
nociSoftware EngineerCommented:
This might be network adapter/switch related.
Could you try to do measurements using netio:

http://www.ars.de/ars/ars.nsf/docs/netio

You might have a problem with your interface adapter connected to the
switch/hub. (using 10Mbit or a Full/Half duplex mismatch).

Also try it between workstations.

Upload & download should be stable & equal. If not you might need to adjust
the network settings, using eth-tools or net-tools.

http://sourceforge.net/projects/gkernel/
http://sites.inka.de/lina/linux/NetTools/

If there are differences, set the switch to some known state (Full Duplex f.e.)
and set the linux system accordingly.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now