Solved

File Synchronization between Windows XP  and Buffalo Technology's Tera Station

Posted on 2006-11-27
5
737 Views
Last Modified: 2012-06-21
I had been using Centered Systems Second Copy software to sync&backup files & folders between the server and several PC's. The software works fine when the serve is a windows machine. I replaced the serve with a 2GB Tera Station NFS appliance which is running some flavor of linux/unix. While windows file explorer shows identical date modified & files sizes info, all files are being copied every time even though all attributes appear to be identical. Files with the same date mod atributes should not be copied.

Centered Systems website suggested that there are problems with date/timestamps, and tried the suggested workaround which does not work. All files are copied every time when synchronizing. THis is very time consuming since there are some where around 30,000 files (mostly jpgs) maybe more and several 4 & g GB video files that will get copied every time.

I tried another piece of software called Sync Now! by Liuxz Software. It seems to have the same issues. Is there any software out there that will do what I need done ????  ... or ... Am I doing something wrong with the software that I have. I really don't want to have to give up my new Tera Server ... it's I nice little piece of software.
0
Comment
Question by:blindrookie
  • 3
  • 2
5 Comments
 

Author Comment

by:blindrookie
ID: 18028828
OK I bumped the points ..... someone please help
0
 
LVL 25

Expert Comment

by:kode99
ID: 18030054
Basically this is a linux/unix and windows issue.  File date time stamps on the NAS are not handled the same as on a windows system, there are similar issues with any samba server.

I assume this is what you tried?
http://www.secondcopy.com/kb/article.aspx?id=10169

The best workaround is to use the archive bit.  The windows OS automatically sets an the archive bit when you modify a file.  So when you run the backup you only need to copy files with this bit set.  Also when the files are backed up you need to clear this bit so they are not recopied any more - until changed again.  This way you do not depend on the date time stamp and the whole problem is avoided.

If you look in your profile on the "How?" tab there is a Advanced Properties button.  Hit that and you get some more option, these are the ones you will need to look at -

"Copy only files with archive bit set"
and
"Clear archive bit after copy"

If you set both of these it should take care of your issue.  Though you should run a full copy first that will clear all archive bits and give you a fresh start.
0
 

Author Comment

by:blindrookie
ID: 18038517
I ran a few tests and it works much better but there is still a problem. I made changes to a file on the source and a different file on the destination. The unchanged files were appropriately skipped from the sync process. The destination file that I changed was copied appropriately to the destination. HOWEVER the the file that I changed on the destination was not copied back to the source.

I ran a test trying to sync in the other direction thinking that this might get around the issue, but it copied every thing back to the original source!!!! this could be dangerous. Then when I reran the first sync profile it copied everything back again.... so this is not a potential solution.

Any ideas????

0
 
LVL 25

Accepted Solution

by:
kode99 earned 150 total points
ID: 18038798
Yes one problem is that the unix/linux does not have an archive bit so this is only going to work for saving file to the NAS.  You may be able to use the file date time stamps going from the NAS to windows.

Here's is the Samba settings to help with the whole time stamp issue,
http://www.oreilly.com/catalog/samba/chapter/book/ch08_01.html

I do not know if you have access to make changes to the terrastation setup but if you can this would likely help.
0
 

Author Comment

by:blindrookie
ID: 18042649
I think I got it working mo bettah. I hadn't set up an NTP server on the TeraStation. That in conjunction with the "IgnoreTimeDifference=2" fixed it for all but a 50 files (out of 250,000 +) that continue to be copied. I have no idea what the NTP Server has to do with it but I am happy for now. I think we can close this one out. You helped a lot I think you deserve the points.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Choosing CentOS 16 79
HP VSA on ESXi Best Practice 3 81
deduplication > shared folder size weirdness? 1 40
VMWare & and Storage 10 70
In this article, I provide some information on storage disks which go into calculations that will help you figure out how much Input/output Operations Per Second (IOPS) your disk subsystem can deliver. To effectively size & tune up applications l…
The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

786 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question