• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 415
  • Last Modified:

DCPROMO ruined my day

Greetings experts

Running Windows 2003 Server with SQL 2000  & Analysis Servives 8.0.2039. We had a custom app installed by a consultant and long story short we were forced to DCPROMO the SQL box. Not ideal but it needed to be done.  Anyway ever since the DCPROMO the cusom App hasn't worked.  The app uses IIS6 to disaply pages. This is intalled on the same box.  I was getting errors that were directly addressed in this article

http://support.microsoft.com/kb/332097

I have set the permissions as descibed and those particular errors are not occuring. The app still doesn't work though.  I know you guys can't make it work for me but what pointers can you give me regarding IIS/Analysis Services and not working after a DCPROMO.

Cheers for any leads . . . .

Rob
0
robjeeves
Asked:
robjeeves
  • 4
  • 2
1 Solution
 
AnthonyP9618Commented:
Have you tried reinstalling IIS?
0
 
robjeevesAuthor Commented:
Not yet mate.  I can try that.  Am waiting for the Vendor to suggest some things.  Might need to do your suggestion.

Thanks

will reply back with some more news

Rob
0
 
rhinocerosCommented:
What's kind of custom App ? by ASP ? App should run with local MSSQL2000, rite ?

If true, I think it should be involved the MSSQL access right problem after DCPROMO, not IIS. MSSQL service can be started under default account ? You maybe need to change the MSSQL service startup logon or MSSQL connection (In MSSQL console) by domain account. please check !

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
robjeevesAuthor Commented:
G'day Mr Rhinoceros :)

The App somehow connects to OLAP cubes and displays charts on ASP pages.  The permissions issues are no longer logged for the APS and i've been running Filemon & Regmon and am seeing no failures anymore.

I'm not too familiar with SQL, could you elaborate a little on you instructions for me?  Currently the box is running SQL2000 and that appears to be working ok.  When I look in services.msc none of the SQL services need starting, they seem to be running. In particular could you elaborate on You maybe need to change the MSSQL service startup logon or MSSQL connection (In MSSQL console) by domain account.

thanks for help so far mate.

Rob
0
 
rhinocerosCommented:
Because you will not have local account again on DC after DCPROMO, so what's account can be used to start all MSSQL services.

1. So you should try to go "Administrative tools --> Service --> Log on Tab --> change the logon account as domain administrator" .

2. In MSSQL console --> SQL Server Group --> Servername (properties) --> Logon account by...
0
 
robjeevesAuthor Commented:
G'day

When i checked the services they were local system.  I tried a DA account and the App was still broken.  I ended up reinstalling analysis Services and it fixed it up a treat.

Thanks everyone for their ideas though

Rob
0
 
robjeevesAuthor Commented:
I'll give rhinoceros the points for having such a great name and the fact he was probably along the right lines on things to check.  Just turned out that Reinstall got it working rather than having to fiddle around any more.

Cheers and Happy Xmas to you

Rob
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now