Linux - Group permission for a user not working

Hi ..I use Debian with Samba installed. I have a group called Sales that has full access to a folder called Reports. 10 users are part of this Sales group. It's been working fine for years then sudenly one user from this group is getting a denied access on this Reports folder. I did not change or add any permissions or groups.

Any ideas?

Thank you.
Who is Participating?
AnnieModConnect With a Mentor Commented:
PAQed with points refunded (250)

Cleanup Admin
ibu1System AdministratorCommented:
First remove user from that group and again him to that group
For example I want to remove 'abc' user from the Sales group
# usermod -g abc abc

It will remove abc user from Sales group
Test if the user remove from Sales group
# groups abc

means the primary group for user abc is abc

Than again add the user abc to group Sales
useradd -g Sales abc

ibu1System AdministratorCommented:
#usermod -g Sales abc
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

davidndallasAuthor Commented:
User 'abc' is on a primary group called 'main' .. this gives them a login script. User 'abc' is also a member of 10 other groups.
I took the user out of the Sales groups then added the user back.
Still not working.

davidndallasAuthor Commented:
Any suggestions ??? Anybody????
Please post the output of the following command:

# id abc
davidndallasAuthor Commented:
Here's what I get when I do the "id abc" command:

uid=1356(abc) gid=1060(main) groups=1060(main),1008(sales),1015(dept)

Please post the output of the same 'id' command with another user that you know can access the share.

Please post the output of the command:  ls -ldn /path/to/Reports

Might be helpful to also post the Reports share definition in the /etc/samba/smb.conf file.

Have you tried running 'smbpasswd -e abc' as root?

What version of Samba are you running?
davidndallasAuthor Commented:
Resolved the problem .. the user is on 35 other groups .. when I started deleting her off the other groups, the permissions started working. Looks like I can only go up to 32 groups.

Thanks for everybody's responses.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.