Solved

PIX 501 static route and VPN problem

Posted on 2006-11-27
3
293 Views
Last Modified: 2012-06-21
Hi -

I have set up a pair of PIX 501s and the VPN works fine (site to site and client).   The problem is when I try to setup port redirection to my internal server.  This breaks the VPN.  

I use these commands to get traffic to one of my services on my server:

static (inside,outside) 68.81.177.162 192.168.1.2 netmask 255.255.255.255 0 0
and
conduit permit tcp host 68.81.177.162 eq 6129 any

These work with the VPN (and before I configured the VPN, but the VPN just stops working.  

Any suggestions would be a great help

Here is the configuraiton file minus the above commands:

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname office
domain-name manhn.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.2.0 remote
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 remote 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.1.0 255.255.255.128
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.224
access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 remote 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.0 255.255.255.128
access-list outside_cryptomap_dyn_40 permit ip any 192.168.3.0 255.255.255.224
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 68.81.177.162 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool office-client 192.168.3.10-192.168.3.20 mask 255.255.255.0
pdm location remote 255.255.255.0 outside
pdm location 192.168.1.0 255.255.255.128 outside
pdm location 192.168.3.0 255.255.255.224 outside
pdm location 192.168.1.2 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 68.81.177.1 1
route outside remote 255.255.255.0 68.81.177.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 68.38.195.215
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 68.38.195.215 netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup manhn address-pool office-client
vpngroup manhn idle-time 1800
vpngroup manhn password ********
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.10-192.168.1.20 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:2e84dee126ca358d07b2b55e54ab49aa
: end
0
Comment
Question by:shaboyi
  • 2
3 Comments
 
LVL 1

Accepted Solution

by:
davidecooper1967 earned 500 total points
ID: 18027246
Are you trying to allow access to your inside 192.168.1.2 on port 6129?


static (inside,outside) 68.81.177.162 192.168.1.2 netmask 255.255.255.255 0 0
access-list outside permit tcp any host 68.81.177.162  eq 6129
access-group outside in interface outside

Conduits have pretty much been replaced with Access-lists so stay away from them if you can.

If thats not what you are trying to do let me know.

DC
0
 

Author Comment

by:shaboyi
ID: 18027511
DC - Thanks.  That is exactly what I am tryig to do.  I used the commads you suggested and got the same result - i.e, I was able to get through the firewall to the applicaton on port 6129 (and I assume any other i setup, like www, etc.) after configuring with those commands,  but then VPN no longer works.  I removed those commmands and it worked again.

I also notice that the static (inside, outside) command alone breaks the vpn - I don't even need to put in the access-list commands.  

I am guessing there is some conflict with the two sets of settings?
0
 

Author Comment

by:shaboyi
ID: 18042367
Found a solution.  I put the inbound services on a different IP (static (inside,outside) to another IP).  the VPN is on the original IP.  Works fine.

Would like to know if it can work with just one IP.  
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now