Redhat up2date error

I have Redhat ES V.04 but when do the update by giving the command up2date i get the following message:
 i have activated the the redhat pack .
up2date
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1245, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 693, in main
    up2dateAuth.updateLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 146, in updateLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 86, in login
    server = rpcServer.getServer()
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 191, in getServer
    password=proxyPassword)
  File "/usr/lib/python2.3/site-packages/rhn/rpclib.py", line 149, in __init__
    type = string.lower(type)
  File "/usr/lib64/python2.3/string.py", line 55, in lower
    return s.lower()
AttributeError: 'NoneType' object has no attribute 'lower'

please help me to fix this and get the updates .





D_wathiAsked:
Who is Participating?
 
nociConnect With a Mentor Software EngineerCommented:
Hm, did python get updated recently?
See also:

http://www.physics.drexel.edu/liki/index.php/Up2date-python-fix
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.