Solved

All reports are designed in SQL Server reporting services. Whenever trying to access Report Builder option from report manager, they are getting "Can not retrieve the application. Authentication error

Posted on 2006-11-28
3
770 Views
Last Modified: 2013-12-03
Environment

We are using .NET Framework 2.0. We setup our web application in another domain. All reports are designed in Microsoft SQL Server reporting services and uploaded to report manager. We have given the link to Report manger from our application.

Issue
Whenever users trying to access Report Builder option from report manager, they are getting "Can not retrieve the application. Authentication error".

Trails made to resolve above issue
Trail 1
From the msdn we come to know the error is due to not setting the Anonymous user privilege
for the Report Builder folder in SQL Server Report services.
The URL reference:
<http://msdn2.microsoft.com/en-us/library/ms365173.aspx>
"By default, the ReportBuilder folder inherits the Integrated Windows authentication setting from the parent ReportServer folder. This default setting will not work if the client and server computer are in different domains (or if the client is authenticating the user locally). Users will get HTTP 401 access denied errors and ClickOnce authentication errors such as "Cannot retrieve application" rather than the connection they expect."
We enable Anonymous user access to the report builder folder in SQL Server Reporting services.

Trail 2
Given all we have been talking about was supporting proxy authentication
with default domain credentials, we would only be able to address this case
but not arbitrary credentials for proxy.
A tested, supported workaround is to set useDefaultCredentials to true as
the followings in the machine.config (see relevant documentation for more
details)
Reference URL:
<https://connect.microsoft.com/feedback/viewfeedback.aspx?FeedbackID=115468&wa=wsignin1.0&siteid=210>
A tested, supported workaround is to set useDefaultCredentials to true as the followings in the machine.config (see relevant documentation for more details)
<defaultProxy enabled="true" useDefaultCredentials="true">
We have tried above two work-around. Still its not resolved. Kindly give me solution how to resolve above issue
0
Comment
Question by:pvines
3 Comments
 
LVL 16

Accepted Solution

by:
Hillwaaa earned 125 total points
ID: 18031643
Hi pvines,

I think that you were on the right track using Trail 1.  Except where you said "We enable Anonymous user access to the report builder folder in SQL Server Reporting services" what the msdn link supplied says that you need to do is turn on anonymous access in IIS:

(from the article)
To enable Anonymous access, do the following:

   1. In Internet Manager, expand Web Sites, navigate to and then expand the ReportServer virtual directory.
   2. Right-click Report Builder, and then select Properties.
   3. On the Directory Security tab, in Authentication and access control, click Edit.
   4. Click Enable anonymous access, and then click OK.

Try that, and let us know how you go.

Cheers,
Hillwaaa
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello, In my precious Article  (http://www.experts-exchange.com/Database/Reporting/A_15280-Create-Project-in-Microstrategy-Part-I.html)we saw the Configuration part for Microstrategy which included Metadata Creation and DataSource Preparation as …
I recently went through setting up a JasperReports Server using the AWS EC2 instance, and this article will cover some basic administration tasks I had to perform.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).

896 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now