simple question about http service for fedora core 5

Hey all

I uninstalled apache at one point and then reinstalled, one thing that im missing, is that when you goto Desktop, administration, server settings, you have NFS, Samb and Services, and I used to have HTTP.

Its disapeared and I used to use that for http configuration like virtual servers, how do I put this simple thing back in please?

Who is Participating?

Improve company productivity with a Business Account.Sign Up

ssvlConnect With a Mentor Commented:
Install system-config-httpd package

first check it is installed of not rpm -qa | grep system-config-httpd
if not


# yum install system-config-httpd

or download and install the package
ibu1System AdministratorCommented:
Copy /usr/bin/redhat-config-httpd to Desktop, administration, server settings
Rename redhat-config-httpd to HTTP and under HTTP properties change the icon of ur wish

That's it
ibu1System AdministratorCommented:
That one is wrong
I wil post new comment shortly
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

thechase22Author Commented:
thats not short enough.
thechase22Author Commented:
Yea I just checked that entire folder, and it doesnt seem to have anything like that, im actually on fedora core 5, and I couldnt see anything that resembled that.
run system-config-httpd in GUI is you got the configuration window???
Are you talking about accessing this through icons or through a menu system (Like the Windows Start menu)?

If you mean the menu system then it depends whether you're on Gnome or KDE.

If in KDE then you could for example run kmenuedit, then add system-config-httpd with the name 'HTTP' to the desired subcategory.

If in Gnome, I think you can go to Settings > Menu Editor (Within the menu itself).

Infact, for either GUI you can probably find the Menu Editor within the menu.

Just add the command to run as system-config-httpd - add the name as HTTP - then choose an appropriate icon.
thechase22Author Commented:
Im using Gnome, I have no idea what you meant about settlings and menu editor.

just add the command to run as system-config-httpd - add the name as HTTP - then choose an appropriate icon, where do I do this?

Im on fedora core 5 btw.
thechase22Author Commented:
Ive also just tried to create a new application with the system-config-httpd and that doesnt work either, cant find it or something
Seems like it hasn't reinstalled properly.

I would recommend attempting a reinstall again.

yum remove apache
yum install apache

or possibly

yum update apache
thechase22Author Commented:
Hmm that didnt work either, I tried the yum updater, remove/install.  I even done the add remove software thing, and problem still there, I just right click desktop, create new launcher and put system-config-httpd in as the command.

So is system-config-httpd actually on your machine after the fresh install of Apache?



locate system-config-httpd

Or just go in the console and type:


then hit tab - see if it's on the list.
thechase22Author Commented:
I still am not understanding this

you say type system-config-

It does nothing, and yes I did a fresh install of apache.

I did manage to locate system-config-httpd, and its location is here /etc/alchemist/namespace for what that means.

am I missing something?
thechase22Author Commented:
omg, that worked perfect, I didnt even know it was a program on its own, thanks so much, good old yum :D
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.