Solved

Removing share disconnects user from entire server and other shares

Posted on 2006-11-28
11
565 Views
Last Modified: 2010-05-18
I have a Win 2000 Server.  The server is set up with the following directory structure:

d:\ (security with everyone & authenticated users full control - not shared)
d:\login (security & shared with everyone & authenticated users full control)
d:\shared (security & shared with everyone & authenticated users full control - security on sub folders)
d:\users (security with everyone & authenticated users full control - propegates down - not shared)
d:\users\username (each users is shared as username$ with permission on the share for that user, security is inherited)

The login script is run from \\server2k\login.  The login script maps each user's X drive to \\server2k\shared folder and each user's U drive to \\server2k\username$.

This works fine and has for some time.

I've recently added a Windows 2003 server and am moving the "U drives" (the users personal directory space) to the new server.  To do this, one by one, I've had the users close their mail (address book and pst files on U drive) and any network files.  I copy their username directory from server2k to server2003.  I remove the share on server2k and rename the folder username-moved.  On the server2003 I set up the share to usersname$ and set the permissions as before.  When the login script runs it runs off server2k and then maps the U drive to server2003 since that is where it finds the share.

This has worked for about 40 users.  Howerver, I have 2 users with an unusual problem.  I'm not sure what else to try.  On these two users, the second I unshare the \\server2k\username$ share they get a pop up that they are disconnected from \\server2k.  I'd expect the disconnect from the "U drive" which is mapped to the username$ share, but it also disconnects them from the X drive which is mapped to \\server2k\shared (with everyone and authenticated users full control) and they can no longer access the \\server2k\login share - so they can't run the login script.  I can ping server2k fine from the machine when it is "disconnected".  I can reboot the client machine (XP) and/or reboot the server and cannot attach to \\server2k for these 2 users.  I can log in on the client machine with my account and connect to the server just fine (which tells me it is account related).  If I put the share back on the \\server2k\username$ folder they immediately have access to all the shares on \\server2k.  

WHY does removing one share disconnect them completely from all shares on that server and not let them connect to them at all even after a reboot??  Why is this only happening for 2 of my users.

The user accounts are NT accounts.  We are doing all this moving in preparation tomove the users into Active Directory accounts, but for now I need the NT domain accounts to continue working.  I could try explicitely adding these users to the shares I need them to access, but it shouldn't be necessary since everyone else works fine.  

Any suggestions would be greatly appreciated.  

Julie
0
Comment
Question by:okcuser
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 2

Expert Comment

by:maehdros
ID: 18029289
I would try running "net use" from a command prompt to see all the connections. Then run "net use x: /delete" for all connections. Then logout and login to see how the login script remaps the drives.

You may have a persistent connection or alternate credentials messing things up.

Good luck.
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 18031622
In addition it could be a local corrupted User profile.

I hope this helps !
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18032299
What if you use the FQDN to remap the drive? or \\server2k'sIP\username$ ?

Any change?


Are these 2 users using laptops with Offline files enabled?
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 

Author Comment

by:okcuser
ID: 18037670
I tried deleting her user profile and having it recreated -that didn't fix it.  Also, it is a desktop and not a laptop.  It does come up tring to synchronize files.  Is that something that is enabled?  I haven't tried with the fqdn.  I'll try that.  
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18037818
If it is trying to synchronize files, then I would try and disable Offline Files on the machine. That could be what is flagging the machine as "Unavailable"

Also, in a Run prompt, type

mobsync /logon

and then try and remap the share.....
0
 

Author Comment

by:okcuser
ID: 18039064
OK - If I map using the fqdn it works.  Why?  No one else needs it.  It is something on her machine though because I can log in with my account and have the same problem on her machine.  I checked the settings on the ip and we have it appending the suffix so it should be getting it.

Also, if I remove her network driver and reboot and set it up again then the login script will run (because it connects to the server) and map her drives and then immediately the server gets disconnected.  The only way I can reconnect is putting the share back on her user drive or by removing the network drivers again.

I'm baffled.   We are going to try and find updated drivers for the network card.
0
 
LVL 66

Accepted Solution

by:
johnb6767 earned 500 total points
ID: 18039198
It has nothing to do with drivers, and TCP/IP settings. It is solely an Offline FIles problem. What windows does, when you make a file available offline, is that it flags the server that it resides on as "Offline". Therefore, it does not check to see if that server goes back online, until you reconnect back to teh network. Thats why \\server\share doesnt work, as it knows that the server is offline, and will not try and send NETBios requests to find it. It works with \\IP\share, and \\FQDN\share, because it bypasses NETBios and uses DNS instead. Any other shares on that server will be unreachable while the computer thinks the server is offline....

Try this registry Key...

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache
"SilentForcedAutoReconnect"=dword:00000001

The DWORD Value of 1 forces Windows to transition any offline servers to online, and then can be connected to.....

taken from

Files that you add to the Offline Files folder on a Windows XP-based computer are synchronized when another person uses the computer.
http://support.microsoft.com/?kbid=811660
0
 

Author Comment

by:okcuser
ID: 18039504
That makes sense.  Somehow it is trying to synchronize files to her old "u drive" on the 2k server, but because I removed the share and put it on the 2k3 server it is seeing it as offline and therefore the entire server as disconnected.  After I install the network again it works for the initial connection and mapping, but then it is probably trying to synchronize and can't find the old share so it disconnects???  She is in a meeting so I'll have to try it out after a while or in the morning.  I'll let you know.

Thanks for your help.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18039546
How to re-initialize the offline files cache and database
http://support.microsoft.com/kb/230738

That should start the offline database from scratch.....

The shares to be synched are located here in the registry,....

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Netcache\Shares

You can simply delete any outdated items as well....
0
 

Author Comment

by:okcuser
ID: 18039859
That worked.  I turned off the offline files,  ran the mobsync and added the netchache registry key.  When I rebooted she connected with no errors.  

What I don't know is which thing fixed it.  I'll try your last suggestion on the other machine that is having problems.  We are in a winter storm warning and I don't feel like walking across the street to check it right now.  

Thanks for all your help!  
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18039934
NP....The reg key should have been the standalone fix......
0

Featured Post

Does Your Cloud Backup Use Blockchain Technology?

Blockchain technology has already revolutionized finance thanks to Bitcoin. Now it's disrupting other areas, including the realm of data protection. Learn how blockchain is now being used to authenticate backup files and keep them safe from hackers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
The recent Petya-like ransomware attack served a big blow to hundreds of banks, corporations and government offices The Acronis blog takes a closer look at this damaging worm to see what’s behind it – and offers up tips on how you can safeguard your…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question