Solved

can't boot past Advanced Options Menu

Posted on 2006-11-28
20
735 Views
Last Modified: 2012-06-27
I'm working on a Windows XP Media Center PC. Children in the house it came from pressed some strange group of keys and now it boots to the Windows Advanced Options Menu, but no matter which option you select, it simply reboots.

It's a newer computer and the HDD is SATA. None of the other boxes around the office have SATA cables available to put HDD into to get the data off of it.

I tried putting an IDE drive into the machine and booting from that to get at the data on the SATA HDD, but even disconnecting all other drives (CD, DVD, SATA HDD) I can't boot the other HDD (the IDE one) - I'm getting the same problem (stuck at WAO menu).

So I'm thinking it's something in the BIOS, but I've scoured it and come up with nothing.

Please help!!!
0
Comment
Question by:prismnetwork
  • 9
  • 6
  • 3
  • +2
20 Comments
 
LVL 69

Expert Comment

by:Merete
ID: 18032272
Do you have the recovery disc that came with it?
But I think at this point your main concern is to save the data before commencing to "fix" so to speak.
As this is a sata hss, what brand?
You can but what is called external enclosures, you take your sata hdd stick it inot the external enclosure and then use that to slave it to an ide connector.

To put you in the picture of external enclosures
you want something like serial sata to ide
http://www.directron.com/35sata.html
>>
http://www.directron.com/externalhd.html
check your locall computer shop, take out the sata hdd and take it with you.

Now the fix, firstly does the hdd spin at all? Is regestered and activated okay if the windows genuine advantgae is not installed coudl be part of the problem.

What is the brand of the hdd so we can run a hdd diagnostic onit, if the hdd is dead??
How old is it?
Media center has a non destructive recovey option but you need the recovery disc to access this.
What windows is onboard Media center or has there been another windows installed?
Need more details as there is different methods of repair and one could render the system if nto correctly and using the correct xp disc.

Windows XP Media Center Edition 2004 - Recovery Procedure
http://www.fujitsu-siemens.co.uk/rl/servicesupport/techsupport/Consumer/MediaCenter/FAQ/MC_RecoveryProcedure.htm

Merete



0
 

Author Comment

by:prismnetwork
ID: 18032329
PC is a Gateway model 838GM
Intel Pentium 4 Processor 630 (3.0 GHz)
512 MB dual channel DDR ram
on the motherboard is printed Intel E210882
HDD is SATA Seagate 7200.7 (200GB)
O/S is Windows XP Media Center Edition 2005

I don't have any CDs for it at the moment, but have requested them from the owner of the PC.  Not sure if they're available or not yet.

The HDD sounds like it's spinning up, so I know it's getting power.

I'm guessing the box is a year or so old.

Not sure how to run a HDD diagnostic without being able to boot - unless the diagnostic software can be burned to a bootable CD?

Thanks.
0
 
LVL 3

Expert Comment

by:MarkWYnne
ID: 18032492
Probably not the cause but have you tried a different keyboard?
 It is odd that you boot froma totally new disk and have the same issue, was this a fresh install on the IDE?
0
 
LVL 69

Assisted Solution

by:Merete
Merete earned 150 total points
ID: 18033451
SeaTools Diagnostic Suite is Seagate's exclusive disc drive diagnostic software designed to troubleshoot most Seagate hard drive issues. Desktop edition works with most ATA, SATA, or SCSI drives in desktop systems and has a 98% accuracy rate.

- Download SeaTools Desktop Edition v3.02.03en (English | 05.19.2005)
http://www.seagate.com/support/seatools/seatoold_reg.html

English (v3.02.04en)    
    Floppy Diskette Creator  http://www.seagate.com/support/disc/download/seatoold_en.exe
    ISO CD-ROM Image  http://www.seagate.com/support/disc/download/SEATOOLD_EN.ISO

Gateway 838GM Media Center - P4 630 3 GHz specifications
http://reviews.cnet.com/Gateway_838GM_Media_Center_P4_630_3_GHz/4507-3118_7-31576776.html?tag=sub
======================================================================================
yes the OS provided Microsoft Windows XP Media Center Edition 2005  so I am not 100% sure you can use a normal windowsxp cd to run a chkdsk /r

How To Install Drivers and Software
Gateway System Recovery Windows XP
http://support.gateway.com/s/SOFTWARE/Medialess/MLXPMC0/MLXPMC0sl.shtml

good Luck
Merete



0
 
LVL 1

Accepted Solution

by:
oneyg earned 350 total points
ID: 18034735
I think the problem will be a stop error 'UNMOUNTABLE BOOT VOLUME', but you can not see because your PC is configured to restart on failure. To see this error, when PC boots press F8 to get to the advanced option menu (without pressing f8, the following option will not be seen), then choose tho option 'disable automatic restart after failure'. There you will see this stop error on a blue screen.

To resolve this you need to have Windows XP bootable CD, and start with it, then at the first setup screen option choose to repair (Pressing R), if the administrator account has a password you will be asked to provide, and when you get to the command prompt, type 'chkdsk'.


Good luck


Oney G
0
 

Author Comment

by:prismnetwork
ID: 18036631
Thank you all for your suggestions.  Let me try some of them and get back to you.  I'll try oneyg's suggestion first since it's a quick one.  Then on to Merete - I appreciate the complete set of tools provided - very helpful.

To MarkWynn - it's not a KB issue - same problem with orignal KB and the one I'm using here; also the IDE HDD I tried has Windows 2000 and was working great in the computer I pulled it from - it has very little on it other than the O/S - it was a recent fresh install for another project that got put on hold.
0
 

Author Comment

by:prismnetwork
ID: 18036973
Oneyg - you're good!  Sure enough I got that stop error you described.  I'm going to try to recover/backup the data on the drive first - then I'll get into repairing the O/S.  Between here and the other techs I've been working with, I think I have the tools to get at the data, but I may need a bit more help if I can't get the CDs that came with the PC.

I'll keep you all posted and will award points accordingly once the situation is resolved.

Thanks.
0
 
LVL 69

Expert Comment

by:Merete
ID: 18042082
great :) yes if those cd woul djust hurry up and arrive then you can progress with chkdsk /r or fix the boot.
You could use an xpcd to rebuild the boot config but i am not sure if a normal xpcd will let you do this.

  Boot from a Windows XP CD.

    2.       At the next screen press "R" to repair using the Recovery Console.

    3.       Press the number correlated with the Windows installation you want to fix. Typically this will be #1.

    4.       In the Administrator password press [ENTER] if you have not set a password for it.

    5.       Type bootcfg /list to see all the entries in the boot.ini file.

    You could get the message:

    “There are currently no boot entries available to display”

    6.       Type bootcfg /rebuild to fix it.

    You will be prompted to answer the question

    “Add installation to boot list (Yes/No/All)” press “Y”

    7.       Under “Enter Load Identifier:” type the name of your operating system (i.e. Microsoft Windows XP Home Edition).

    8.       For “Enter OS Load Options:” usually the value is “/fastdetect” (without quotation marks).

    9.       Take out the Windows XP CD and type exit.

0
 
LVL 9

Expert Comment

by:PeterMac
ID: 18046570
Not sure problem is not still in Bios Setup. - Especially as you were getting same error on another HD. Unmountable error can be due to HD corruption, but can also be due to inability to handle type of HD installed.

Check Bios again, not familiar with your System, but there is probably option re large disk support - make sure this is enabled, and check any other HD options relating to type of HD installed.
0
 

Author Comment

by:prismnetwork
ID: 18047021
I checked all the options in the BIOS and can't find anything.  I too was thinking it was something in the BIOS because the computer responded with the same blue screen for the original SATA HDD, as well as a newly formatted IDE HDD - set it up in another computer - only thing on it is W2K, SP3).

I can't just run the repair because I don't have a true XP CD.  The CDs that go with the computer did arrive, but it's a Gateway recovery disk that clearly states rigt on the CD that it will wipe out all data on the hadr drive if I use it.  

So I'm trying to recover the data from it before I go any further.  I was able to boot from a bootable Linux CD that another tech helped me create.  So now I can see it, but I can't seem to copy it anywhere - tried connecting that other HDD I mentioned (the IDE one with just the O/S on it) and I can view that one as well, but I don't seem to be able to write to it.

The other thing that concerned me is that the original SATA disk, when I tried to view it, returned a prompt about it being "dirty".  I know very little about Linux.  The disk I'm using is Knoppix 5.0, single CD version.  I created the CD okay and the computer will boot from it, but I'm not too sure what I'm doing in that O/S.

Any suggestions that will help me get that data are greatly appreciated.  I do have a spare IDE drive (unformatted) that's the same size as the SATA in this box.  And I have a copy of Ghost 2003 - maybe I could ghost the HDD?  Concerns with this are that the SATA disk is coming up as "dirty" and that I'm not entirely sure how to do the ghosting.  It's been several years since I've used ghost and when I did it was from a floppy.  This computer doesn't even have a floppy drive (but I could install on e if necessary).

While I'm waiting for the next post, I'll start going through the Ghost documentation.  But I'm still worried about that SATA disk having a bad status.  And I'll look through the BIOS again.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 9

Expert Comment

by:PeterMac
ID: 18047309
Sorry cant help with knoppix, never used it myself, but you should be able to get plenty of help from others.
One suggestion you could try without really risking anything is to install your spare IDE drive, and run Gateway recovery CD to that - if it really is spare disk recovery has nothing to "wipe out". If it works you then have running system to try and access SATA drive.

PS "dirty" just means system was not shut down cleanly, and disk should be checked - you already knew that.
0
 

Author Comment

by:prismnetwork
ID: 18049820
OK, so I got Windows reinstalled on the spare drive and that drive is at least working.  If you'll recall, I was getting that same BSOD error with the spare IDE drive as I was with the original SATA HDD.  So I tried repairing the IDE with the Windows CD I had used to install the O/S - the repair didn't work - which concerns me because repair is what I'm supposed to ultimately do with the SATA drive.  So I reformatted and reinstalled Windows on the IDE drive and got that bootable again (in a different PC than the "broken" one).

Then I tried connecting the SATA into the box that the working IDE drive was in so I could copy the data from it - well Windows just balked at it - tried having it connected at boot time - Windows hung on boot; tried disconnecting it until Windows booted and then plugging it back in and Windows froze - seems it can't get through the new hardware automated wizard.

So, back to the bootable Linux CD and both drives in the original box to copy data files.  Lo & behold... there appears to be some weird limit on copying files to the IDE drive - can't seem to have more than 8 sub folders in a folder!  There's a massive slew of files I need to copy - I can see them all, but I just can't copy them!!!

Not sure whether to cry, scream, or laugh insanely at this point.  Any suggestions to copy the data off of the sata onto ANY other media would be greatly appreciated - bear in mind that the only way I seem to be able to boot the computer is with a bootable CD.

Here are the pieces/parts I'm working with:  1 IDE port, 1 CD-ROM drive, 1 DVD+/-R/CD-RW combo drive, 4 SATA ports, 1 SATA HDD (where the data is that I need to capture), 1 IDE HDD (this is a spare with Win2000 SP4 on it and nothing else other than the few files I've been able to capture so far), spare box with SATA connectors on the MoBo and found a power supply with SATA connectors too, Linux Knoppix 5.0 bootable operating system CD (whole O/S runs from the CD), Seagate Diagnostic Tools bootable CD (quick scan of the SATA HDD reports errors).

Any help greatly appreciated - getting those files is top priority.
0
 
LVL 9

Expert Comment

by:PeterMac
ID: 18053055
Clutching at straws now...     Cant help with copying, assume limitation is something to do with Knoppix system.

Still dont understand why having such problems booting from IDE drive on both systems, If you can see SATA drive from Linux, and copy files off of it, then essentially drive is working. Only thing this leaves is drivers.

Have you tried installing SATA drivers on IDE drive, believe that while SATA drive itself does not require special drivers, SATA controllers on motherboard often do. Bad, or no drivers could be responsible for hangs at Boot time, on both systems.

Normally SATA drivers would be installed as part of initial OS load (To SATA Drive), press F6 to load special drivers, but assume can be added later when install was to standard IDE. You will need to track down drivers for the two motherboards you are using. Link below may help with Gateway, you have not said what other system is...

ftp://download.intel.com/support/motherboards/desktop/d865glc/BFLC_English.pdf

0
 

Author Comment

by:prismnetwork
ID: 18089109
FINALLY!!! Progress...

Based on an article I found online (http://pcworld.about.com/magazine/2111p196id112479.htm)
and a little help from a different EE thread (http://www.experts-exchange.com/Operating_Systems/Q_21208463.html?qid=21208463)
I managed to create these Windows XP Pro SP2 boot floppies (Win XP Media Center 2005 has essentially the same core as Win XP Pro SP2) - the program to create them is a free download from Microsoft (http://support.microsoft.com/kb/310994) (requires 6 formatted floppies - I used DOS to format them)

Then I tried using the repair feature in the installation (not the recovery console - go through like you're doing a fresh install and then choose to repair an existing installation).  But it prompted for the O/S CD and I couldn't get past that (don't have O/S CD, just a Gateway recovery CD that would wipe everything out).

So then I did try the recovery console option and used chkdsk /r - it took forever to run and kept starting back at 50% after it reached 75% - but then finally it finished.  I also did a fixboot and fixmbr.

Then I tried booting into Safe Mode - success!  I also ran a defrag on the computer.

Then came the big test... a normal boot... success!  So now I'm trying to backup the computer using Windows backup.  It's not going well, I think because there is some corruption on the HDD.  The first corruption was in Favorites, so I opened IE and exported them.  Then I went to the Favorites folder through windows explorer and deleted all the files.  That got the backup past that part.  Now it's stuck in the registry - I'm not happy about this part.

That's as far as I've gotten.  Although the tools I ended up using came from other places, you all were very helpful and I will be awarding points once this whole mess is resolved.  Thanks again all.  Without you I probably wouldn't have ended up on the research path I went down.  
0
 

Author Comment

by:prismnetwork
ID: 18089159
Oh yeah, and before I used the boot floppies, I ran Seagate's disk utilities to scan and repair the HDD. (created the bootable CD from a download from Seagate's website).
0
 
LVL 69

Expert Comment

by:Merete
ID: 18090200
there is another solution, not to steer you away from all this awsome effort,
but you can slave the hdd/s using a 2.5 or 3.5  ide to pc connector,
http://www.bay-wolf.com/hddadapter.htm
take them out of the laptop plug them into ide on cdrom on another desktop, just unpower pull out the power cable to ensure no discharge when handling the hdd.
That desktop will detect your hdd as slave instead of the cdrom.
If you need sata ide there are external enclosures.
http://www.dealsonic.com/25usb20.html
There ya go now I have disturbed your train of thought :)
But its worth a shot to save off everything then you can simply delete partitions or whatever clean install.
And then you'll have them for the future.

0
 

Author Comment

by:prismnetwork
ID: 18093067
Merete - slaving the Gateway's HDD into another computer is something I tried fairly early on in the process and was unsuccessful (although this method has worked for other unbootable HDDs in the past for me).  (See my comment - Date: 11/30/2006 03:08PM PST)

The Gateway will now boot into Windows normally.  I'm having trouble doing a Windows backup though - there seems to be some data corruption.  I'll see how I fair trying to work around each point of corruption to backup as much as possible.  I'm expecting that even though the computer will boot and appears normal, there will be many problems with it going forward.
0
 
LVL 69

Expert Comment

by:Merete
ID: 18098743
sorry I must have missed those details gee I must pay more attention.
Let us know how you go and what problems you encounter.
cheers Merete
0
 

Author Comment

by:prismnetwork
ID: 18118481
Well, I'm about as far as I can go with this computer.  I managed to get the Windows backup to complete for just the documents, favorites, and desktops of each of the users.  But the system state and registry files are damaged, so the complete backup won't finish.  Then came the problem of getting the backup from the HDD to a DVD.  9GB doesn't fit on a 4.7 GB DVD and the version of Nero on the PC doesn't support spanning.  So I found a utility that wraps itself around windows backup and allows you to run the backup straight to DVD and prompts for each new disk as its needed (yeah - spanning!).  It's called FireStreamer (or something like that - there's a free trial version of it available online).  So I got the DVDs off to the owner and tried using a free registry repair tool to repair the registry so I could get the complete backup to run.  I used Registry Mechanic 6 - also available as a trial.  But the trial didn't fix all of the errors - would have needed to buy the full version for that (supposedly).

So the computer boots and as far as I can tell, I can open all the data.   But I know based on the Seagate scan, chkdsk scan, and inability to run a complete backup that there is corruption on the HDD (guessing some combo of physical and data).  So now I'm just waiting to see if a new HDD is coming in for it that I need to format and install or if I'm returning the box in its current state.

Thank you all for your help.  I'm awarding points/grade as follows:
* oneyg 11/28 10:18pm - this was the post that came closest to the problem and what had to be done to get the computer booted - will receive most points
* merete 11/28 5:14pm - this post was also very helpful, as were some of your others, so it will also receive some points
* as far as data recovery, I had to use other forums and my own research for this (a considerable amount) – hence the B grade – info provided was great, just not enough of it

Thanks again!
0
 
LVL 69

Expert Comment

by:Merete
ID: 18118620
thank you prismnetwork  big effort on yoru behalf, I wish well.
Regards M
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Introduction How to create multiboot configuration with XP\Vista and Windows 7 on it? And most important question - how to do this correctly so not to have any kind of nightmares we get when system gets screwed? First of all one should realize t…
Many people tend to confuse the function of a virus with the one of adware, this misunderstanding of the basic of what each software is and how it operates causes users and organizations to take the wrong security measures that would protect them ag…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now